1. rujiy_kot 4 16.05.19 18:58 Сейчас в теме +2 $m

Добавить поля в выгрузку из СБИСа

Есть обработка СБИСа.
Выгрузка реализаций и счетов-фактур настроена.
Контрагенту необходимо добавить поля в выгрузку накладной:
- номер заказа (определяется по основанию (сделке)),
- отсрочка платежа (поле с фиксированным текстом),
- штрих-код (для табличной части, определяется по номенклатуре).
(Такие требования у Призмы)
По сообщениям в интернете обработку менять нельзя. Всё необходимо сделать настройками через ini-файлы, без изменения обработки СБИСа.
Делал по инструкции:
http://wiki.razgovorov.ru/index.php/Настройка_внешней_обработки_СБИС_для_1С_8.х
Добавил новый ini-файл без постфикса sbis, для документа "Реализации товаров и услуг", настройки СБИСа показывает, что настройки реализации изменены, но при выгрузке Реализации в файл формируется два документа в формате xml (накладная и СФ), но каждый раз никаких изменений.
Как я только не пробовал писать, делал по аналогии с примерами (выше по ссылке), но подобные изменения никак не влияют на выходной файл.
Я не понимаю, что делаю не так...
<?xml version="1.0" encoding="utf-8"?>
<ини>
<мФайл Имя="ЭДОНакл">
<мТаблДок Имя="Товары">
<СуммаНДС>11111</СуммаНДС>
</мТаблДок>
</мФайл>
</ини>
Вознаграждение за ответ
Показать полностью
Найденные решения
5. rujiy_kot 4 20.05.19 08:51 Сейчас в теме
Кому интересно или кто случайно найдёт по поиску эту тёму.
Вот код XML файла ВО82УТ10_РеализацияТоваровУслуг.XML
<?xml version="1.0" encoding="utf-8"?>
<ини>
    <мФайл Имя="ЭДОНакл">
	<мПараметр Имя="Заказ">
		<Параметр_Имя>'Заказ'</Параметр_Имя>
		<Параметр_Значение>[Документ].сбисНомерЗаявки</Параметр_Значение>
	</мПараметр>
	<мПараметр Имя="Отсрочка">
		<Параметр_Имя>'Отсрочка'</Параметр_Имя>
		<Параметр_Значение>'K010'</Параметр_Значение>
	</мПараметр>
	<мТаблДок Имя="Товары">
            	<мПараметр Имя="Штрихкод">
                	<Параметр_Имя>'Штрих-код'</Параметр_Имя>
	                <Параметр_Значение>{сбисПолучитьШтрихКод()}</Параметр_Значение>
 		</мПараметр>
        </мТаблДок>
    </мФайл>
</ини>
Показать


Вот код обработки: ВнешниеФункции_Клиент, формы: РаботаСДокументами1С

Функция сбисПолучитьШтрихКод(Контекст) Экспорт
	
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	               |	Штрихкоды.Штрихкод
	               |ИЗ
	               |	РегистрСведений.Штрихкоды КАК Штрихкоды
	               |ГДЕ
	               |	Штрихкоды.Владелец = &Владелец
	               |	И Штрихкоды.ЕдиницаИзмерения = &ЕдиницаИзмерения";
	Запрос.УстановитьПараметр("Владелец",Контекст.Номенклатура);
	Запрос.УстановитьПараметр("ЕдиницаИзмерения",Контекст.ЕдИзмНоменклатуры);
	
	Результат = Запрос.Выполнить().Выбрать();
	
	Если Результат.Следующий() Тогда
		Возврат Результат.Штрихкод;
	Иначе
		Сообщить("По номенклатуре: " + Контекст.Номенклатура + " и единице измерения: " + Контекст.ЕдИзмНоменклатуры + " не найден Штрих-код! В файл ШК не выгружен");
		Возврат "";	
	КонецЕсли;	
	
КонецФункции
Показать

Оба файла нужно положить в каталог со сбисом.
Остальные ответы
Избранное Подписка Сортировка: Древо
2. uriah 16.05.19 21:20 Сейчас в теме
Какая платформа, конфигурация, релиз, стандартная или переписанная? Мало данных!
3. rujiy_kot 4 17.05.19 08:44 Сейчас в теме
(2) сверху в тегах - "1С:Управление торговлей 10", в сообщение действительно не написал.
УТ 10.3.
Но обработка СБИСа уже сама адаптируется к конфигурации. Важно понимать как править эти ini-файлы.
4. Sergio_S11 17.05.19 16:38 Сейчас в теме
(3) А в обработке ВнешниеФункции_Клиент ты свой ini подцепил?
My Webpage
6. rujiy_kot 4 20.05.19 08:57 Сейчас в теме
(4) А Вы автор этого вики?
Нет, не подцеплял, решение нашёл методом проб и ошибок.
Из моих ошибок было - значения нужно писать в одинарных кавычках - '.
Новые поля нужно было писать через: мПараметр, его имя и значения.
5. rujiy_kot 4 20.05.19 08:51 Сейчас в теме
Кому интересно или кто случайно найдёт по поиску эту тёму.
Вот код XML файла ВО82УТ10_РеализацияТоваровУслуг.XML
<?xml version="1.0" encoding="utf-8"?>
<ини>
    <мФайл Имя="ЭДОНакл">
	<мПараметр Имя="Заказ">
		<Параметр_Имя>'Заказ'</Параметр_Имя>
		<Параметр_Значение>[Документ].сбисНомерЗаявки</Параметр_Значение>
	</мПараметр>
	<мПараметр Имя="Отсрочка">
		<Параметр_Имя>'Отсрочка'</Параметр_Имя>
		<Параметр_Значение>'K010'</Параметр_Значение>
	</мПараметр>
	<мТаблДок Имя="Товары">
            	<мПараметр Имя="Штрихкод">
                	<Параметр_Имя>'Штрих-код'</Параметр_Имя>
	                <Параметр_Значение>{сбисПолучитьШтрихКод()}</Параметр_Значение>
 		</мПараметр>
        </мТаблДок>
    </мФайл>
</ини>
Показать


Вот код обработки: ВнешниеФункции_Клиент, формы: РаботаСДокументами1С

Функция сбисПолучитьШтрихКод(Контекст) Экспорт
	
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	               |	Штрихкоды.Штрихкод
	               |ИЗ
	               |	РегистрСведений.Штрихкоды КАК Штрихкоды
	               |ГДЕ
	               |	Штрихкоды.Владелец = &Владелец
	               |	И Штрихкоды.ЕдиницаИзмерения = &ЕдиницаИзмерения";
	Запрос.УстановитьПараметр("Владелец",Контекст.Номенклатура);
	Запрос.УстановитьПараметр("ЕдиницаИзмерения",Контекст.ЕдИзмНоменклатуры);
	
	Результат = Запрос.Выполнить().Выбрать();
	
	Если Результат.Следующий() Тогда
		Возврат Результат.Штрихкод;
	Иначе
		Сообщить("По номенклатуре: " + Контекст.Номенклатура + " и единице измерения: " + Контекст.ЕдИзмНоменклатуры + " не найден Штрих-код! В файл ШК не выгружен");
		Возврат "";	
	КонецЕсли;	
	
КонецФункции
Показать

Оба файла нужно положить в каталог со сбисом.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата до 120 000 руб.
Полный день

Работа от Инфостарт
Санкт-Петербург
Временный (на проект)

Руководитель отдела внедрения 1С
Новосибирск
зарплата от 60 000 руб. до 160 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 115 000 руб. до 160 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день