INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Шишкина Ирина | Консультант, PM | Студия креативного консалтинга Не просто ИДЕЯ

«Эмоциональный интеллект в управлении ИТ-командами»

- Эмоциональный интеллект - почему это сейчас так важно? Обзор сложностей управления ИТ-командами - Грядущий кризис по Гоулману: "коэффициент умственного развития все выше, а коэффициент эмоционального развития все хуже" - Умение владеть собой для ИТ-Директора. Риски для команды, связанные с низким эмоциональным интеллектом руководителя. Инструмент для оценки своих эмоций. - Эмпатия ИТ-Директора: влияние на стейкхолдеров проекта - "Ненастроенный программист" или как определить уровень эмоционального интеллекта команды. Простые инструменты - как понять, что движет командой?

1. IrinaBasova 09.08.18 11:14 Сейчас в теме

Помогите разобраться с установкой com соединения.

Добрый день. Необходимо установить com соединение одной базы с другой на платформе 83. У меня все работает в файловой базе. Необходимо настроить обмен на серверном варианте. Не выходит (пишет про отказ доступа к папке с базой хотя доступ к ней есть) Пытаюсь выполнить соединение на файловых базах расположенных на сервере 1с. COM объект создается, но отсутствует метод Cоnnect, из-за этого вываливается ошибка.
Попытка
		
		//#Если Клиент Тогда
		//Состояние("Идет процесс соединения ...");
		//#КонецЕсли
	
		ОбъектПодключения = ОбъектПодключения +".COMConnector";
		
		Попытка
			ТекCOMПодключение = Новый COMОбъект(ОбъектПодключения);
		Исключение
			Сообщить("Ошибка создания объекта "+ОбъектПодключения+" !") ;
			Сообщить( ОписаниеОшибки()  ) ;
		КонецПопытки;

		
		ТекCOMОбъект = ТекCOMПодключение.Connect(СтрокаПодключения);
					
		//#Если Клиент Тогда
		//Состояние("Соединение установлено");
		//#КонецЕсли		
			
	Исключение
		
		СтрокаСообщенияОбОшибке = "При попытке соедиения с COM-сервером произошла следующая ошибка:" + Символы.ПС 
						+ ОписаниеОшибки();
Показать
Ответы
Сортировка: Древо
2. IrinaBasova 09.08.18 11:19 Сейчас в теме
(1)Win 64, В качестве ОбъектПодключения использую v83.ComConnector -тоже самое и если поменять на v83.ComConnector.1 (в службах компонентов ).
4. IrinaBasova 09.08.18 11:21 Сейчас в теме
(2)ничего не меняется. В компоненте v83.ComConnector не доступна галочка на роли CreatorOwner (т.е. не могу установить эту галочку), читала что это важно.
17. Doreng 6 09.08.18 11:57 Сейчас в теме
(1)
Функция ПодключитьсяКБазе()
СоединениеСБазой = Новый COMObject("V83.COMConnector");
ПараметрыДоступа = "Srvr=""ВашСервер"";Ref=""ВашаБаза"";Usr=""Пользователь"";Pwd=""Пароль"";";
Попытка
База = СоединениеСБазой.Connect(ПараметрыДоступа);
Возврат База;
Исключение
Возврат ОписаниеОшибки();
КонецПопытки;	
КонецФункции
Показать
3. VmvLer 09.08.18 11:21 Сейчас в теме
1. ОбъектПодключения - расшифровать,
2. текст ошибки полностью

и понимать, что в клиент-серверном варианте никакой папки с базой быть не может.

пока 1-2 нет, играем в "ежика в тумане"
5. IrinaBasova 09.08.18 11:23 Сейчас в теме
(3)папки с базой это ясно что быть не может, т.к. в серверном варианте не взлетело, пробую в файловом, но на нужном сервере(тестово)
6. IrinaBasova 09.08.18 11:25 Сейчас в теме
(3)
 При попытке соедиения с COM-сервером произошла следующая ошибка:
{ОбщийМодуль.ЦЗС_ОбщегоНазначения.Модуль(81)}: Ошибка при вызове метода контекста (Connect): Произошла исключительная ситуация (V83.COMConnector.1): {МодульВнешнегоСоединения(13)}: Ошибка при вызове конструктора (ComОбъект)
7. IrinaBasova 09.08.18 11:28 Сейчас в теме
(3)Объект подключение расшифровала выше
8. Denis_CFO 12 09.08.18 11:42 Сейчас в теме
(7) Вот точно рабочий код (только что проверял) из файловой подключался к серверной:
Функция СоединениеСВнешнейБазой()
	Параметры = "Srvr=server2008;Ref=ZIK;Usr=БС;Pwd="";";
	СисИнфо = Новый СистемнаяИнформация;
	ВерсияПлатформы = Лев(СтрЗаменить(СисИнфо.ВерсияПриложения, ".", ""), 2);
	V8COMConnector= Новый COMОбъект("V" + ВерсияПлатформы + ".COMConnector"); 
	Попытка 
		Base1С = V8COMConnector.Connect(Параметры);
		Возврат Base1С;
	Исключение
		Сообщить(ОписаниеОшибки());
	КонецПопытки;
КонецФункции
Показать

Платформа: 1С:Предприятие 8.3 (8.3.11.2528)
9. VmvLer 09.08.18 11:45 Сейчас в теме
Если вместо

СтрокаСообщенияОбОшибке = "При попытке соедиения с COM-сервером произошла следующая ошибка:" + Символы.ПС 
                        + ОписаниеОшибки()

использовать

Информация = ИнформацияОбОшибке();
СтрокаСообщенияОбОшибке = "При попытке соедиения с COM-сервером произошла следующая ошибка:" + Символы.ПС 
                        + ПодробноеПредставлениеОшибки(Информация)


добудем ли мы какую-нить более ценную информацию об ошибке?

если нет то можно глобальным поиском по типовой конфигурации по тегу "COMConnector" найти вагон и тележку стандартных
способов соединения

если и это не поможет, то копать системные права пользователя под которым на сервере работают "сомы".
10. Aitbay 09.08.18 11:46 Сейчас в теме
1. проверить регистрацию библиотеки comcntr.dll
если винда 64битная то регить из папки syswow64 с указанием полного пути.
2. проблема с подключением иногда вылетает из за того что на сервере стоит взломанная платформа.
11. Denis_CFO 12 09.08.18 11:48 Сейчас в теме
(10)
проблема с подключением иногда вылетает из за того что на сервере стоит взломанная платформа
не знал, но за совет спасибо, а пруф есть или опытным путём?
13. Aitbay 09.08.18 11:49 Сейчас в теме
12. IrinaBasova 09.08.18 11:49 Сейчас в теме
15. Aitbay 09.08.18 11:54 Сейчас в теме
(12) тогда сначала запускаем командную строку от администратора
пишем regsvr32 comcntr.dll -u
потом
cd c:\windows\system32\syswow\
regsvr32 c:\progra~2\1cv8\номерПлатформы\bin\comcntr.dll
если платформа 64битная тогда
regsvr32 c:\progra~1\1cv8\номерПлатформы\bin\comcntr.dll
16. Denis_CFO 12 09.08.18 11:56 Сейчас в теме
+ (15) либо запустите 1С от имени администратора, так тоже срабатывает.
14. IrinaBasova 09.08.18 11:53 Сейчас в теме
(10)через службы компонентов или из ком. строки
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Удаленный ИТ-журналист
Санкт-Петербург
По совместительству

Удаленный бизнес-аналитик 1С
Санкт-Петербург
Временный (на проект)

Программист 1С
Москва
Полный день

Консультант-аналитик 1С
Санкт-Петербург
зарплата от 80 000 руб.
Полный день

Аналитик 1С
Москва
зарплата от 80 000 руб. до 120 000 руб.
Полный день