0. Alex_E 1881 09.07.16 12:16 Сейчас в теме

Конструктор внешних печатных форм NEW beta (обычные и управляемые приложения!)

Исходная обработка http://infostart.ru/public/162019/, здесь просто исправлены некоторые процедуры и функции для управляемого приложения. (Публикуется с согласия автора SeiOkami)
12.07.2016 - Версия 4.3 - убрал модальность для управляемой формы, изменена встроенная ВПФ .
23.11.2016 - Версия 4.4 - изменена встроенная ВПФ .
03.04.2018 - Версия 4.7 - исправлено сохранение ВПФ в клиент-серверном варианте от vshish.
11.05.2018 - Версия 4.8 - исправление от VovkaPutin плюс убрал из текста модуля ВПФ директивы препроцессора (то, что начинается с "#"), убрал модальность при открытии ВПФ из конструктора.

Перейти к публикации

Вознаграждение за ответ
Показать полностью
Комментарии
Избранное Подписка Сортировка: Древо
1. progr-2008 118 10.07.16 16:08 Сейчас в теме
Метод объекта не обнаружен (Печать).

2. Alex_E 1881 10.07.16 16:11 Сейчас в теме
(1) progr-2008, Расскажите подробней, как Вы использовали обработку?
Вот две ВПФ, которые я только что создал для обычного и управляемого приложения.
Читайте исходную статью, как пользоваться обработкой (изменял для управляемого приложенгия, если найдёте косяки в обычном - пишите - исправлю)
Прикрепленные файлы:
АвансовыйОтчет (внешняя для 2.0).epf
АвансовыйОтчет (внешняя для 3.0).epf
6. progr-2008 118 12.07.16 00:05 Сейчас в теме
(2)2. Alex_E, а можно подробнее, по шагам, как получили эти формы?
У меня разнообразные ошибки выдаются при разных наборах требуемых функций.


7. Alex_E 1881 12.07.16 08:28 Сейчас в теме
(6) progr-2008,
У меня разнообразные ошибки выдаются при разных наборах требуемых функций.
- про подробнее, будет время выложу инструкцию - сейчас полугодие - не дадут)))
Вы пишИте, что не получается, может в таком режиме смогу помочь...
А то у меня информации 0, только по первому посту могу предположить, что пробуете в обычном приложении...
8. progr-2008 118 12.07.16 09:42 Сейчас в теме
(7) и в обычном, и в управляемых, в разных конфигурациях - сообщения разные.
Формирую по-умолчанию в УПП 1.3 и в БП 3.0.
Похоже, от версии конфигурации зависит - в некоторых работает, в некоторых нет.
9. Alex_E 1881 12.07.16 11:24 Сейчас в теме
(8) progr-2008, Давайте попробуем таки на абстракное
в разных конфигурациях - сообщения разные.
а пойдём прям по примерам, в такой то конфигурации для такого то документа возникает такая-то ошибка, лучше с картинками, по другому я ничего понять не смогу...
46. AlexO 125 15.04.17 10:03 Сейчас в теме
(2)
Вот две ВПФ, которые я только что создал для обычного и управляемого приложения.
Это для каких конф?
48. Alex_E 1881 15.04.17 10:15 Сейчас в теме
51. AlexO 125 15.04.17 10:21 Сейчас в теме
(48) а тот авансовый отчет, который выложили у SeiOkami - он тоже для БП3 был?
53. Alex_E 1881 15.04.17 10:30 Сейчас в теме
(51) не помню для чего и не помню, что выкладывал - наверное давно дело было
3. TrinitronOTV 11.07.16 05:47 Сейчас в теме
"...наметилась тенденция выносить процедуры и функции печати из модуля менеджера в общие модули. Поэтому, чаще всего, созданную конструктором ВПФ придётся допиливать, перенося в модуль ВПФ эти самые процедцры и функции из общих модулей."
А как-то можно эти общий процедуры и функции программно перенести в ВПФ?
4. Alex_E 1881 11.07.16 07:48 Сейчас в теме
(3) TrinitronOTV,
А как-то можно эти общий процедуры и функции программно перенести в ВПФ
овчинка выделки не стоит... Для этого всё равно придётся скопировать тексты общих модулей в конструктор и придумать анализатор текста, чтобы из вызовов процедур общих модулей убрать их имена. Проще создать заготовку ВПФ конструктором, а потом нужные процедуры и функции общих модулей (те, в которых планируется сделать изменения) перенести в модуль ВПФ и тут уже отредактировать. Время на разработку ВПФ всё равно в разы сокращается...
5. TrinitronOTV 11.07.16 12:37 Сейчас в теме
(4) в общем-то согласен с вами
10. Alex_E 1881 12.07.16 14:33 Сейчас в теме
Выложил описание на примере счет покупателю в БП 3.0, вот ВПФ из того примера
Прикрепленные файлы:
СчетНаОплатуПокупателю (ВПФ).epf
progr-2008; +1 Ответить
11. progr-2008 118 12.07.16 21:15 Сейчас в теме
(10)Alex_E, отличное описание, особенно важно про изменения ВПФ.

На этой версии конфигурации все сразу получилось и для счета, и для реализации, причем, в счете даже сумма прописью сразу была.

Пункты 1-6 так и делала раньше, только версии конфигураций другие были, не во всех работало, а еще - по несколько форм сразу включала.
Проще намного по одной форме делать, а не сразу пакет.

Теперь достаточно понятно стало.

Спасибо!
12. Alex_E 1881 12.07.16 22:29 Сейчас в теме
(11) progr-2008, Всегда пожалуйста!!!
Про ошибки так ничего конкретного и не скажете, или их нет больше?
13. progr-2008 118 12.07.16 23:47 Сейчас в теме
(12) с этой версией БП 3.0, если делать по одной форме - ошибок пока нет, пробовала на нескольких документах. Получилось и несколько форм для реализации.

Теперь стало понятно, что если в УПП включать по одной форме и выбирать не Печать, а функцию для этой формы, тоже пока получается без ошибок. Пробовала на реализации, счете.

А вот если несколько форм сразу включить - тогда проблемы, связанные с параметрами печати и т.д.
Но лучше по одной форме делать, намного проще разбираться.

Например, для счета в УПП, если основная Печать:
{ВнешняяОбработка.СчетНаОплатуПокупателю_ВнешняяПечатная.МодульОбъекта(18,19)}: Ожидается выражение
ПараметрыПечати =<<?>> ;
{ВнешняяОбработка.СчетНаОплатуПокупателю_ВнешняяПечатная.МодульОбъекта(19,25)}: Ожидается выражение
КоллекцияПечатныхФорм =<<?>> ;
{ВнешняяОбработка.СчетНаОплатуПокупателю_ВнешняяПечатная.МодульОбъекта(21,19)}: Ожидается выражение
ПараметрыВывода =<<?>> ;

А в реализации еще:
{ВнешняяОбработка.РеализацияТоваровУслуг_ВнешняяПечатная.МодульОбъекта(47)}: Значение не является значением объектного типа (ДоступнаПечатьПоКомплектно)
ПараметрыВывода.ДоступнаПечатьПоКомплектно = Истина;
14. Alex_E 1881 13.07.16 06:32 Сейчас в теме
(13) progr-2008, Надо будет посмотреть на досуге...которого сейчас практически нет))) УПП 1.3? Вижу, выше было, зря спрашиваю)))
18. Alex_E 1881 14.07.16 14:55 Сейчас в теме
(13) progr-2008, покрутил на УПП 1.3, сразу - запускать только в обычном приложении! Потом - под одной печатной форме однозначно) Если нужен пакет - сделать на основании одной ВПФ не проблема, могу, конечно, написать инструкцию, но оно надо?
progr-2008; +1 Ответить
19. progr-2008 118 15.07.16 01:03 Сейчас в теме
(18) по одной форме - все получается, с УПП работаю только в обычном.
А вот пакет - очень хорошо бы инструкцию, для УПП надо.
20. Alex_E 1881 15.07.16 09:15 Сейчас в теме
(19) progr-2008, если только позже - сейчас на части рвут - полугодие.........
progr-2008; +1 Ответить
15. Alex_E 1881 13.07.16 08:59 Сейчас в теме
Модераторы, а почему в еженедельном обзоре публикацию не выложили?
16. Alraune 1422 13.07.16 09:07 Сейчас в теме
(15) этим занимаются не модераторы. Тем не менее, проверила письмо с рассылкой, Ваша публикация там есть. В блоке "Новые разработки за StartMoney", примерно в середине списка
17. Alex_E 1881 13.07.16 09:19 Сейчас в теме
(16) Alraune, Спасибо Ирина! У меня наверное очки запылились - не увидел))))
21. hitchkock 10 18.07.16 17:55 Сейчас в теме
Есть проблема с сохранением печатной формы, когда конфа серверная. Компилируется и создается начальное представление на сервере, а конечное сохранение происходит на клиенте, а это разные пути, соответственно файла не видит. Я побыстрому выпутался так:
1. Создал реквизит формы произвольного типа - ДвоичныеДанныеОбработки;
2. поправил код команды "КомандаСохранить":
//Не работает когда серверная
	//ДвоичныеДанныеОбработки = Новый ДвоичныеДанные(Объект.ИмяГотовогоФайла);
	//ФайлОбработки = Новый Файл(Объект.ИмяГотовогоФайла);
	ПолучитьДвоичныеДанные();
	ФайлОбработкиСуществует = СуществованиеФайлаОбработки();
	
	//Если ФайлОбработки.Существует() тогда
	Если ФайлОбработкиСуществует тогда
Показать

3. создал соответственно серверную процедуру и функцию:
&НаСервере
Процедура ПолучитьДвоичныеДанные()
	ДвоичныеДанныеОбработки = Новый ДвоичныеДанные(Объект.ИмяГотовогоФайла);
КонецПроцедуры

&НаСервере
Функция СуществованиеФайлаОбработки()
	ФайлОбработки = Новый Файл(Объект.ИмяГотовогоФайла);
	Возврат ФайлОбработки.Существует();
КонецФункции
Показать
СергейКа; Alex_E; +2 Ответить
22. Alex_E 1881 19.07.16 07:19 Сейчас в теме
(21) hitchkock, Спасибо, включу, как будет время...
23. BigB 172 22.07.16 14:45 Сейчас в теме
(0), на мой взгляд - отличная дыра в безопасности.
Я с помощью Вашей обработки легко получу доступ к серваку где будет находится база.
Не спрашивайте: -Как?
Догадайтесь сами.
24. Alex_E 1881 22.07.16 14:58 Сейчас в теме
(23) BigB, Дыр в безопасности существует много, но есть поговорка - нато и щука в пруду, что бы карась не зевал)))

ЗЫ Обработка вообще то не моя, см. анонс, и существует здесь уже довольно таки длительное время... Но, если вы имеете доступ к базе, то зачем Вам получать его ещё?
25. Alex_E 1881 24.08.16 08:00 Сейчас в теме
(23) BigB, Так что там про дыры? :-)
26. l-Rain 25.08.16 17:00 Сейчас в теме
Спасибо, в БП 3.0 работает замечательно!
27. Alex_E 1881 25.08.16 20:37 Сейчас в теме
28. Светлый ум 218 29.08.16 20:16 Сейчас в теме
Выдается ошибка пробовал на 2х конфигурациях платформа 8.3.8.2027:

Возможно, обработка (отчет) устарела или не является дополнительной:Метод объекта не обнаружен (СведенияОВнешнейОбработке)

-------------------

Нашел решение, необходимо добавить функции в модуль объекта обработки - как сказано в статье:
(Для того чтобы добавить дополнительную обработку или отчет в тонкий клиент нужно в модули отчета или обработки прописать одну процедуру и две функции.)
http://infostart.ru/public/305037/
klaus38; Kolunya; Alex_E; Team leader; +4 Ответить
29. Alex_E 1881 29.08.16 20:31 Сейчас в теме
(28) Светлый ум, А можно поподробнее о каких конфигурациях идёт речь? И хотя бы текст ошибки - просто пробую на БП 3.0 УТ 11 .2 ЗУП 3.0 - всё на УФ - ошибок нет, ежели есть - хочу увидеть и исправить...правда...
30. Светлый ум 218 29.08.16 22:12 Сейчас в теме
(29)

- Розница 2.1
- Управление складом 4.0 (Акселот)
31. Светлый ум 218 29.08.16 22:13 Сейчас в теме
Текст ошибки я уже приводил:
"Возможно, обработка (отчет) устарела или не является дополнительной:Метод объекта не обнаружен (СведенияОВнешнейОбработке)"

- только этот текст, видимо дело в БСП (судя по комментам в http://infostart.ru/public/305037/ )
32. Alex_E 1881 29.08.16 22:18 Сейчас в теме
(31) Светлый ум, Да блин - тест ошибки можно показать?
33. Alex_E 1881 29.08.16 22:29 Сейчас в теме
(31) Светлый ум, Вот ничё не делая для Розница 2.2.4.22 ВПФ Заказ поставщику.... Усё работает, ещё раз - напишите полный текст ошибки и конфигурацию.
Прикрепленные файлы:
ЗаказПоставщику (ВПФ_Розница).epf
34. Alex_E 1881 29.08.16 22:38 Сейчас в теме
(31) Светлый ум,
Возможно, обработка (отчет) устарела или не является дополнительной:Метод о
- это реально из БСП, но, опять же - нужна конфигурация и полный текст ошибки, и вообще полный фарш - ВПФ, с этой ошибкой
35. Светлый ум 218 30.08.16 18:42 Сейчас в теме
(34) значит такая петрушка только в отраслевках:

- у меня докрученная Розница "Розница 8. Магазин бытовой техники и средств связи, редакция 2.1 (2.1.8.16)",

поэтому сильно не заморачивайтесь по поводу ошибки, кому надо тот из комментов возьмет - способ допила.
(Плюс комменту 28 поставьте, чтобы в шапке публикации решение было)
36. Alex_E 1881 30.08.16 18:46 Сейчас в теме
(35) Светлый ум, Как скажете (поставил)... Вообще этот конструктор не решает всех проблем - просто даёт заготовку для разработки с минимизацией времени на типовое решение))))
37. WeLap 66 26.10.16 11:54 Сейчас в теме
Почему может такая ошибка выдаваться при компиляции:{ВнешняяОбработка.КонструкторВнешнихПечатныхФорм.МодульОбъекта(78)}: Метод объекта не обнаружен (Run)
WshShell.Run(СтрокаЗапуска, 0, Истина);
38. Alex_E 1881 26.10.16 15:15 Сейчас в теме
(37) WeLap, Озвучьте пожалуйста конфигурацию и объект, где получили эту ошибку...
39. zxcvbnm,. 28.12.16 17:30 Сейчас в теме
(38)
Здравствуйте!
У меня не открывается файл. Конфигурация и ошибка во вложении.
Прикрепленные файлы:
40. Alex_E 1881 28.12.16 17:45 Сейчас в теме
(39) Попробуйте на платформе постарше, у мня таких проблем не наблюдается, но ставить 8.3.6.* при наличии 8.3.9.* как то не хочется. Если очень нужно - пишите в личку - мог посмотреть через амми админ
41. zxcvbnm,. 29.12.16 11:46 Сейчас в теме
(40) Но в 8.3 (8.3.5.1146) работает, только она локальная версия. Может быть причина в том, что удаленный доступ?
42. Alex_E 1881 29.12.16 16:04 Сейчас в теме
Может быть причина в том, что удаленный доступ?
не могу сказать, нужно видеть, что происходит....
43. Cartman 17.03.17 08:39 Сейчас в теме
Вот такая ошибка, что в обычном, что в клиент-серверном режиме.
Платформа 1С:Предприятие 8.3 (8.3.8.1933)

{ВнешняяОбработка.КонструкторВнешнихПечатныхФорм.МодульОбъекта(1311,9)}: Процедура или функция с указанным именем не определена (РазобратьСтрокуRegEx)
рез=<<?>>РазобратьСтрокуRegEx(НРег(ОбрабатываемаяПроцедураФункция.ТекстПроцедуры),"[\(\)\.\,\;\s=]"+имя+"[\(\)\.\,\;\s=]");
44. Alex_E 1881 17.03.17 09:08 Сейчас в теме
(43) Вы попробуйте пройти по обработке создани "по умолчанию", в смысле выделте только нужную печатную форму. Будет так же?
45. Cartman 17.03.17 12:48 Сейчас в теме
(44) Это при открытии. Забыл указать.
Обычное приложение.
47. AlexO 125 15.04.17 10:08 Сейчас в теме
(0)"наметилась тенденция выносить процедуры и функции печати из модуля менеджера в общие модули"
сейчас это уже и не тенденция вовсе, а "стандарт" - разные БСП в разных конфигурациях и разных внутренних версиях БП, ЗУП и УПП, все во внешних модулях, которые бесконечно вызывают друг друга, и постоянное изменение кода модулей (от правки кода до исправления описаний функций и комментариев).
Так что если кто желает сделать пусть даже простенькую общую ВПФ для разных конфигураций (не говоря уже про универсальные обработки) - предстоит веселенькое занятие сбора, а потом и бесконечной актуализации по всем версиям.
Молодец 1С, как обычно, сделала все правильно - теперь еще и зарубила на корню универсальные обработки.
49. Alex_E 1881 15.04.17 10:17 Сейчас в теме
(47) идите в SAP - тем всё универсально просто))))
50. AlexO 125 15.04.17 10:19 Сейчас в теме
(0)"Отладчиком смотри, где собака порылась, на вид всё фильдиперсово"
Вы же не в блоге у себя, исправьте, что ли, такие высказывания ))
52. Alex_E 1881 15.04.17 10:29 Сейчас в теме
(50) Вот прям всё прочитал, публикацию и комменты, но приведённой цитаты не нашёл))))) но это ничего, тем более поправить что-то можно только в течении получаса, так что терпите, сэр, или просто, коли не нравится, уйдите по английски))))

ЗЫ если бы и нашёл, то исправлять бы не стал, ибо не вижу ничего криминального
55. AlexO 125 15.04.17 10:34 Сейчас в теме
(52) это ближе к концу, абзацем ниже от
"Внимание: После каждого изменения лучше сохранять ВПФ и проверять работоспособность, если менять всё подряд, потом может получится, что легче будет начать с начало, чем исправить то, что наменяли. Ещё совет, когда всё работает, и собираетесь что- то допилить, создайте новую версию ВПФ, и меняйте её – останется рабочий вариант, и текущий, с попыткой допила" :)
57. Alex_E 1881 15.04.17 10:42 Сейчас в теме
(55) Вот новая редакция
Отладчиком смотрим, где собака порылась. На вид всё фильдиперсово, однако видим вместо строки число.
, в старой реально была ошибка. Этот вариант менять не буду - мне нравится так)))
54. AlexO 125 15.04.17 10:31 Сейчас в теме
Кстати, не указали, что теперь всегда нужно при создании своей ВПФ - сразу создавать и сервисную форму отладки для этой ВПФ. Именно по причине невозможности теперь создавать универсальные обработчики, в том числе - универсальные отладчики ВПФ. Но уже по причине невозможности программного открытия самих ВПФ при отладке.
У вас форма как раз есть в примере, только не указано, насколько она будет важна в дальнейшем.
56. Alex_E 1881 15.04.17 10:34 Сейчас в теме
(54) Форма для отладки создается всегда, в реальной работе (после подключения ВПФ) она не используется, нужна только для отладки. В принципе никому не мешает, но если дело принципа - можно удалить, на работоспобность ВПФ не повлияет
62. Amur_MVS 107 26.07.17 18:58 Сейчас в теме
Спасибо, очень полезная обработка!
63. vshish 110 29.01.18 02:58 Сейчас в теме
Нормальная обработка, но не все работает если база серверная.
1. Кнопка сохранить пытается сохранить на клиенте то, что сформировано на сервере и нет на клиенте.
2. кнопка зарегистрировать тоже не работает( не разбирался почему.
а так да очень удобно создать ВПФ и подправить ее под себя.
77. vshish 110 03.04.18 08:16 Сейчас в теме
Уже писал в (63), что при серверном варианте базы обработка не работает.
Компилируется на сервере, а сохраняется на клиенте. и файл не передается.
исправить можно заменой процедуры Команда сохранить на исправленный вариант

Алексей. Если не сложно исправь и опубликуй.

&НаСервереБезКонтекста
Функция ПолучитьДвоичныеДанныеФайла(ИмяГотовогоФайла, Отказ)

	ФайлОбработки = Новый Файл(ИмяГотовогоФайла);
	
	Если ФайлОбработки.Существует() тогда
		Возврат Новый ДвоичныеДанные(ИмяГотовогоФайла);
	Иначе 
		Отказ = Истина;
		Возврат Неопределено;
	КонецЕсли;

КонецФункции // ПолучитьДвоичныеДанныеФайла()
 

&НаКлиенте
Процедура КомандаСохранить(Команда)
	
	Если НЕ Объект.сФайлВродеБыГотов тогда
		ПоказатьПредупреждение(,"Скомпилируйте файл ВПФ!");
		Возврат;
	КонецЕсли;
	
	Отказ = Ложь;
	ДвоичныеДанныеОбработки = ПолучитьДвоичныеДанныеФайла(Объект.ИмяГотовогоФайла, Отказ);
	
	Если не Отказ тогда
		ДиалогФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
		ДиалогФайла.Фильтр = "*.epf";
		ДиалогФайла.Расширение = "epf";
		ДиалогФайла.ПолноеИмяФайла = Объект.ИмяНовойОбработки;
		Если ДиалогФайла.Выбрать() Тогда
			ИмяФайла = ДиалогФайла.ПолноеИмяФайла;
			ДвоичныеДанныеОбработки.Записать(ИмяФайла);
			ГотовыйФайлик = Новый Файл(ИмяФайла);
			
			Счетчик = 0;
			Пока НЕ ГотовыйФайлик.Существует() И Счетчик < 999 цикл
				Счетчик = Счетчик + 1;
			КонецЦикла;
			
			сФайлСохранен = Истина;
			
			Если ГотовыйФайлик.Существует() тогда
				Объект.ПолныйПутьВПФ = ГотовыйФайлик.ПолноеИмя;
				Режим = РежимДиалогаВопрос.ДаНет;
				Оповещение = Новый ОписаниеОповещения("ПослеЗакрытияОткрытияВПФ", ЭтаФорма, Параметры);
				ПоказатьВопрос(Оповещение, "Файл внешней печатной формы сохранен. Открыть его для проверки?", Режим, 0);
			Иначе
				ПоказатьПредупреждение(,"Чего-то не так =(");
			КонецЕсли;	
			
		КонецЕсли;
	КонецЕсли;   
	
КонецПроцедуры
Показать
78. Alex_E 1881 03.04.18 08:44 Сейчас в теме
79. vshish 110 03.04.18 08:56 Сейчас в теме
(77) и зарегистрировать в полученном шаблоне тоже не работает в серверном варианте. Но ее я не стал править
80. Alex_E 1881 03.04.18 09:21 Сейчас в теме
(79) я пока выложу Ваше исправление, а с регистрацией срозхданной ВПФ на сервере потом - нет времени развернуть сервер, когда сделаю - сделаю и это, а так потестить не на чем....
64. Alex6600 20.02.18 11:02 Сейчас в теме
65. kazzuss 4 23.03.18 09:18 Сейчас в теме
Алексей, спасибо большое!

Только учусь делать ВПФ - с Вашей обработкой все получилось и многое стало понятно.
66. Alex_E 1881 23.03.18 09:53 Сейчас в теме
67. vpaoli 25 27.03.18 11:09 Сейчас в теме
Если программист сделал за свою жизнь сам хотя бы одну внешнюю печатную форму, то сделать вторую не представляется трудным. И времени на это нужно немного.
Инструмент, ускоряющий создание печатных форм, конечно очень нужен и ценен, но только тем, кто этим занимается постоянно. Но если Вы программист широкого профиля, которому нужно делать эти формы не чаще раза в полгода , то вникать во всевозможные инструменты по ускорению создания чего то там ..., форм, обработок, обращению к HTTP сервисам и т.п. нецелесообразно. Слишком много таких инструментов может существовать .... для того , чтобы забивать ими свой единственный мозг.
68. Alex_E 1881 27.03.18 11:39 Сейчас в теме
(67) Я где-то прописал обязательность использования этого констуктора?))))
69. vpaoli 25 27.03.18 11:51 Сейчас в теме
70. Alex_E 1881 27.03.18 11:59 Сейчас в теме
(69) Аааа, ну эт мы всегда пожалуйста)))
Итак, ИМХО - по мне так он ценен как раз не тем, кто постоянно этим занимается (им не нужно, когда конвейер работает давно и ставбильно, он не требует пристального внимания наладчиков), а тому, кто делает ВПФ от случая к случаю, и загружать свой мозг информацией, как это делается нет никакой необходимости - есть инструмент, в который это заложено, им и пользуемся...
А то, ить, все знают как копать ямы, но можно копать руками, а можно экскаватором, в разных ситуациях использование каждого из этих способов может быть вполне себе оправдано, но по мне так, в любом случае, лопату нужно иметь...
71. vpaoli 25 27.03.18 12:12 Сейчас в теме
Для того , чтобы копать экскаватором , нужно сначала на курсы экскаваторщиков устроиться. Поучиться недельку другую. Спасибо за ваш инструмент. Как только придется сделать ВПФ, сразу о нем вспомню!
72. Alex_E 1881 27.03.18 12:17 Сейчас в теме
(71) а для того чтобы делать ВПФ ничё не нужно?...вот прям так взять любого гуманоида с улицы, и он раз и наваяет любую ВПФ?
73. vpaoli 25 27.03.18 12:30 Сейчас в теме
Гуманоидов, инопланетян и др. не рассматриваем. Берем обычного отечественного 1С программиста. Вот что действительно ему нужно, так это принципы, приемы построения (кодирования) ВПФ. Из учебников 1С, ИТС и др. Иначе он не программист , а студент-гуманоид. А инструменты - это дело наживное, хочу использую, хочу нет. Но не подумайте, что я спорю. Безусловно , инструменты всякие нужны, инструменты всякие важны!
74. Alex_E 1881 27.03.18 13:07 Сейчас в теме
(73) я вообще к Вашему
чтобы копать экскаватором , нужно сначала на курсы экскаваторщиков устроиться.
, но не суть...
81. Alex_E 1881 03.04.18 09:42 Сейчас в теме
Выложил новую версию, с исправлением от vshish. Ещё раз спасибо!
82. Dmitri93 4 09.04.18 15:02 Сейчас в теме
(81) Привет! Скачал версию 4.7, она в модуле объекта почему-то не до конца пишет слово "КонецПроцедуры" в процедуре печать. Естественно потом не открывается) после исправления в конфигураторе открывается нормально.
Прикрепленные файлы:
83. Alex_E 1881 09.04.18 15:06 Сейчас в теме
Видел такое у кого-то из клиентов, когда на его компе делал ВПФ, потом стал исправлять на своём - не проявилось... В принципе дописать КонецПроцедуры не проблема, но...порядок быть должЁн - пишите в личку - посмотрим серез АА на Вашем компе - может удастся словить причину...
84. VovkaPutin 24 10.05.18 15:39 Сейчас в теме
(83)где код, в котором это прописывается (конецпроцедуры)? У нас тоже не дописывается, Зарплата и управление персоналом, редакция 3.1 (3.1.6.37)
85. Alex_E 1881 10.05.18 19:46 Сейчас в теме
(84) Уже отвечал в (83) - Вам такое же предложение...
86. VovkaPutin 24 11.05.18 08:09 Сейчас в теме
87. VovkaPutin 24 11.05.18 08:30 Сейчас в теме
(85), Исправил так, работает (в скриншоте). Так же ошибка после кнопки Сохранить - Открыть. Скриншот также прилагается
Прикрепленные файлы:
88. Alex_E 1881 11.05.18 08:52 Сейчас в теме
89. VovkaPutin 24 11.05.18 08:55 Сейчас в теме
(88), также добавил код в модуль объекта, чтобы обработка регистрировалась во внешних отчетах,обработках в Зуп 3.1:

код
90. Alex_E 1881 11.05.18 08:59 Сейчас в теме
(89) Вот это, ИМХО, лишнее... Обработка запускается в разных базах, используется редко, потому регистрация ни к чему...если конечно не стоит задача постоянно ваять ВПФ для конкретной базы))))
91. VovkaPutin 24 11.05.18 09:03 Сейчас в теме
(90), при внедрении УФ не помешает)
92. Alex_E 1881 11.05.18 09:06 Сейчас в теме
93. VovkaPutin 24 11.05.18 09:07 Сейчас в теме
(92), по ошибке модальных окон есть идеи?
94. Alex_E 1881 11.05.18 09:17 Сейчас в теме
(93) Сейчас исправлю, выложу. Дайте почту в личку - пришлю новый вариант для теста
95. Alex_E 1881 11.05.18 11:08 Сейчас в теме
Выложил новую версию 4.8 с исправление от VovkaPutin (ещё раз спасибо), плюс убрал из текста модуля ВПФ все строки с #Если... #КонецЕсли #Область ... #КонецОбласти итд. Плюс убрал модальность при открытии ВПФ из конструктора, в последних версиях конфигураций на УФ от неё совсем отказались, потому падало с ошибкой...
96. alexvi33 11.05.18 13:28 Сейчас в теме
Сделал ВПФ М11 для документа Требование-накладная БП 3. БЫСТРО И ПРОСТО. Проверил - РАБОТАЕТ.
Инструкция подробная.
97. alexvi33 11.05.18 13:29 Сейчас в теме
98. Alex_E 1881 11.05.18 13:35 Сейчас в теме
99. avtom1c 22.06.18 11:05 Сейчас в теме
Хорошая обработка! Может для новичков что то будет и "сложновато"(если будут какие то запинки), НО реально экономит время :)
100. VKuser15680667 11.09.18 15:27 Сейчас в теме
Создал ВПФ "Накладная на перемещение" для ERP, чтоб в нем автоматически проставлялся "ответственный", прописал , запустил через "открыть" (отладка) всё прекрасно сработало, регистрирую обработку в ERP и она перестает работать с ошибкой " Значение не является значение объектного типа Ответственный"....0_0
101. Alex_E 1881 11.09.18 15:40 Сейчас в теме
(100) К сожалению я не вижу этой ошибки и смоделировать её не могу, могу посмотреть через АА, если хотите - пишите в личку...
102. VovkaPutin 24 14.09.18 10:05 Сейчас в теме
(100), отладкой пользоваться умеете?
103. Helsin_G 14.09.18 20:20 Сейчас в теме
Добрый день создал ВПФ "ПриложениеКДоговору" в БП 3.0 (3.0.64.48) 1С:Предприятие 8.3 (8.3.12.1529)
При открытии печатной формы выходит ошибка --

{ОбщийМодуль.УправлениеПечатьюБП.Модуль(911)}: Значение не является значением объектного типа (Свойство)
Если НЕ ПараметрыПечати.Свойство("ИсключаемыеТипыДокументов") Тогда
104. Alex_E 1881 14.09.18 21:52 Сейчас в теме
(103) Ошибка в общем модуле, надо смотреть откуда вызов...могу глянуть через АА, пишите в личку.
105. FilatovRA 144 18.09.18 14:00 Сейчас в теме
Спасибо огромное за ваш труд!
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день

Руководитель группы сервисов ЭДО, ЭЦП и криптографии
Москва
зарплата от 150 000 руб.
Полный день

Руководитель группы интеграций (1С)
Москва
зарплата от 150 000 руб.
Полный день

Руководитель группы сервисов FRM на 1С
Москва
зарплата от 150 000 руб.
Полный день

Консультант-аналитик 1С (ЗУП)
Санкт-Петербург
Полный день