0. moolex 802 15.03.15 15:36 Сейчас в теме

Перенос объектов 1С

Простой и наглядный перенос объектов между любыми базами 1С 8 с предварительным анализом на возможные различия в данных (через файл, через интернет, через буфер обмена). Интерактивная настройка правил обмена на стороне источника и получателя.
В обработке есть удобный обзор по подсистемам, поиск и обработка данных по заданному фильтру. Сравнение объектов, поиск ссылок.
Конструктор кода по созданию объектов, написание скриптов и отладка мини-функций в УФ.
Отключение/включение регламентных заданий. Регистрация/снятие с регистрации объектов в планах обмена. И многое другое.

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. graZy 15 16.03.15 17:46 Сейчас в теме
+

возможно есть и другое что (даже видел тут платную правда похожую на типовую выгрузку xml)
но ...
для меня реально что-то похожего не хватало от 1с (обычной выгрузки - загрузки, без возможности особых "извращений")

так что мое простое спасиб (пока применить не к чему, но в будущем надеюсь пригодиться когда-нибудь)

прим: ;) обработка не только обычная выгрузка-загрузка (так что кому надо посложней навороты думаю в ней найдут то что надо)
157. moolex 802 28.07.18 13:06 Сейчас в теме
не здесь оставил заметку
159. dimaster 39 22.08.18 22:14 Сейчас в теме
(157)
подскажите, плз, можно ли сделать такое
выгрузка из УТ10
загрузка в операцию
Расходный кассовый ордер инкассо
в БП3 просто операция Д57 К50
?


выгрузка -
включать правила выгрузки
----------------------------------------------
[ИсключаемыеСвойства]
[ПодменаИмен]
[ИсключаемыеОбъекты]
[ДополнительныйЗапрос]
ВЫБРАТЬ
РасходныйКассовыйОрдер.Номер,
РасходныйКассовыйОрдер.Дата,
РасходныйКассовыйОрдер.Проведен,
РасходныйКассовыйОрдер.Касса.ТорговыйОбъект.Наименование КАК Касса,
РасходныйКассовыйОрдер.СтатьяДвиженияДенежныхСредств КАК Статья,
РасходныйКассовыйОрдер.Ссылка КАК Ссылка,
РасходныйКассовыйОрдер.СуммаДокумента КАК Сумма
ИЗ
Документ.РасходныйКассовыйОрдер КАК РасходныйКассовыйОрдер
ГДЕ
(РасходныйКассовыйОрдер.СтатьяДвиженияДенежныхСредств = ЗНАЧЕНИЕ(Справочник.СтатьиДвиженияДенежныхСредств.Инкассация)И
(РасходныйКассовыйОрдер.Дата МЕЖДУ &НачДатаВыгрузки И &КонДатаВыгрузки))

[ОграничитьПоКоличеству]
[ПрефиксСвойств]
[ОбщийРодитель]
[ПодставитьДатуВместоПустой]
----------------------------------------------------------------------------
или, может, быть, есть фильтры - другой отбор выгружаемых данных.
правильно ли выгружаю и как грузить в операцию?
2. y-ha 16.03.15 17:53 Сейчас в теме
Присоединюсь - обработка дельная, перенос номенклатуры из БП 2.0 в БП 3.0 вместе с ценами сделала.
Rostislav.ru; moolex; +2 Ответить
3. Константин С. 594 17.03.15 10:19 Сейчас в теме
При выгрузке и загрузке выдало сообщение:

Внимание! У элемента справочника пустой код и пустое наименование! Вид = НомераГТД


Можно добавить информационности
4. moolex 802 17.03.15 10:36 Сейчас в теме
(3) Константин С., из сообщения вроде понятно, что элемент справочника НомераГТД не имеет ни кода ни наименования.
здесь два варианта:
1. найти этот элемент в базе источнике(или в базе получателе) и установить любой код или наименование и заново выгрузить. (это можно сделать как раз на закладке обзор через фильтр и обработку)
2. Вариант когда в конфигурации стоит длина кода=0 и длина наименования=0, - это вообще плохо, когда в информационной базе есть такие справочники. Здесь либо использовать УникальныйИдентификатор, либо обработка будет постоянно делать новый элемент при загрузке данных и возможно будет постоянно показывать разницу при анализе данных.
5. Константин С. 594 17.03.15 11:23 Сейчас в теме
Cпасибо за ответ, я вообшем разобрался как решить. Хотель обратить внимание на информационность

А еще прогресс загрузки выгрузки в УФ.
6. moolex 802 17.03.15 11:40 Сейчас в теме
(5) Константин С., с прогрессом загрузки/выгрузки в УФ - это я еще не разобрался с УФ. Эта обработка - мое первое знакомство с УФ :)
если есть какие ссылки на пример прогресса - буду признателен.
102. BackHand001 19 12.06.17 11:11 Сейчас в теме
(6)

&НаКлиенте
Процедура КакаяТоПроцедураОбработкиДанных(МассивДанных)
      // Делим массив на 100 порций
      Порция = Цел(МассивДанных.Количество / 100);
      
     Для СчПорций = 1 По 101 Цикл
        ПроцедураОбработкиПорцииДанныхНаСервере(СчПорций,Порция,МассивДанных);     

         // А вот вывод прогресса
         Состояние("Процесс Обработки Данных", СчПорций,"Выполнено %");

     КонецЦикла;

&НаСервереБезКонтекста
Процедура ПроцедураОбработкиПорцииДанныхНаСервере(СчПорций,Порция,МассивДанных) 

Для ИндМассива = СчПорций*Порция  По (СчПорций+1)*Порция Цикл
       ЭлементМассива = Массив[ИндМассива];
        //Обрабатываем ......
        // Еще Обрабатываем )))
        // Совсем Обработали.

КонецЦикла;

КонецПроцедуры
Показать
7. Константин С. 594 17.03.15 11:5