Runtime Error - из-за чего бывает?

. Leja Leja (Leja) 08.12.09 12:09 Сейчас в теме
Добрый день всем!
Подскажите, из-за чего в 7-ке может быть Runtime Error. Запускаю обработку, которая рассчитывает некие параметры, и через полчаса работы 1С вылетает с такой ошибкой.
1С Предприятие сетевая версия, 7.70.027
Сама база в dbf, размер около 1,5 Гб
Добавить вознаграждение
Ответы
. Альтаир Павленко (Altair777) 08.12.09 12:16 Сейчас в теме
(1) хм... полчаса работы?
А скриншот можете показать? Или более подробное описание ошибки.
Места на винте много?
. Leja Leja (Leja) 08.12.09 12:29 Сейчас в теме
Свободного места на винте 8 Гб.
скриншот ошибки (больше никаких сообщений нет):
Прикрепленные файлы:
. Leja Leja (Leja) 08.12.09 12:33 Сейчас в теме
добавлю, что база на локальном компе
. Ёпрст (Ёпрст) 1012 08.12.09 12:43 Сейчас в теме
(4) если база на локальной тачке , зачем юзать скулеву платформу ?...
И чего обработка делает то ?
Завалить 1с-ину как 2 пальца...
А так - тупо памяти не хватает..
. Саша (Time dont wait) 08.12.09 12:53 Сейчас в теме
Запустите Scandisk
Попробуйте переместить базу на другое место
. Leja Leja (Leja) 08.12.09 12:57 Сейчас в теме
(5) потому что тестирую на локальной машине.

В обработке заполняются и анализируются большие таблицы значений, поэтому насчет памяти, наверное, вы правы..
. Юрий Тимофеев (Tatitutu) 3562 08.12.09 13:04 Сейчас в теме
(7) попробуй отключить (Снять галку) востановление системы с диска на котором база.
. Ёпрст (Ёпрст) 1012 08.12.09 13:33 Сейчас в теме
(7) режь на куски.. 1с-ина не любит большие тз..
. Leja Leja (Leja) 08.12.09 13:41 Сейчас в теме
(9) как обычно приходится чужие косяки разгребать... :(
. Сергей (newbas) 08.12.09 23:31 Сейчас в теме
Такое часто бывает из-за переполнения стека рекурсии. Думаю, что стоит оптимизировать алгоритм обработки.
12. binagal (binagal) 17.04.10 16:43 Сейчас в теме
1С 7.7.025 на SQL 2000 вываливается с ошибкой Runtime Error!
Microsoft Visual C++ Runtime Library
Runtime error!

This application has requested the Runtime to terminate it in an unusual way. Please contact the aplication support team for more information.

Никаках существенных изменений в конфигурацию, настройки БД, права на папку БД не вносилось.
Ошибка появляется в различное время у некоторых пользователей одновременно (у 5-10 из 50). Это бывает при существенной нагрузке на БД, 10-20 раз в день.У некоторых пользователей в этот момент ошибка SQL - Deadlock.
SQL сервер - на отдельной физической машине W2k3. Пользовательские 1С запускаются на 2-х терминальных серверах W2k3 x64. Пробовали запускать на другом сервере W2k3 - ошибки повторились.
В этой же системе работает другая БД SQL 1С 7.7. С ней таких проблем нет.
Никакая закономерность, кроме высокой загрузки не выявлена.
Испробованы все найденные советы:
- очистка mlg файла
- проверены права
- убраны галочки со свойств сетевых карт - разрешить отключать устройство для экономии электроэнергии
- все диски проверены Scandisk
- проведено тестирование и исправление БД
- проверена целостность БД в SQL

Как выявить закономерность? Как найти причину?
13. Jurii (jmw) 19.04.10 09:15 Сейчас в теме
Диски NTFS или FAT32 ?
Дефрагментацию давно делали?
Такая проблема возникает чаще всего на FAT32 при сильной фрагментации.
При чём одна база может работать как часы, а вторая даже запускаться не хочет!
Я пользую MyDefrag - бесплатная, простая, можно вместо скринсейвера.
14. binagal (binagal) 19.04.10 11:48 Сейчас в теме
Jurii пишет:
Диски NTFS или FAT32 ?
Дефрагментацию давно делали?

NTFS
дефрагментация раз в неделю
15. Денис Денин (MrDen) 20.04.10 00:06 Сейчас в теме
(12) 1С 7.7.027 не пробовали?
(3) Свободного места на винте маловато! Кто знает, что еще делается на сервере
Ну, а "большие" ТЗ как раз к падению и ведут! 1 - оптимизация алгоритмов, 2 при больших объемах данных в памяти перейти на ИТЗ и оптимизировать структуру в памяти, очень помогает.
16. binagal (binagal) 03.01.12 13:56 Сейчас в теме
(15) Денис Денин, на 7.7.027 то-же самое
17. binagal (binagal) 03.01.12 13:58 Сейчас в теме
Как оказалось, причиной были некоторые прямые запросы в БД SQL, меняющие данные.
18. Михаил Труников (voyger_men) 05.01.12 17:49 Сейчас в теме
у меня такая штука выскакивала когда начал накрываться жесткий диск, в базе полетела одна дбфка, вообщем очень долго помучился пока не восстановил.
19. Евгений Черников (johnman) 28.05.12 06:59 Сейчас в теме
Тоже ситуация с вылетом ошибки. База дбф.
Формируется книга продаж, при подборе в книгу больше 55к документов .. база вылетает с ошибкой.
При формирование по квартально... всё отлично формируется.
Поэтому делаю вывод... 1с не любит больших объёмов.
20. makc B (swi76) 30.05.12 09:53 Сейчас в теме
ПРоверяй алгоритм обработки, скорее всего много данных формируется ....
21. Sergey (ra9000) 9 30.05.12 13:36 Сейчас в теме
Когда памяти не хватает в сеансе для обработки или отчета. Когда места под базу забивается. и т.п.
22. Сергей (Che) Коцюра (CheBurator) 3367 31.05.12 04:22 Сейчас в теме
(19) убери расшифровки в макете
24. Гость 01.06.12 12:02 Сейчас в теме
апрос к регистру дает нулевой результат:

Данный регистр заполняется следующим кодом: Код
Процедура ОбработкаПроведения();
ВыбратьСтроки();
Пока ПолучитьСтроку() > 0 Цикл
Регистр.ТоржестваИБанкеты.ДокументРегистратор = ТекущийДокумент();
Регистр.ТоржестваИБанкеты.ЗалТоржествИБанкетов = ЗалТоржествИБанкетов;
Регистр.ТоржестваИБанкеты.ДатаП = ДатаП;
Регистр.ТоржестваИБанкеты.ВремяС = ВремяС;
Регистр.ТоржестваИБанкеты.ВремяПо = ВремяПо;
Регистр.ТоржестваИБанкеты.Контрагент = Контрагент;
///Табличная часть
Регистр.ТоржестваИБанкеты.Номенклатура = Номенклатура;
Регистр.ТоржестваИБанкеты.Количество = Количество;
Регистр.ТоржестваИБанкеты.Цена = Цена;
Регистр.ТоржестваИБанкеты.Сумма = Сумма;
Регистр.ТоржестваИБанкеты.Единица = Единица;
Регистр.ТоржестваИБанкеты.КоличествоПерсон = КоличествоПерсон;

Регистр.ТоржестваИБанкеты.ДвижениеВыполнить();
КонецЦикла;
КонецПроцедуры



В регистре есть записи, это проверял
Теперь запрос с выводом в табличную часть:
Код
Процедура ПриОткрытии()
ТабЗнач = Результат;
ТабЗнач.НоваяКолонка("ДеньТоржест",,,,"День");
ТабЗнач.НоваяКолонка("ВремяС",,,,"Время с");
ТабЗнач.НоваяКолонка("ВремяПо",,,,"Время по");
ТабЗнач.НоваяКолонка("КоличествоПерсон",,,,"Количество персон");
ТабЗнач.НоваяКолонка("Контрагент",,,,"Заказчик");
КонецПроцедуры



Процедура Сформировать()
ТабЗнач = Результат;
ТекстЗапроса = "
| Период С НачДата По КонДата;
| ДеньТоржест = Регистр.ТоржестваИБанкеты.ДатаП;
| ВремяС = Регистр.ТоржестваИБанкеты.ВремяС;
| ВремяПо = Регистр.ТоржестваИБанкеты.ВремяПо;
| КоличествоПерсон = Регистр.ТоржестваИБанкеты.КоличествоПерсон;
| Контрагент = Регистр.ТоржестваИБанкеты.Контрагент;
| ЗалТоржествИБанкетов = Регистр.ТоржестваИБанкеты.ЗалТоржествИБанкетов;
| Условие(ЗалТоржествИБанкетов = ВыбЗалыТоржествИБанкетов);
| Группировка Контрагент Упорядочить ПО Контрагент.Наименование;
|";
Запрос = СоздатьОбъект("Запрос");
Запрос.Выполнить(ТекстЗапроса);
Пока Запрос.Группировка("Контрагент") = 1 Цикл
НоваяСтрока = ТабЗнач.НоваяСтрока();
НоваяСтрока.ДеньТоржест = Запрос.ДеньТоржест;
НоваяСтрока.ВремяС = Запрос.ВремяС;
НоваяСтрока.ВремяПо = Запрос.ВремяПо;
НоваяСтрока.КоличествоПерсон = Запрос.КоличествоПерсон;
НоваяСтрока.Контрагент = Запрос.Контрагент;
Сообщить(Запрос.Контрагент);
КонецЦикла;
КонецПроцедуры



Проверял в отладчике, параметры "ВыбЗалыТоржествИБанкетов", "НачДата", "КонДата" определены правильно. Но цикл не срабатывает, т.к. Запрос.Группировка("Контрагент") = 0
Помогите дилетанту, что тут не так.
25. Angelok Angelok (Angelok) 8 09.06.12 10:10 Сейчас в теме
(1) чаще всего ошибки операционной системы, вирусы, кривая версия платформы
26. Vladimir Gricenko (Gavroch.v) 05.08.12 22:56 Сейчас в теме
Переустановите платформу!
27. 3BEPb777 Семь (3BEPb777) 24.01.16 14:10 Сейчас в теме
на какую и в чём смысл?
Думаю дело в объёме оперативной памяти.
28. 3BEPb777 Семь (3BEPb777) 24.01.16 14:19 Сейчас в теме
Такая проблема возникла при переходе с 7.7 на 8.
При проверки Бухгалтерии падает с этой ошибкой.
оперативки 3 Гб
29. Марианна Гаврикова (гаврюша) 25.01.16 02:11 Сейчас в теме
Если винда XP, то больше 2х ГБ не берет...