Не отрабатывает КД (УТ 11.1 - БП 3.0)

1. anton popov (dexxxqqq) 03.01.17 20:41 Сейчас в теме
Здравствуйте, уважаемые участники форума. Отредактировал код обработчика "Поля поиска" в ПКО "Контрагенты" в штатных правилах обмена. Но никак не хочет отрабатывать как надо. Во всех случаях в приемнике находится один и тот же контрагент с пустым ИНН. В источнике создаю нового, то есть совпадения по идентификатору исключены. Также очищаю соответствия в регистре "Соответствие объектов информационных баз". В настройках ПКО галку "Продолжить поиск по полям поиска, ..." поставил. Цель - исключить контрагентов с пустым ИНН.

Пробовал и такой вариант

Если НомерВариантаПоиска = 1 тогда
	Если СвойстваПоиска["ИНН"] <> "" Тогда
		СтрокаИменСвойствПоиска = "ИНН, КПП";
	КонецЕсли;
КонецЕсли;
...Показать Скрыть


и такой

Если НомерВариантаПоиска = 1 тогда
	Если СвойстваПоиска.Получить("ИНН") <> "" Тогда
		СтрокаИменСвойствПоиска = "ИНН, КПП";
	КонецЕсли;
КонецЕсли;
...Показать Скрыть


и такой

Если НомерВариантаПоиска = 1 тогда
	Если ЗначениеЗаполнено(СокрЛП(СвойстваПоиска.Получить("ИНН"))) Тогда
		СтрокаИменСвойствПоиска = "ИНН, КПП";
	КонецЕсли;
КонецЕсли;
...Показать Скрыть


Отладкой правил для синхронизации пользоваться не умею. В универсальный обмен штатные правила загружаться не хотят.
Найденные решения
9. anton popov (dexxxqqq) 05.01.17 22:12 Сейчас в теме
Разобрался. Надо было измененные правила положить не только в источник под именем ExchangeRules, но и в приемник под имененм CorrespondentExchangeRules. Видимо при прямом подключении достаточно обновить правила источника, но при подключении через FTP нужны на стороне источника и приемника.
Остальные ответы
2. lefthander lefthander (lefthander) 03.01.17 21:18 Сейчас в теме
3. anton popov (dexxxqqq) 03.01.17 21:23 Сейчас в теме
(2) Нет, поиск по УИД оставил. Просто поставил вторую галку "Продолжить поиск по полям поиска, ..."
Интересная штука. Сделал копии баз, там все работает как надо. Причем любой из вариантов, который я написал. Что я не учел? Почему на рабочих базах может не работать?
4. anton popov (dexxxqqq) 04.01.17 01:01 Сейчас в теме
Странная фигня. При подключении через FTP не отрабатывают мои измененные правила. При прямом подключении все ок. В чем может быть дело? Какая разница какой тип подключения?
5. lefthander lefthander (lefthander) 04.01.17 01:16 Сейчас в теме
(4)возможно в номерах сообщений. Обмен должен быть последовательный, если из одной базы будет выгрузка чаще чем из другой, то это не есть хорошо.
(3)все таки попробуйте его отключить.
6. anton popov (dexxxqqq) 04.01.17 13:09 Сейчас в теме
(5)

У меня из одной базы в расписании действительно обмен настроен чаще. А что с этим делать? Номера сообщений совпадают.
Заметил, что не работает еще одно изменение, которое я делал какое-то время назад (совсем не связанное с текущим). Причем совсем ранние изменения отрабатывают нормально. Почистил все кеши, которые только можно. В регистре "соответствия объектов информационных баз" этих элементов нет.

Еще такой момент. Правильно ли я делаю, что правлю ExchangeRules.xml в источнике? Нужно ли править CorrespondentExchangeRules.xml в приемнике?

Отключить поиск по UID попробовал. Ничего не изменилось
7. lefthander lefthander (lefthander) 04.01.17 17:31 Сейчас в теме
(6)как то у вас все в куче. Вы правили поля поиска в ПКО правил обмена. Насколько я понимаю правила из последнего поста - это правила регистрации изменений. Все таки где и что вы правите?
Расписание я всегда настраиваю со сдвигом времени, что бы не было наложений выгрузки/загрузки.
А правите правила в конвертации?
8. anton popov (dexxxqqq) 04.01.17 17:58 Сейчас в теме
(7) Все верно, правлю поля поиска в ПКО правил обмена (файл ExchangeRules.xml из УТ). Правила регистрации - это RegistrationRules.xml, я его не трогаю. В архиве с правилами есть еще третий файл, CorrespondentExchangeRules.xml.

А вопрос собственно про комплект правил в приемнике (БП). Нужно ли править какой-то из этих файлов в приемнике (БП)? Ведь там есть свой комплект правил (CorrespondentExchangeRules, ExchangeRules, RegistrationRules). Используются ли они в моем случае, если обмен идет через FTP?

Я так понял, что ExchangeRules источника (УТ) повторяется в CorrespondentExchangeRules приемника (БП). Для чего это?

Да, правлю в конвертации.
9. anton popov (dexxxqqq) 05.01.17 22:12 Сейчас в теме
Разобрался. Надо было измененные правила положить не только в источник под именем ExchangeRules, но и в приемник под имененм CorrespondentExchangeRules. Видимо при прямом подключении достаточно обновить правила источника, но при подключении через FTP нужны на стороне источника и приемника.
Оставьте свое сообщение