INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Карук Евгения | Руководитель проектов | Центр разработки

«Плюсы и минусы перехода на EDT»

Доклад о преимуществах и недостатках 1С разработки в среде Enterprise Development Tools. - Расскажу о личном опыте работы с этой средой. - Что лично мне в ней нравится, что нет. - Новые возможности среды разработки. - Какие есть проблемы и неудобства при использовании. - В каких случаях и для каких конфигураций с ней имеет смысл работать уже сейчас.

dchumak 16.08.2018 03:00
(20) для того, чтобы записи по КУДИР появились, нужно сделать восстановление последовательности налогового учета УСН. В этом случае, программа проводит документ с режимом проведения неопределено и в коде формируются проводки по УСН.
Общий модуль НалоговыйУчетУСН, процедура ДвиженияУСН()

Процедура ДвиженияУСН(ДокументСсылка, РежимПроведения = Неопределено) Экспорт //
	
	//Получение реквизитов шапки
	СтруктураШапкиДокумента = Новый Структура("Ссылка, ВидДокумента, Дата,  Организация, ДатаОплаты, Оплачено, 
		|ОтражатьВНалоговомУчете, ОтражатьВУправленческомУчете, Подразделение, ПодразделениеОрганизации", 
		ДокументСсылка, ДокументСсылка.Метаданные().Имя, ДокументСсылка.Дата);

	МетаданныеДокумента = ДокументСсылка.Метаданные().Реквизиты;
	Для Каждого Реквизит из СтруктураШапкиДокумента Цикл
		Если МетаданныеДокумента.найти(Реквизит.Ключ)=Неопределено тогда
			Продолжить;
		КонецЕсли;
		СтруктураШапкиДокумента.Вставить(Реквизит.Ключ,ДокументСсылка[Реквизит.Ключ]);
	КонецЦикла;
	
	Если СтруктураШапкиДокумента.ОтражатьВНалоговомУчете=Ложь Тогда
		Возврат;
	КонецЕсли;
		
	Если НЕ ЗначениеЗаполнено(СтруктураШапкиДокумента["ДатаОплаты"]) тогда
		СтруктураШапкиДокумента.Вставить("ДатаОплаты",СтруктураШапкиДокумента.Дата);
	Иначе
		//Особый контроль для документов оплаты
		СтруктураШапкиДокумента.Вставить("ДатаОплаты",?(СтруктураШапкиДокумента.Оплачено,УправлениеДенежнымиСредствами.ПолучитьДатуДвижений(СтруктураШапкиДокумента.Дата,СтруктураШапкиДокумента.ДатаОплаты),СтруктураШапкиДокумента.Дата));
		Если СтруктураШапкиДокумента.ВидДокумента = "ПриходныйКассовыйОрдер" или
			СтруктураШапкиДокумента.ВидДокумента = "РасходныйКассовыйОрдер" Тогда
		//Оплачено или не отражается в упр. учете
			Если СтруктураШапкиДокумента.Оплачено=Истина или СтруктураШапкиДокумента.ОтраженоВОперУчете=Ложь Тогда
				//Формируются движения по регламентированному учету
			Иначе
				//Документ по регламентированному учету не проводится			
				Возврат;
			КонецЕсли; 
		ИначеЕсли СтруктураШапкиДокумента.ВидДокумента = "ПлатежныйОрдерПоступлениеДенежныхСредств" или
			СтруктураШапкиДокумента.ВидДокумента = "ПлатежныйОрдерСписаниеДенежныхСредств" Тогда
			
			СтруктураШапкиДокумента.Вставить("Оплачено", Истина);
			//Формируются движения по регламентированному учету	
		Иначе
			Если СтруктураШапкиДокумента.Оплачено=Ложь тогда
				//Документ по регламентированному учету не проводится			
				Возврат;
			КонецЕсли;
		КонецЕсли; 
	Конецесли;
	
	Если НЕ ПрименениеУСН(СтруктураШапкиДокумента.Организация, СтруктураШапкиДокумента.ДатаОплаты) Тогда
		Возврат;
	КонецЕсли;
	
	Если ПрименениеУСНДоходы(СтруктураШапкиДокумента.Организация, СтруктураШапкиДокумента.ДатаОплаты) Тогда
		Возврат;
	КонецЕсли;
	
	//~//
	ПараметрыПартионногоУчета = глЗначениеПеременной("ПараметрыПартионногоУчета");
	СтруктураШапкиДокумента.Вставить("ПроводитьПоПартиям",ПараметрыПартионногоУчета.СписыватьПартииПриПроведенииДокументовНал);
	
	Если РежимПроведения = Неопределено Тогда
		//Вызвано обработкой вовстановления последовательности. Выполняются все действия (крооме регистрации в последовательности)
		
		//Очистим лишние движения под документами, что бы они не повлияли на результаты запросов
		
		НаборЗаписей = РегистрыНакопления.ВзаиморасчетыУСН.СоздатьНаборЗаписей();
		НаборЗаписей.Отбор.Регистратор.Установить(ДокументСсылка);
		Если ЗначениеЗаполнено(НаборЗаписей.Отбор.Регистратор.Значение) Тогда
			НаборЗаписей.Записать(Истина);
		КонецЕсли;
		
		Если (НЕ ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ОтчетКомиссионераОПродажах")) И
			(НЕ ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПолучениеУслугПоПереработке")) И
			(НЕ ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.АвансовыйОтчет")) И
			(НЕ ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ВозвратТоваровОтПокупателя")) И
			(НЕ ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПоступлениеТоваровУслуг")) И
			(НЕ ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПоступлениеТоваровУслугВНТТ")) И
			(НЕ ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.РегламентныеОперацииНалоговогоУчетаПоУСН")) Тогда
			
			НаборЗаписей = РегистрыНакопления.РасходыПриУСН.СоздатьНаборЗаписей();
			НаборЗаписей.Отбор.Регистратор.Установить(ДокументСсылка);
			Если ЗначениеЗаполнено(НаборЗаписей.Отбор.Регистратор.Значение) Тогда
				
				НаборЗаписей.Прочитать();
				
				Инд=0;
				Пока Инд < НаборЗаписей.Количество() Цикл
					Если НаборЗаписей[Инд].ЭтапПроведения < 0 Тогда
						Инд=Инд+1;
					Иначе
						НаборЗаписей.Удалить(Инд);
					КонецЕсли;
				КонецЦикла;
				
				НаборЗаписей.Записать(Истина);
			КонецЕсли;
		КонецЕсли;
			
		Если (НЕ ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ВозвратТоваровОтПокупателя")) И
			(НЕ ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.РегламентныеОперацииНалоговогоУчетаПоУСН")) Тогда
			
			НаборЗаписей = РегистрыНакопления.КнигаУчетаДоходовИРасходов.СоздатьНаборЗаписей();
			НаборЗаписей.Отбор.Регистратор.Установить(ДокументСсылка);
			Если ЗначениеЗаполнено(НаборЗаписей.Отбор.Регистратор.Значение) Тогда
				
				НаборЗаписей.Прочитать();
				
				Инд=0;
				Пока Инд < НаборЗаписей.Количество() Цикл
					Если НаборЗаписей[Инд].ЭтапПроведения < 0 Тогда
						Инд=Инд+1;
					Иначе
						НаборЗаписей.Удалить(Инд);
					КонецЕсли;
				КонецЦикла;
				
				НаборЗаписей.Записать(Истина);
			КонецЕсли;
		КонецЕсли;
		
	Иначе
		//Вызов из документа. Необходимо зарегистрировать в последовательности
		РегистрацияВПоследовательностиНУ_УСН(СтруктураШапкиДокумента, РежимПроведения);
		
		Если не СтруктураШапкиДокумента.ПроводитьПоПартиям Тогда
			//Дополнительная обработка не производится.
			Возврат;  
		КонецЕсли;
	КонецЕсли; 
	//~\\
    	
	Если ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.АвансовыйОтчет") Тогда
		
		ОтразитьВУСН(ДокументСсылка, "Оплата", СтруктураШапкиДокумента,1);
		ОтразитьВУСН(ДокументСсылка, "Поступление", СтруктураШапкиДокумента,2);
		
	ИначеЕсли 
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.АккредитивПереданный") ИЛИ //~
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.АккредитивПолученный") ИЛИ //~
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ИнкассовоеПоручениеПереданное") ИЛИ //~
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ИнкассовоеПоручениеПолученное") ИЛИ //~
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПлатежноеТребованиеВыставленное") ИЛИ //~
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПлатежноеТребованиеПолученное") ИЛИ //~
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПлатежноеПоручениеВходящее") ИЛИ
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПлатежноеПоручениеИсходящее") ИЛИ
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПлатежныйОрдерПоступлениеДенежныхСредств") ИЛИ
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПлатежныйОрдерСписаниеДенежныхСредств") ИЛИ
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПриходныйКассовыйОрдер") ИЛИ
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.РасходныйКассовыйОрдер") ИЛИ
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПоступлениеДенежныхДокументов") ИЛИ
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ВыдачаДенежныхДокументов") Тогда
		
		ОтразитьВУСН(ДокументСсылка, ,СтруктураШапкиДокумента);
		
	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.АктОбОказанииПроизводственныхУслуг") ИЛИ
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПередачаНМА") ИЛИ  
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.РеализацияУслугПоПереработке") Тогда
		
		ОтразитьВУСН(ДокументСсылка, "РеализацияУслуг", СтруктураШапкиДокумента);
		
	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПередачаОС") Тогда
		Если НЕ ДокументСсылка.ПравоСобственностиПереходитПослеГосРегистрации Тогда
			ОтразитьВУСН(ДокументСсылка, "РеализацияУслуг", СтруктураШапкиДокумента);
		КонецЕсли;
		
	//~//
	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ОтчетКомитентуОПродажах") Тогда
		
		Если УправлениеЗапасами.ИспользуетсяРасширеннаяАналитикаУчета(СтруктураШапкиДокумента.Дата) Тогда
			ОтразитьВУСН(ДокументСсылка, "Поступление", СтруктураШапкиДокумента, 0);
			ОтразитьВУСН(ДокументСсылка, "РеализацияУслуг", СтруктураШапкиДокумента, 1);
		Иначе
			ОтразитьВУСН(ДокументСсылка, "РеализацияУслуг", СтруктураШапкиДокумента);
		КонецЕсли;
			
	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ВозвратПереданныхТоваров") Тогда
		
		Если ДокументСсылка.ВидОперации = Перечисления.ВидыОперацийВозвратТоваровПоставщику.ИзПереработки Тогда
			ОтразитьВУСН(ДокументСсылка, "ВозвратИзПереработки", СтруктураШапкиДокумента);
		КонецЕсли;
		
	//~\\
	
	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ВозвратТоваровОтПокупателя") Тогда
		
		Если ДокументСсылка.ДоговорКонтрагента.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СКомиссионером Тогда
			ОтразитьВУСН(ДокументСсылка, "ВозвратСРеализации", СтруктураШапкиДокумента);
		Иначе
			ОтразитьВУСН(ДокументСсылка, "ВозвратОтПокупателя", СтруктураШапкиДокумента, 1);
		КонецЕсли;

	ИначеЕсли
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ВозвратТоваровПоставщикуИзНТТ") ИЛИ //~
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ВозвратТоваровПоставщику") Тогда
		
		Если ДокументСсылка.Товары.Количество() > 0 Тогда
			ОтразитьВУСН(ДокументСсылка, "ВозвратПоставщику", СтруктураШапкиДокумента);
		КонецЕсли;
		
	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ОтражениеЗарплатыВРеглУчете") Тогда
		
		ОтразитьВУСН(ДокументСсылка, "НачислениеЗП", СтруктураШапкиДокумента);
		
	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ОтчетКомиссионераОПродажах") Тогда
		
		Если НЕ ДокументСсылка.УдержатьКомиссионноеВознаграждение Тогда
			ОтразитьВУСН(ДокументСсылка, "УслугаКомиссионера", СтруктураШапкиДокумента,0);
			ОтразитьВУСН(ДокументСсылка, "РеализацияКомиссионером", СтруктураШапкиДокумента,1);
		Иначе
			ОтразитьВУСН(ДокументСсылка, "ЗачетВознагражденияКомиссионера", СтруктураШапкиДокумента,0);
			
			Отказ = Ложь;
			УчетнаяПолитика = ОбщегоНазначения.ПолучитьПараметрыУчетнойПолитики(СтруктураШапкиДокумента.Дата, Отказ, СтруктураШапкиДокумента.Организация, "Нал");
			ВыделятьНДСУСН = ?(Отказ, Истина, УчетнаяПолитика.ПорядокПризнанияРасходовПоНДС = Перечисления.ПорядокПризнанияРасходовПоНДС.ПоОплатеПоставщику);
			
			Если ВыделятьНДСУСН Тогда
				ОтразитьВУСН(ДокументСсылка, "ЗачетВознагражденияКомиссионераНДС", СтруктураШапкиДокумента,1);
				ОтразитьВУСН(ДокументСсылка, "РеализацияКомиссионером", СтруктураШапкиДокумента,2);
			Иначе
				ОтразитьВУСН(ДокументСсылка, "РеализацияКомиссионером", СтруктураШапкиДокумента,1);
			КонецЕсли;
		КонецЕсли;
	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.РеализацияОтгруженныхТоваров") Тогда
		
		ОтразитьВУСН(ДокументСсылка, "РеализацияКомиссионером", СтруктураШапкиДокумента,1);
	
	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ОтчетОРозничныхПродажах") Тогда
		
		ОтразитьВУСН(ДокументСсылка, "Розница", СтруктураШапкиДокумента);
		
	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПередачаТоваров") Тогда
		
		Если НЕ ДокументСсылка.ВидОперации = Перечисления.ВидыОперацийПередачаТоваров.ИзПереработки Тогда
			
			ОтразитьВУСН(ДокументСсылка, "ВПереработку", СтруктураШапкиДокумента);
			
		КонецЕсли;
				
	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПолучениеУслугПоПереработке") Тогда
	//ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПоступлениеИзПереработки") Тогда // БП
		
		ОтразитьВУСН(ДокументСсылка, "УслугаПоПереработке", СтруктураШапкиДокумента);
		ОтразитьВУСН(ДокументСсылка, "ИзПереработки", СтруктураШапкиДокумента , 1);

	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПоступлениеДопРасходов") ИЛИ
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПоступлениеНМА") Тогда
		
		ОтразитьВУСН(ДокументСсылка, "Поступление", СтруктураШапкиДокумента);
		
	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПоступлениеТоваровУслуг") Тогда
		
		Если (ДокументСсылка.ДоговорКонтрагента.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СПоставщиком) И
			ДокументСсылка.ВидОперации <> Перечисления.ВидыОперацийПоступлениеТоваровУслуг.ВПереработку Тогда
			
			ОтразитьВУСН(ДокументСсылка, "Поступление", СтруктураШапкиДокумента);
			
		КонецЕсли;
		
	//~//
	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПоступлениеТоваровУслугВНТТ") Тогда
		
		Если ДокументСсылка.ДоговорКонтрагента.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СПоставщиком И 
			ДокументСсылка.ВидОперации = Перечисления.ВидыОперацийПоступлениеТоваровУслугВНТТ.ОтПоставщика Тогда
			
			ОтразитьВУСН(ДокументСсылка, "Поступление", СтруктураШапкиДокумента);
			
		КонецЕсли;
	//~\\
	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.РеализацияТоваровУслуг") Тогда
		
		Если ДокументСсылка.ДоговорКонтрагента.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СПокупателем
			И (НЕ ДокументСсылка.ВидОперации = Перечисления.ВидыОперацийРеализацияТоваров.ОтгрузкаБезПереходаПраваСобственности) Тогда
			
			ОтразитьВУСН(ДокументСсылка, "Реализация", СтруктураШапкиДокумента);
			
		Иначе
			
			ОтразитьВУСН(ДокументСсылка, "НаРеализацию", СтруктураШапкиДокумента);
			
		КонецЕсли;
		
	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.СписаниеТоваров") ИЛИ
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПередачаМатериаловВЭксплуатацию") ИЛИ
		ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ТребованиеНакладная") Тогда
		
		ОтразитьВУСН(ДокументСсылка, "Списание", СтруктураШапкиДокумента);
	
	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ПеремещениеТоваров") Тогда
		
		ОтразитьВУСН(ДокументСсылка, "Перемещение", СтруктураШапкиДокумента);
		
	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.КомплектацияНоменклатуры") Тогда
		
		ОтразитьВУСН(ДокументСсылка, "Комплектация", СтруктураШапкиДокумента);
		
	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.КорректировкаДолга") Тогда
		
		Если ДокументСсылка.ВидОперации = Перечисления.ВидыОперацийКорректировкаДолга.ПереносЗадолженности Тогда
		
			ОтразитьВУСН(ДокументСсылка, "ПереносЗадолженности", СтруктураШапкиДокумента);
			
		ИначеЕсли ДокументСсылка.ВидОперации = Перечисления.ВидыОперацийКорректировкаДолга.ПроведениеВзаимозачета Тогда	
			
			ОтразитьВУСН(ДокументСсылка, "ПроведениеВзаимозачетаДебитор", СтруктураШапкиДокумента,0);
			ОтразитьВУСН(ДокументСсылка, "ПроведениеВзаимозачетаКредитор", СтруктураШапкиДокумента,1);
			
		ИначеЕсли ДокументСсылка.ВидОперации = Перечисления.ВидыОперацийКорректировкаДолга.СписаниеЗадолженности Тогда		

			ОтразитьВУСН(ДокументСсылка, "СписаниеДебиторскойЗадолженности", СтруктураШапкиДокумента,0);
			ОтразитьВУСН(ДокументСсылка, "СписаниеКредиторскойЗадолженности", СтруктураШапкиДокумента,1);
			
		КонецЕсли;
	//~//
	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.РасчетСебестоимостиВыпуска") Тогда
		
		ОтразитьВУСН(ДокументСсылка, "Выпуск", СтруктураШапкиДокумента);
		
	ИначеЕсли ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.ОплатаОтПокупателяПлатежнойКартой") Тогда
		
		ОтразитьВУСН(ДокументСсылка, "ПереносЗадолженности", СтруктураШапкиДокумента);
	//~\\
	КонецЕсли;
	
	
КонецПроцедуры
Показать


Когда же просто проводишь документ, то данные из КУДИР пропадают до момента следующего восстановления последовательности.
shnurov 16.08.2018 02:37
Я базу получал используя механизмы расчета. Конфигуратор в руки и разбирайтесь как в зупе происходит расчет. В кратце могу сказать что вызывается обработка "МенеджерРасчетаЗарплаты", подготавливаются данные, и вызывается процедура расчета, возвращаются расчетные данные в том числе и база если она есть в начислении. Все это можно посмотреть в любом документе расчета, премия, разовые, начисление зп и др.
Ниже пример кода
		УстановитьПривилегированныйРежим(Истина);
		НачатьТранзакцию();	
		МенеджерРасчета=РасчетЗарплатыРасширенный.СоздатьМенеджерРасчета(Объект.ПериодРегистрации, Объект.Организация);
		МенеджерРасчета.НастройкиРасчета.РассчитыватьНачисления=Истина;
		МенеджерРасчета.ИсключаемыйРегистратор=Объект.Ссылка;
		СотрудникиДляНачислений=МенеджерРасчета.ТаблицаСотрудников();
		СотрудникиДляРассчета=Новый Массив;
		Пока ВыборкаСотрудник.Следующий() Цикл
			СотрудникиДляРассчета.Добавить(ВыборкаСотрудник.Сотрудник);
			НоваяСтрока=СотрудникиДляНачислений.Добавить();
			НоваяСтрока.Сотрудник=ВыборкаСотрудник.Сотрудник;
			НоваяСтрока.ДатаНачала=Объект.ПериодРегистрации;
			НоваяСтрока.ДатаОкончания=ВыборкаСотрудник.ДатаОкончания;			
		КонецЦикла;		
		МенеджерРасчета.НастройкиРасчета.Сотрудники=СотрудникиДляРассчета;						
		ОтборМенеджераРасчета=МенеджерРасчета.СоздатьОтборы();
		ОтборМенеджераРасчета.Подразделение=Объект.Подразделение;
		МенеджерРасчета.ЗаполнитьНачислениеЗарплаты(СотрудникиДляНачислений, ОтборМенеджераРасчета);
		МенеджерРасчета.РассчитатьЗарплату();
		ОтменитьТранзакцию();	
		УстановитьПривилегированныйРежим(Ложь);
Показать


Далее нужная вам таблица
МенеджерРасчета.Зарплата.Начисления

ее анализируете.
PhoenixAOD 16.08.2018 02:05
biformatus 16.08.2018 01:41
А есть способ сделать нормальный адрес, например субдомен.домен.ком/имя подкаталога хранилища?
user1023212 16.08.2018 01:16
(18)
"ТекушийПользователь = ПользователиИнформационнойБазы.ТекущийПользователь().ПользовательОС;"



работает
))) спасибо
DimchK 16.08.2018 00:32
Дык я же решение отметил! выше смотри.
DimchK 16.08.2018 00:30
(14)Забыл написать решение, а щас забыл решение smile:( Кажись чёта с портами было что-то ну очень элементарное. Увы.
khabibullin.tu 16.08.2018 00:26
(6) Версия ЗУП ПРОФ - самая последняя, регистр расчета - "Начисления"
nvv1970 16.08.2018 00:17
(20) ну если бы просто компрессию включил (page), то раз в 5-10 тоже получил бы... Без синхронизации, в своей же базе... Но это конечно не колоночное хранение (
DarkUser 16.08.2018 00:14
Какая точно версия конфигурации ЗУП 3.1 и как называется регистр расчета в котором есть искомая запись?
user1022969 16.08.2018 00:10
(14)Вы о чем? Можете скрин прислать, где там в УПП 1.3 время есть?
nolodin 16.08.2018 00:08
На закладке "Анализ прав пользователей" при нажатии на кнопку "Обновить" выдается ошибка "Неверное имя колонки". Платформа 8.3.11.2954, Конфигурация Комплексная автоматизация 2 (2.2.4.81)
obmanOZ 16.08.2018 00:05
(13) У меня ИП применяет патент, в УТ отмечен именно как ИП. Если Вы говорите, что можно прилепить, Вы знаете как? Я не нашел такой возможности
pwn 15.08.2018 23:38
(13) Спасибо за комментарий. Беда в том, что вы комментируете "работу" отчета, который был сделан более шести лет назад для конфигурации, которая на текущий момент не поддерживается фирмой 1С. За окном 15 августа 2018 года. Отчет был сделан в в декабре 2011 года. It looks very strange for me. Но за замечание, спасибо. Правда, учитывая выше изложенное, ваш пост выглядит как спам или троллинг. Но я могу ошибаться, конечно.
maxPromC 15.08.2018 23:23
khabibullin.tu 15.08.2018 23:22
(4) Это ничего не даст, мне нужна именно база в разрезе всех начислений, на которые накручена премия
Fox-trot 15.08.2018 23:20
(8)попробуй уменьшить время ожидания сервера, и тогда по идее в логах можно будет прочитать об ошибке
хотя канешна по хорошему я б начал с самих настроек. к примеру адрес указан как имя днс или ийпи?
DarkUser 15.08.2018 23:13
Можно. Только это не серии надо делать, а точки. Как правило при добавлении новой точки надо по значению поискать её наличие в списке точек. И если она уже есть, то не создавать новую а использовать существующую и устанавливать значение с новой серией и новой/существующей точкой. Тогда все серии будут в одну линию, если точка у них одинакова. Так же не стоит забывать о том, что точки на диаграмме Ганта могут быть вложенными, по типу дерева значений.
Ko1t 15.08.2018 23:13
(30)
Имя пользователя на английском.

На всякий случай, чтобы наверняка, привожу картинку что я имею ввиду под именем пользователя.
И это имя должно быть без пробелов и латиницей:
https://ibb.co/fcWyAp

Если все-таки не работает, тогда опять же попробуйте закомментировать код в котором устанавливается поле "reporter" в строке: 2066
&НаКлиенте
Процедура СоздатьОбновитьЗапросОбработка(ДопПарам=Неопределено, Отказ=Ложь)
....
//ДобавитьПолеЗапросаДляИзмененияВJira(fields,"reporter","name","ПарамЗапросJira","Reporter_Name");
...
КонецПроцедуры
Fox-trot 15.08.2018 23:12
Запрос.УстановитьПараметр("%Наименование%", Наименование);

оно?
niko 15.08.2018 23:11
УТ 11. Документ пересчет товаров, при проведении возникает ошибка "в строке количество должно равняться 1 т.к. политика учета серий товара предусматривает, что количество по любой серии этого товара всегда будет равно 1". Подскажите, как провести документ?
Cooler 15.08.2018 23:09
(2)
Сердце чует, что можно как-то просто решить эту задачу
Ага, проще некуда: сумму премии разделить на процент премии и умножить на 100 - профит!
Infector 15.08.2018 23:04
Те, кто слишком проникся 7.7 обычно бросаются в глаза. Еще привычки к именам переменных в схожих алгоритмах сохраняются.
У меня выработалась во-первых привычка дробить процедуры, во-вторых оформлять запросы так, чтобы открывались конструктором при любом раскладе, СтрЗаменить() всегда в них вместо склеивания строк.
Правда видоизменяется со временем все, в том числе и стиль по мере обретения новых знаний.
khabibullin.tu 15.08.2018 22:54
Коллеги, ну хоть кто-нибууууууудь знает ?
milov.aleksey 15.08.2018 22:52
При загрузке из экселя поиск значения по наименованию. Но это среди присвоенных значений, а как найти в списке значений свойств?
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| КонтрагентыДополнительныеРеквизиты.Значение КАК Значение
|ИЗ
| Справочник.Контрагенты.ДополнительныеРеквизиты КАК КонтрагентыДополнительныеРеквизиты
|ГДЕ
| КонтрагентыДополнительныеРеквизиты.Свойство = &Свойство
| И КонтрагентыДополнительныеРеквизиты.Значение.Наименование ПОДОБНО &Наименование";
Запрос.УстановитьПараметр("Свойство", Свойство);
Запрос.УстановитьПараметр("Наименование", Наименование);
Infector 15.08.2018 22:45
В свое время намучался с интернет-почтой из встроенного языка. CDO задачу выполняет без лишних заморочек и заскоков, а главное админам из Европы не нужно ничего втирать почему что-то нужно подшаманить, когда у них все работает и про капризы загадочной русской платформы.
dsdred 15.08.2018 22:45
Напишите какие сертификаты необходимо добавить.

Отсутствует Проф по «1С:ERP Управление предприятием 2»
pm74 15.08.2018 22:43
(1)
раз HR попросила очистить шредер .
я - " почему уборщица не сделает "
ответ (дословно) - " этим должны заниматься специально обученные люди "
ок вытряхнул . (потом уборщицу нашел и ей показал)

В общем если кому нибудь в Че нужны квалифицированные услуги по очистке шредера, замене картриджа , распечатке на принтере или отправки е-майл обращайтесь. Качественно. Дорого.

з.ы. сейчас раз в квартал в одной фирме (совместно с бухгалтером) делаю авансовые сф ( осн, комиссионер , бппс, по сделкам , взаимозачеты .. гемор вобщем)
VKuser183781430 15.08.2018 22:40
Проблема следующего характера: имеется серверная и клиентская платформа (8.3.12.1567), конфигурация Управление нашей фирмой (1.6.13.54) документ Поступление на счет, при загрузке документов с банка при отмене проведения возникает ошибка - Запись не верна! Значение поля не соответствует установленному отбору: ФактОплатыДокументов: (Регистр сведений: Факт оплаты документов; Поле: Документ) выяснил что ошибка появляется только в серверном варианте работы 1с + postgres при выгрузке ИБ в файловый режим работы, отмена проведения документа проходит нормально. В чем может быть причина? Версии серверной и клиентской платформы обновлены до последнего релиза, по битности совпадают, пробовал накатывать три платформы на релиз меньше соответственно... В чем может быть причина ошибки и как её можно устранить? Перепробовал уже все что знал и не знал)
SanyMaga 15.08.2018 21:34

ВЫБРАТЬ
    ТоварыНаСкладахОстаткиИОбороты.Номенклатура,
    ТоварыНаСкладахОстаткиИОбороты.Характеристика,
    ТоварыНаСкладахОстаткиИОбороты.ВНаличииНачальныйОстаток,
    ТоварыНаСкладахОстаткиИОбороты.ВНаличииПриход,
    ТоварыНаСкладахОстаткиИОбороты.ВНаличииРасход,
    ТоварыНаСкладахОстаткиИОбороты.ВНаличииКонечныйОстаток,
    ТоварыНаСкладахОстаткиИОбороты.Регистратор,
    Закупки.СуммаОборот / Закупки.КоличествоОборот КАК СтоимостьЕденицы,
    Закупки.СуммаОборот,
    Закупки.КоличествоОборот

ИЗ
    РегистрНакопления.ТоварыНаСкладах.ОстаткиИОбороты(, , Авто, , ) КАК ТоварыНаСкладахОстаткиИОбороты
        ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.Закупки.ОстаткиИОбороты(, , Авто, , )  КАК Закупки
        ПО ТоварыНаСкладахОстаткиИОбороты.Номенклатура = Закупки.АналитикаУчетаНоменклатуры.Номенклатура
            И ТоварыНаСкладахОстаткиИОбороты.Характеристика = Закупки.АналитикаУчетаНоменклатуры.Характеристика
            И ТоварыНаСкладахОстаткиИОбороты.Период= Закупки.АналитикаУчетаНоменклатуры.Период

Показать
dsdred 15.08.2018 21:14
(19)Ну DDoS-атака это уже отдельный вопрос администрирования.
khabibullin.tu 15.08.2018 21:11
Или такое вообще невозможно ? Сердце чует, что можно как-то просто решить эту задачу
Agema 15.08.2018 20:28
panteranew 15.08.2018 20:18
(16)ВЫ МОЛОДЕЦ С БОЛЬШОЙ БУКВЫ! Получилось, пока не знаю по остаткам посмотрю, но суммы без минусов! Спасибо добрый человек smile:-)
WKBAPKA 15.08.2018 20:15
Dem1urg 15.08.2018 20:14
(35) Да, все верно. В слайде опечатка. Должно быть

Строка2 = Таблица2[Сч2];
khabibullin.tu 15.08.2018 20:14
Коллеги, очень нужна помощь знающих ЗУП 3.1. В регистре расчета есть запись с рассчитанной премией. Каким образом можно получить программно базу по этой строке ?

Читал в интернете про виртуальную таблицу "База" регистра расчета, но не понял как ей пользоваться

Вакансии


Программист 1С
Москва
зарплата от 100 000 руб. до 200 000 руб.
Полный день

Преподаватель 1С
Санкт-Петербург
Полный день

Удаленный ИТ-журналист
Санкт-Петербург
По совместительству

Удаленный бизнес-аналитик 1С
Санкт-Петербург
Временный (на проект)