madonov 16.10.2018 02:09
(188) В ЗУП3 6-НДФЛ неплохо собирается штатными методами. Нужно только в них разобраться.
С моей стороны разработка аналоги для ЗУП3 не планируется.
user677208_alexander.niko 16.10.2018 01:56
Доброго времени суток!
Нет возможности принять участия. Какие есть или планируются возможности просто посмотреть записи докладов и выступлений в будущем?
kote 16.10.2018 01:55
(42)
Имел ввиду переменную Сервер в выражении
#Если Сервер Тогда..
kote 16.10.2018 01:53
(41) intellisens зло. Все должно быть просто и понятно без этих дьявольских штучек!
tormozit 16.10.2018 01:19
(40)
а разве директивы не поддерживают Истина/Ложь?
Если сомневаешься, лучший способ проверить верность утверждения - проверить его самому. Тем более проверить это можно очень легко и быстро.
В конечном итоге - ЭтоСервер - это же тоже булева переменная, не?
Не понял. Что такое ЭтоСервер? Можешь подробнее описать свою мысль?
tormozit 16.10.2018 01:16
(39) Причем тут имена переменных? Статью то прочитал? =)
oldcopy 16.10.2018 00:48
Да нормальное решение, чего все на человека накинулись? Потому что лучше делать резервные копии так, чем не делать их вообще.
kote 16.10.2018 00:43
Хмм.. а разве директивы не поддерживают Истина/Ложь?
В конечном итоге - ЭтоСервер - это же тоже булева переменная, не?
kote 16.10.2018 00:41
Чего только люди не придумают - лишь не давать нормальные имена переменным и/или не рефакторить код.. ))
user856012 16.10.2018 00:37
(1)
опыт работы с электронной подписью в VPN соединении через веб-клиент в браузере IE
Поскольку речь идет о связке IE+криптография, то я бы обязательно озаботился тем, чтобы адрес веб-сервера был добавлен в перечень надежных узлов IE на клиентских ПК: "Свойства браузера" - "Безопасность" - "Надежные узлы" - "Узлы" - "Добавить".

Без этого IE с ЭЦП корректно не работает даже без VPN (проверено на Контур-Экстерн, Госуслуги, Госзакупки и т.д.)
user1068267 16.10.2018 00:34
Ваша ссылка не открывается.
Мой код нельзя превратить в рабочий?
kote 16.10.2018 00:29
Проекты сами по себе бывают провальными - со Скрамом и без - и без анализа всей картины не ясно, а не загнулся бы их проект сильно раньше (как ни иронично, съэкономив денег собственнику и заказчику)..

А тот, кто ищет спасения/причины неудач в скраме - по сути инструменте организации работы - зря есть свой хлеб..

По моему, в статье - персонажи похожи на постоянных клиентов сект.. вот и весь ответ. Ну и да, разного рода консультанты разного рода подходов будут всегда на них кормиться - зачастую сами являясь сектантами.. подобное тянется к подобному в социуме
eksetro 16.10.2018 00:11
Может лучше воспользоваться типовой наработкой? https://курсы-по-1с.рф/articles/2017-02-12-two-methods-for-inventory-check/ , если нет еще ссылки на документ, то табличную часть преобразовать в таблицу значений и использовать в запросе.
Armando 15.10.2018 23:57
(31) Чтобы было легче отвечать на такие вопросы, я вопросительное предложение воспринимаю как утверждение: "Вам пакет не нужен". Если утверждение верно говорю Да, иначе Нет.
rasdag 15.10.2018 23:48
(2) Отличие в том, что пока у них нет аналитики по - источникам финансирования в проводках, и как я понял из разговоров - они его тупо забыли добавить - во всяком случае не задумывались об этом. Плюс в том - что нет защиты как у Раруса - и соответственно отпадает куча геморроя с установками СЛК и т.д. Надеюсь все таки, что доведут до ума и можно будет спокойно от Раруса отказаться.
user856012 15.10.2018 23:48
(3)
программный ключ (установлен на ПК)
Что за "программный ключ"? Что-то связанное с ЭЦП (если это - вопрос дилетанта, то прошу извинить: до сих пор имел дело в основном с КриптоПро)?

Или имеется в виду программная лицензия 1С:Предприятие?

аппаратный ключ на eToken вставленный в ПК
В принципе, тот же вопрос. Хотя аппаратная лицензия 1С поставляется на HASP, а не на eToken.
Dzenn 15.10.2018 23:45
(36) использую, конечно, но стараюсь, чтобы процедуры/ функции были как пуля smile;-) однозначными и линейными. Нелинейность и ветвления можно организовать в другой процедуре, в которой не будет нашей переменной
Xershi 15.10.2018 23:41
(1) на ИС есть публикации. На основе бсп в фоне запустить можно серверные вызовы.
fixin 15.10.2018 23:38
Проверил, в последней версии реквизиты GUID в табличной части не очищаются. Но это связано с тем, что теперь их можно редактировать. А так логический косяк в построении алгоритма остался, но там только для предопределенных элементов пропускается копирование реквизитов, так что норм.

Советую сделать выгрузку и загрузку объекта в XML, просто в текстовое поле, чтобы перекидывать из базы в базу.

Также можно выгружать/загружать ТЧ в MXL, как это сделано в моем редакторе реквизитов под ОФ.
tormozit 15.10.2018 23:33
(35) Т.е. ты не используешь условный оператор (оператор ветвления) в методах?
Функция ФУ(Фа)
	Если Фа = 1 Тогда
		Спр = Справочники.Номенклатура.НайтиПоКоду("").ПолучитьОбъект(); ВызватьИсключение "Отладка"; 
	ИначеЕсли Фа = 2 Тогда
		Спр = Справочники.Номенклатура.НайтиПоКоду("").ПолучитьОбъект(); ВызватьИсключение "Отладка"; 
	Иначе
		Спр = Справочники.Валюты.НайтиПоКоду("").ПолучитьОбъект(); ВызватьИсключение "Отладка"; 
	КонецЕсли; 
КонецФункции
Показать

Чтобы покрыть такой код сценарным тестом, пользователю нужно будет выполнить такие действия, чтобы сработала каждая ветвь условия.
Dzenn 15.10.2018 23:27
(34) я использую это в рамках одной процедуры/функции, а в рамках одной процедуры/функции нелинейного кода у меня не бывает в принципе
SaperVodichka 15.10.2018 23:24
(2) спасибо, за информацию, но тема ещё не закрыта:

1) аппаратный ключ на eToken вставленный в ПК
веб-клиент + VPN = не виден
тонкий-клиент + VPN = не виден
тонкий клиент в сети = не виден
(Примечание: тут попробуем совет установить утилиту «eToken PKI Client» написал админу)

2) программный ключ (установлен на ПК)
тонкий клиент + VPN = виден
веб-клиент + VPN = не виден

может ещё есть опыт у кого, или рабочая схема с использованием VPN и IIS в связке, возможно в IIS проблема, что он доступ к публикации даёт, но расширения работы с файлами и криптографией как-то блокирует?
tormozit 15.10.2018 23:24
(29)
если забыл удалить — 1С сама мне об этом напомнит вызовом исключения
Это если код линейный, что бывает далеко не всегда. Если будет например оператор ветвления, то опасность оставить такой код вырастает ощутимо, а каждый раз делать поиск маркера в тексте - утомительно.
В общем предложенный тобой прием понятен, но он опаснее, чем описанные в статье. Ведь фрагменты из статьи можно и оставлять и удалять в любой момент и при этом логика программы не подвергается риску изменения.
RaVeNMeN 15.10.2018 23:23
Добрый день.
Терминальный доступ, на сервере стоит Эксель.
Но почему то появляется ошибка - скрин.
Что нужно сделать?

апдейт: файл был открыт... нет уже ошибки smile:)
tormozit 15.10.2018 23:16
(31) Да, вопросы с отрицанием перед глаголом тоже в этом плане раздражают. Для однозначного восприятия ответа они требуют включения глагола в ответ. А ведь задающему вопрос часто всего то нужно убрать частицу "не" перед глаголом, чтобы отвечающий мог использовать варианты "да/нет".
mp40 15.10.2018 23:02
Подключаемый внешний отчет по клиентам. Выводит форму акта сверки по взаиморасчетам с клиентом. Для конфигурации Розница 2.2 .
Маргарита Иванова 15.10.2018 22:53
Нужно сделать так, чтобы при попытке списать со склада товар, которого там нет, выводилась ошибка. Код выдает ошибку на списание любого товара, вне зависимости есть он на складе или нет, и выводит ее 4 раза подряд. Может кто-нибудь помочь решить проблему?

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| СкладСИЗОстатки.СИЗ
|ИЗ
| РегистрНакопления.СкладСИЗ.Остатки КАК СкладСИЗОстатки"
;
РезультатЗапроса = Запрос.Выполнить();
ТаблицаЗначений = Новый ТаблицаЗначений;
ТаблицаЗначений.Колонки.Добавить("СИЗ");
ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
Для каждого СтрокаТабЧасти Из СписаниеС Цикл
Если СтрокаТабЧасти.СИЗ <> ВыборкаДетальныеЗаписи.СИЗ
Тогда
НоваяСтрока = ТаблицаЗначений.Добавить();
НоваяСтрока.СИЗ = СтрокаТабЧасти.СИЗ;
КонецЕсли;
КонецЦикла;
КонецЦикла;
Если ТаблицаЗначений.Количество() > 0 Тогда
Для каждого Строка Из ТаблицаЗначений Цикл
Сообщение = Новый СообщениеПользователю;
Сообщение.Текст = "На складе отсутствует " + Строка.СИЗ + ". ";
Сообщение.Сообщить();
КонецЦикла;
Отказ = Истина;
КонецЕсли;

Движения.СкладСИЗ.Записывать = Истина;
Для Каждого ТекСтрокаСписаниеСиз Из СписаниеС Цикл
Движение = Движения.СкладСИЗ.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.СИЗ = ТекСтрокаСписаниеСИЗ.СИЗ;
КонецЦикла;
АлександрВладимирович 15.10.2018 22:50
Лично я использовал для этого управленческую организацию.
РКО в управленческой кассе. Управленческая организация подключается в разделе фин результат и предприятие
mrm1212 15.10.2018 22:36
В разгар санкций очень актуальная статья, винду как запретят, так все на убунту пересядем!!! =))))
bumazhkin 15.10.2018 22:34
Смены открываются и закрываются без проблем. Соответственно и в ККМ и в системе статус смены одинаковый.
erazh 15.10.2018 22:22
Есть ли какие-нибудь способы создания фонового задания из внешнего отчета/обработки без внесения изменений в общие модули конфигурации?

Цель: Создание формы-ожидания, когда отчет формируется слишком долго. (Чтобы клиентская часть не блокировалась)
Saifa 15.10.2018 22:22
(41) Не понимаю, как посмотреть версию БПО у например, вот этого сканера https://www.scanstore.ru/catalog/scane...-02-A.html
У конфигурации знаю - 2.0.4.10. Где еще что посмотреть у сканера?
spacecraft 15.10.2018 22:21
(72)
писать в стиле ТДД вполне можно не писав при этом сами тесты.

Это как? Само название как бы говорит, что тесты вначале.

Если речь про попытку "писать в стиле ТДД" в 1С, то даже обсуждать это не буду. Уже говорил почему.

TDD это совсем не то, что вы себе представляете. Это нужно вникнуть в методологию. Научиться мыслить в нужном направлении.

Это как начать писать код под управляемые формы после обычных. Требуется перестраивать мышление, а не пытаться на УФ писать по привычке как на ОФ.
Чтобы не было недопонимания: это не прямая аналогия.
1c-intelligence 15.10.2018 22:12
(59)
я, правда, за последние месяцы только эту статью прочитал

вот ведь а... Что такое с людьми творится.
pentanom 15.10.2018 22:08
На просторах интернета нашел:

В обшем модуле МенеджерОбменаЧерезУниверсальныйФормат
В процедуре ПКО_Документ_СборкаТоваров_ПриОтправкеДанных

ДанныеXDTO.Вставить("Товары", РезультатЗапроса[РезультатЗапроса.Количество() - 2].Выгрузить());

Замените на:
ДанныеXDTO.Вставить("Товары", РезультатЗапроса[РезультатЗапроса.Количество() - 1].Выгрузить());

Кажется работает.
vitkernel1 15.10.2018 21:59
Халяву никто не любит.
Но если окажете благотворительную помощь, наш фонд будет благодарен.
eksetro 15.10.2018 21:58
Наверное, только дописывать. И вообще, клиент от позиции не отказывался, возможно эту позицию вы будете заказывать у другого поставщика.
Техподдержка 15.10.2018 21:54
(3) Добрый день!
Обработка писалась специально для УТ 11.4, на ERP 2.4 её тестирование не производилось, поэтому не могу сказать.
Spirit007 15.10.2018 21:51
Если УТ 10.3 на поддержке, значит у конфигурации режим совместимости 8.2 -никаких расширений быть не может. Если не хочется ломать форму на поддержке, то можно копированием с основной создать новую форму и назначить ее основной формой объекта и ее уже изменять. При обновлении на новый релиз не забывать менять основную форму с типовой на свою.
Timur.V 15.10.2018 21:43
Если разбираться с нуля, можно начать со следующих ссылок:
1) Общие сведения о Microsoft Crypto API
2) Криптопровайдеры. API для работы с криптосервисами Windows, ссылка (две страницы).
3) Концепция CryptoAPI, ссылка.

После изучения темы по CryptoAPI, начинайте копать тему по eToken.

Где найти драйверы для данного токена?
Для работы с «eToken» используется утилита «eToken PKI Client». Загрузить установочный файл можно с этой страницы.

И у вас какой-то усложненный вариант решения проблемы.
1) Если подключаться с той же машины к публично опубликованной базе на веб-сервере apache, то расширения устанавливаются.
2) Теперь нужно проверить работу на соседнем компьютере (без vpn, в локальной сети)
3) а уж потом разбираться с vpn
acsent 15.10.2018 21:35
(71) писать в стиле ТДД вполне можно не писав при этом сами тесты.
когда творишь процедуры могут по 100 раз меняться - это нужно 100 х 500 тестов переписывать
PS творишь - это НЕ то когда пишешь по ТЗ. дорбавьте на форму реквизит "А". при его изменении должен измениться реквизит "Б"

Вакансии

Программист 1С
Нижний Новгород
зарплата от 120 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 120 000 руб.
Полный день

Программист 1С
Новосибирск
зарплата от 80 000 руб. до 100 000 руб.
Полный день

Системный аналитик
Новосибирск
зарплата от 80 000 руб. до 100 000 руб.
Полный день

Программист 1С
Салехард
зарплата от 80 000 руб. до 200 000 руб.
Полный день