«1С:УНФ 1.6.23»: CRM, интеркампани и улучшенная форма подбора товаров

0. Infostart 19.10.20 16:36 Сейчас в теме
В конфигурации обновили возможности CRM, поддержали новые требования к маркировке, а также добавили целый ряд других давно обещанных возможностей.

Перейти к новости

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Rebl 29.10.20 10:47 Сейчас в теме
Все хорошо, за исключением того что вызов этой новой формы подбора безбожно тормозит на файловых базах. По секунд 30 висит. А также теперь висять верхние группы номенклатуры при включенной галке показывать внутреннюю номенклатуру. В общем работать с данным релизом в режиме файловой базы стало просто не возможно.
2. LeonidKr 30.10.20 12:54 Сейчас в теме
(1) Эмм... Обновил вот конфу до 23 - его релиза. Файловая база. 4 пользователя, 30 тыс. позиций. 25 групп, максимальная вложенность 3 уровня. Не замечаю тормозов, а по сравнению с старой формой подбора, вообще летает все. Как я понял, они адаптировали форму списка и форму выбора номенклатуры под форму подбора, ну и еще всяких плюшек довинтили. А форма выбора и форма списка у вас не тормозит?
3. Rebl 31.10.20 14:37 Сейчас в теме
(2)Позиций ~11000, 12 групп, максимальная вложенность 5 уровней. Единственное - много видов цен рассчитывающихся как процент от учетной (созданы для постоянных клиентов). Тормозит именно открытие формы выбора из документов ввода. Например открываем заказ клиента - добавить позицию - показать все - и получаем зависон на 15-30 секунд. Далее открываем заказ клиента - подбор - и получаем зависон на 15-30 секунд. Далее открываем номенклатуру - нажимаем любою верхнюю группу (именно верхнюю) - и при включенной галке показывать вложенную номенклатуру - получаем зависон на 15-30 секунд. Все остальное работает без проблем, за исключением того открытия Администрирования. Но тут на сайте есть расширение решающее эту проблему.
4. LeonidKr 02.11.20 14:28 Сейчас в теме
(3) А версию платформы обновляли? Столкнулся с проблемой что у меня нечто подобное появилось на платформе 8.3.18.
5. Rebl 02.11.20 14:55 Сейчас в теме
(4) Да платформа обновилась до 8.3.18. Но УНФ не работает на 8.3.18 максимальная совместимость в версией 8.3.16.
6. Rebl 02.11.20 15:00 Сейчас в теме
(4) Проверил на 1С:Предприятие 8.3 (8.3.16.1148) проблема ушла но ругается на старую версию 1с
7. Rebl 02.11.20 15:05 Сейчас в теме
1С:Предприятие 8.3 (8.3.17.1549) - тоже нормально отрабатывает, 8.3.18 - уже глючит.
8. LeonidKr 03.11.20 12:03 Сейчас в теме
Используйте версию 8.3.17.1549. На ней все норм и УНФ не ругается на версию.
9. dyahon 10.11.20 17:28 Сейчас в теме
Мне очень нравится конфигурация УНФ, но механизм "Интеркампани"...

Обновил копию базы, чтобы протестировать механизм:

1) Закрытие месяца - перестало запускаться,

потому что ошибка в функции:
Функция НужноЗаполнятьДокументыПередачТоваровМеждуОрганизациями(Организация, ДатаПроверки) Экспорт
	
	Если Не ПолучитьФункциональнуюОпцию("ПередачаТоваровМеждуОрганизациями") Тогда
		Возврат Ложь;
	КонецЕсли;
	
	Запрос = Новый Запрос;
	Запрос.Текст =
	Запрос = Новый Запрос(
	"ВЫБРАТЬ Первые 1
	|	РезервыТоваровОрганизацийОстатки.Организация КАК Получатель
	|ИЗ
	|	РегистрНакопления.РезервыТоваровОрганизаций.Остатки(
	|			&ДатаПроверки,
	|			Организация = &Организация) КАК РезервыТоваровОрганизацийОстатки");
	Запрос.УстановитьПараметр("ДатаПроверки", ДатаПроверки);
	Запрос.УстановитьПараметр("Организация", Организация);
	
	Возврат Не Запрос.Выполнить().Пустой();
	
КонецФункции
Показать

2) Помощник создания перепродаж - не считает что нужно создавать документы за период, потому что берет остатки по регистру на начало месяца - поэтому нужно выбрать Декабрь2020, чтобы создать документы перепродажи за Ноябрь2020
3) После создания документов перепродажи - удаляются движения по РН "Резервы организаций" у всех предыдущих документов
(Почему не сторно?, почему за весь период? - неизвестно)
Запрос = Новый Запрос;
	
	Запрос.УстановитьПараметр("Получатель", ОрганизацияПолучатель);
	Запрос.УстановитьПараметр("ПериодРегистрации", Объект.ПериодРегистрации);
	Запрос.Текст =
	"ВЫБРАТЬ РАЗЛИЧНЫЕ
	|	Резервы.Регистратор КАК Регистратор
	|ИЗ
	|	РегистрНакопления.РезервыТоваровОрганизаций КАК Резервы
	|ГДЕ
	|	Резервы.Период <= &ПериодРегистрации
	|	И Резервы.Организация = &Получатель";
	Выборка = Запрос.Выполнить().Выбрать();
	
	Пока Выборка.Следующий() Цикл
		Набор = РегистрыНакопления.РезервыТоваровОрганизаций.СоздатьНаборЗаписей();
		Набор.Отбор.Регистратор.Значение = Выборка.Регистратор;
		Набор.Записать();
	КонецЦикла;
Показать

4) Созданные документы перепродажи - по РН "Запасы и затраты" - списывают запасы с организации-отправителя, но на Организацию-продавца - приход не создается
5) Вместо себестоимости в РН "Запасы и затраты" записывается цена продажи

Чем дальше смотрю - страшнее становится, такое ощущение, что до релиза функционал никто не тестировал
11. marengo75 10.12.20 21:58 Сейчас в теме
(9) у Вас по прежнему так работает интеркомпани ?
10. user1492320 12.11.20 17:46 Сейчас в теме
Здравствуйте!
Подскажите, интеркампани работает для производственных компаний? Например, чтобы компании Х произвести пельмень нужна мука, которая находится на общем складе, но куплена компанией У.
Оставьте свое сообщение
Вопросы с вознаграждением