Сборка мобильного приложения на Сборщик мобильных приложений(8.3.24.68)

1. PaulSparrow 14.06.24 12:57 Сейчас в теме
Доброго дня.
Подскажите, кто собирал мобильное приложение под Андроид на Сборщике мобильных приложений(8.3.24.68).
Какие вы JDK использовали и настройки Android Studio?
То и дело сборка вылетает с ошибками.
Найденные решения
10. PaulSparrow 14.06.24 14:37 Сейчас в теме
Немного подразобравшись и получив тут помощи все получилось собрать.
Сборщик мобильных приложений(8.3.24.68)

[info] Версия ОС : Windows x86-64, Microsoft Windows 10 version 10.0 (Build 19045)
[info] Версия платформы : 8.3.24.1586 Windows x86-64
[info] Версия сборщика : 8.3.24.68
[info] Номер мобильной версии : 8.3.24.77
[info] Путь к Java : C:\Java\jdk-17.0.11
[info] Архитектура Java : 64
[info] Версия Java : java version "17.0.11" 2024-04-16 LTS
[info] Версия Android SDK : 33, Android SDK Platform 13

Суть дела изначально в ошибке:
Error occurred during initialization of VM
Could not reserve enough space for 1572864KB object heap
-----
Изначальная версия JDK была 32 разрядной. Перешел на 64 - и эту ошибку удалось победить. На крайний случай в интернете нашел, что в конфе самого сборщика есть в коде настройки как переопределить зарезервируемое количество оперативной памяти. Оно для 32-х и 64-х бит разное. Но лучше проще - брать 64bit версию JDK.

По второй ошибке:
> Task :mergeSignReleaseResources
FAILURE: Build failed with an exception.
* What went wrong:
Execution failed for task ':processSignReleaseMainManifest'.
> Manifest merger failed with multiple errors, see logs
-----
В мобильном приложении присутствует внешняя компонента. Вся проблема заключалась в ней. В ней есть конфликт:
C:\Public\tcd\mab-d2722694-64f0-418f-9cef-06c05cc7f3b8\AndroidManifest.xml:46:2-72 Warning:
Element uses-permission#android.permission.ACCESS_WIFI_STATE at AndroidManifest.xml:46:2-72 duplicated with element declared at AndroidManifest.xml:33:2-72
Тут нужно залезть в саму компоненту - выгрузить её на компьютер из конфигуратора, распаковать. Найти AndroidManifest.xml в которой найти соответствующую строчку (<uses-permission android:name="android.permission.ACCESS_WIFI_STATE"/>) и удалить ее. Перезапаковать компоненту и по новой загрузить ее в конфигурацию и по новой собрать на ее основе мобильное приложение.
Приложение должно собраться. У меня же две идентичные по сути компоненты и одну (на которую ругался) я удалил и все собралось.
Остальные ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. laperuz 46 14.06.24 13:23 Сейчас в теме
Собираю на JDK 1.8 давно уже, проблем не было.
Ну и в последнее время платформенным сборщиком, там точно все работает без необходимости устанавливать у себя что-то
3. PaulSparrow 14.06.24 13:32 Сейчас в теме
(2) Можете дать ссылочку на zip с Вашим JDK 1.8?
На оф сайте уже нельзя скачать (блокирует по ip), скачал от стороннего архива, но не совсем уверен, что то что нужно.
5. laperuz 46 14.06.24 13:57 Сейчас в теме
(3)Кажется, что дело в 32-битной JDK, памяти не хватает.

Если не удалят, выложил сюда JDK: https://disk.yandex.ru/d/fSO2cCdbK2tKSg
PaulSparrow; +1 Ответить
6. laperuz 46 14.06.24 14:05 Сейчас в теме
(5)Платформенный сборщик еще в конце апреля собирал на JDK 1.8, сейчас, смотрю, перешли на JDK 17.

[info] Путь к Java               : C:\JAVA
[info] Архитектура Java          : 64
[info] Версия Java               : openjdk version "17.0.10" 2024-01-16 LTS
[info] Путь к Android SDK        : C:\Android\
[info] Версия Android SDK        : 33, Android SDK Platform 13
8. PaulSparrow 14.06.24 14:11 Сейчас в теме
(6) Да, попробовал 17-ую. Такую же новую ошибку выдает:


> Task :mergeSignReleaseResources

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':processSignReleaseMainManifest'.
> Manifest merger failed with multiple errors, see logs
7. PaulSparrow 14.06.24 14:09 Сейчас в теме
(5) Спасибо. Это преодолеть получилось. Но далее снова ошибка вылетает. Не пойму, какие еще объединения завершились с ошибкой и почему...
9. laperuz 46 14.06.24 14:36 Сейчас в теме
4. PaulSparrow 14.06.24 13:38 Сейчас в теме
Вообще ошибку выкатывает такую:

[info] Android 4in1
...

[info] Начинается сборка
To honour the JVM settings for this build a single-use Daemon process will be forked. See https://docs.gradle.org/7.3.3/userguide/gradle_daemon.html#sec:disabling_the_daemon.

FAILURE: Build failed with an exception.

* What went wrong:
Unable to start the daemon process.
This problem might be caused by incorrect configuration of the daemon.
For example, an unrecognized jvm option is used.
Please refer to the User Manual chapter on the daemon at https://docs.gradle.org/7.3.3/userguide/gradle_daemon.html
Process command line: cmd /C start "Gradle build daemon" /B /belownormal /WAIT C:\Java\java-se-8u43-ri\bin\java.exe -Xmx1536m -Dfile.encoding=windows-1251 -Duser.country=RU -Duser.language=ru -Duser.variant -cp C:\Public\tcd\gradle\wrapper\dists\gradle-7.3.3-bin\6a41zxkdtcxs8rphpq6y0069z\gradle-7.3.3\lib\gradle-launcher-7.3.3.jar org.gradle.launcher.daemon.bootstrap.GradleDaemon 7.3.3
Please read the following process output to find out more:
-----------------------
Error occurred during initialization of VM
Could not reserve enough space for 1572864KB object heap


* Try:
> Run with --stacktrace option to get the stack trace.
> Run with --info or --debug option to get more log output.
> Run with --scan to get full insights.

* Get more help at https://help.gradle.org
10. PaulSparrow 14.06.24 14:37 Сейчас в теме
Немного подразобравшись и получив тут помощи все получилось собрать.
Сборщик мобильных приложений(8.3.24.68)

[info] Версия ОС : Windows x86-64, Microsoft Windows 10 version 10.0 (Build 19045)
[info] Версия платформы : 8.3.24.1586 Windows x86-64
[info] Версия сборщика : 8.3.24.68
[info] Номер мобильной версии : 8.3.24.77
[info] Путь к Java : C:\Java\jdk-17.0.11
[info] Архитектура Java : 64
[info] Версия Java : java version "17.0.11" 2024-04-16 LTS
[info] Версия Android SDK : 33, Android SDK Platform 13

Суть дела изначально в ошибке:
Error occurred during initialization of VM
Could not reserve enough space for 1572864KB object heap
-----
Изначальная версия JDK была 32 разрядной. Перешел на 64 - и эту ошибку удалось победить. На крайний случай в интернете нашел, что в конфе самого сборщика есть в коде настройки как переопределить зарезервируемое количество оперативной памяти. Оно для 32-х и 64-х бит разное. Но лучше проще - брать 64bit версию JDK.

По второй ошибке:
> Task :mergeSignReleaseResources
FAILURE: Build failed with an exception.
* What went wrong:
Execution failed for task ':processSignReleaseMainManifest'.
> Manifest merger failed with multiple errors, see logs
-----
В мобильном приложении присутствует внешняя компонента. Вся проблема заключалась в ней. В ней есть конфликт:
C:\Public\tcd\mab-d2722694-64f0-418f-9cef-06c05cc7f3b8\AndroidManifest.xml:46:2-72 Warning:
Element uses-permission#android.permission.ACCESS_WIFI_STATE at AndroidManifest.xml:46:2-72 duplicated with element declared at AndroidManifest.xml:33:2-72
Тут нужно залезть в саму компоненту - выгрузить её на компьютер из конфигуратора, распаковать. Найти AndroidManifest.xml в которой найти соответствующую строчку (<uses-permission android:name="android.permission.ACCESS_WIFI_STATE"/>) и удалить ее. Перезапаковать компоненту и по новой загрузить ее в конфигурацию и по новой собрать на ее основе мобильное приложение.
Приложение должно собраться. У меня же две идентичные по сути компоненты и одну (на которую ругался) я удалил и все собралось.
11. laperuz 46 14.06.24 14:39 Сейчас в теме
(10)Чтобы вторую часть не делать, можно использовать последнюю 25 мобильную платформу и её сборщик, там это поправили.
12. PaulSparrow 14.06.24 14:41 Сейчас в теме
(11) Как вариант. Но пока 25-й месяц отроду страшновато)
14. o4karek 14.06.24 14:53 Сейчас в теме
(11) Платформу не обязательно. Сборщика достаточно
15. PaulSparrow 14.06.24 15:03 Сейчас в теме
(14) Интересно, читал там требования по платформе, что версия платформы должна быть не ниже версии сборщика. Но можно попробовать.
16. o4karek 14.06.24 16:40 Сейчас в теме
(15) Чего? Это где там такое написано?
Мобильная версия, которая используется для сборки мобильного приложения, не может быть выше версии сборщика. Это факт. Но ниже - и может и нормально работает.
Другими словами - сборщик 25 версии даже не загрузит 26 мобильную версию, но загрузит и нормально соберет 24 и ниже (до определенного предела).
17. PaulSparrow 14.06.24 16:43 Сейчас в теме
(16) Я может что-то не так написал.
На оф сайте загрузки обновлений так пишут:
Текущая версия "Мобильная платформа 1С:Предприятия" предназначена для использования с версией технологической платформы 1С:Предприятие 8 не ниже 8.3.25.1257.

То есть я имел ввиду, что технологическую платформу 25 ставить пока не хочу.
18. o4karek 14.06.24 17:36 Сейчас в теме
(17) Сборщик вполне работает с младшими версиями. И на 24 должен работать
13. o4karek 14.06.24 14:52 Сейчас в теме
(10) Проблема с внешней компонентой решается установкой сборщика из 8.3.25 (максимально свежую версию). Там ничего не придется доделывать.
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот