Сборка мобильного приложения на 8.3.23.9

1. Xershi 1500 11.05.23 14:07 Сейчас в теме
Добрый день, коллеги!
google прислал страшное письмо:
Устраните нарушение, иначе приложение будет удалено
Your app may be removed from Google Play if you do not resolve the issue(s) by the deadlines listed below.
Разрешение "Запрос пакетов установки". Использование разрешения не связано напрямую с основным назначением вашего приложения..
We found that your app is not compliant with how REQUEST_INSTALL_PACKAGES permission is allowed to be used. Specifically, the use of the permission is not directly related to the core purpose of the app.
А обновлял я его пару лет назад.
Пришлось обновить картинку, белый фон уже не катит, краткое наименование не должно совпадать с наименованием.
Заполнить кучу опросов. Далее основное убрал в конфигурации опцию REQUEST_INSTALL_PACKAGES, т.к. она мне в приложении и не нужна. 1С на эту тему даже где-то выкатил письмо, уже потерял ссылку, кто наткнется можете добавить в эту тему.
Далее танцы с бубном. Обновить пришлось jdk. Оракл сделал скачивание по регистрации и РФ и РБ в списке нет, поэтому решил скачать от мелкософта бесплатно последнюю версию, сейчас 20 была. Оказалось в конфигурации сборщика прописано ограничение Версия Java c 8.0 по 18.99 Ну что же скачал 17. Полезли ошибки, грандл 7.3.3 не понимает новую версию. Пришлось методом тыка перебирать остановился на 12. Ну что ж еще баг встретил, что опера перестает работает, если во время сборки вылетает ошибка. Это на заметку, кто в курсе в чем причина? Перезагрузка ПК решала проблему.
После того как мы перезаполнили профиль приложения в консоли, появилась возможность загрузить обновление, теперь уже не через апк файлы, а через бандлы, чтобы сделать больший охват устройств, то нам и удобнее! Обновление прошло успешно, но пришло еще одно письмо!
com.google.android.gms:play-services-ads-lite:16.0.0
Эта версия SDK была отмечена как устаревшая. Установите более новую версию (19.3.0+).

С 9 августа 2023 г. 00:00 (по UTC) вы не сможете публиковать новые версии приложения, в которых используется этот SDK.

com.google.android.gms:play-services-ads:16.0.0
Эта версия SDK была отмечена как устаревшая. Установите более новую версию (19.3.0+).

К этой версии SDK приложено сообщение от разработчика:

This version is officially deprecated, and will soon disable ad loading. Please update to a new version. See https://developers.google.com/admob/android/deprecation for more details.

С 9 августа 2023 г. 00:00 (по UTC) вы не сможете публиковать новые версии приложения, в которых используется этот SDK.
Показать

После обновления студии и скачивания всех пакетов не увидел, чтобы я мог на это повлиять, возможно нужно что-то в сборщике переписать? Чтобы он 8 грандл стал использовать? К концу лета похоже придется снова переопубликовать.
У кого какие идеи? Кто смог решить эти проблемы?
Найденные решения
8. laperuz 46 18.07.23 11:07 Сейчас в теме
(7)Получил ответ от 1С:

Добрый день,

Переход на новую версию библиотеки рекламы произошел в версии 8.3.24, которая в скором времени выйдет.
В данный момент можно использовать 8.3.23.68 с выключенной мобильной функциональностью "Реклама". Если реклама выключена сборщик уберет библиотеки рекламы из сборки и вы сможете опубликовать ваше приложение.


P.S. правда не знаю как это связано с тем, что сканирование отвалилось
Остальные ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. Xershi 1500 11.05.23 14:54 Сейчас в теме
В довесок еще два предупреждения:
Незашифрованный трафик разрешен для всех доменов
Настройки сетевой безопасности вашего приложения разрешают незашифрованный трафик для всех доменов. Это может привести к перехвату отправляемых данных. Утечка персональных данных или информации, позволяющей идентифицировать личность, может нарушить конфиденциальность пользователей.

Рекомендуем разрешить только зашифрованный трафик, установив значение "false" для параметра cleartextTrafficPermitted, или добавить политику шифрования для отдельных доменов.

Ваше приложение принимает сертификаты пользователей во время проверки защищенных подключений
Настройки сетевой безопасности вашего приложения разрешают работу с пользовательскими сертификатами. Это может привести к перехвату отправляемых или изменению передаваемых данных.

Рекомендуем вложить элемент trust-anchors, который разрешает сертификаты пользователей, в элемент debug-overrides. После этого сертификаты будут доступны, только когда для параметра android:debuggable задано значение "true".

Но это не критично как я понимаю.
3. laperuz 46 11.05.23 16:16 Сейчас в теме
Точно с такой же ошибкой воевал)
Вообще советую пользоваться платформенным сборщиком, там никаких танцев с версиями библиотек не нужно, соберётся гарантированно.
По поводу старых версий библиотек мне разработчики ответили, что в 8.3.24 обновят
4. Xershi 1500 11.05.23 16:45 Сейчас в теме
(3) пока не было желания писать в 1С. Так и думал, что дело в сборщике. Подождем когда обновят его. Надеюсь google не пришлет плохих писем по осени.
5. Evgeniy7620041976 1 17.07.23 15:54 Сейчас в теме
Были какие-то изменения в мобильной платформе по этому поводу? у меня уже отключили работу мобильной камеры. Написано с 1-го июля не будет возможно обновление и перестала работать сканирование штрих кодов через камера. А через apk работает
6. laperuz 46 17.07.23 17:21 Сейчас в теме
(5)А с каким сообщением отключили?
Приведите полный текст сообщения, попробую разработчикам на партнерском написать
7. Evgeniy7620041976 1 18.07.23 09:03 Сейчас в теме
(6) Вот они вывалили такие сообщения. И перестало работать сканирование. А через apk работает. Тоесть какая-то связь наблюдается

Разработчик SDK (com.google.android.gms) сообщил, что версия play-services-ads:16.0.0 устарела. Если вы не перейдете на новую версию, то в дальнейшем не сможете публиковать выпуски приложения, использующие этот SDK.
Разработчик SDK (com.google.android.gms) сообщил, что версия play-services-ads-lite:16.0.0 устарела. Если вы не перейдете на новую версию, то в дальнейшем не сможете публиковать выпуски приложения, использующие этот SDK.

om.google.android.gms:play-services-ads-lite:16.0.0
Эта версия SDK была отмечена как устаревшая. Установите более новую версию (19.3.0+).

С 20 июля 2023 г. 00:00 (по UTC) вы не сможете публиковать новые версии приложения, в которых используется этот SDK.

com.google.android.gms:play-services-ads:16.0.0
Эта версия SDK была отмечена как устаревшая. Установите более новую версию (19.3.0+).

К этой версии SDK приложено сообщение от разработчика:

This version is officially deprecated, and will soon disable ad loading. Please update to a new version. See https://developers.google.com/admob/android/deprecation for more details.

С 1 июля 2023 г. 00:00 (по UTC) вы не сможете публиковать новые версии приложения, в которых используется этот SDK.
8. laperuz 46 18.07.23 11:07 Сейчас в теме
(7)Получил ответ от 1С:

Добрый день,

Переход на новую версию библиотеки рекламы произошел в версии 8.3.24, которая в скором времени выйдет.
В данный момент можно использовать 8.3.23.68 с выключенной мобильной функциональностью "Реклама". Если реклама выключена сборщик уберет библиотеки рекламы из сборки и вы сможете опубликовать ваше приложение.


P.S. правда не знаю как это связано с тем, что сканирование отвалилось
9. Xershi 1500 18.07.23 11:26 Сейчас в теме
(8) в моём приложении есть реклама, но адмоб её полгода не крутит почему то.
10. Evgeniy7620041976 1 16.08.23 12:39 Сейчас в теме
(8) Я использую мобильную платфому Версия 8.3.23.59. Что-то не нашел мобильную платформу 8.3.23.68. Функциональность Реклама у меня не включена
12. laperuz 46 16.08.23 14:29 Сейчас в теме
11. Evgeniy7620041976 1 16.08.23 12:46 Сейчас в теме
А сегодня гугл вобще отказался публиковать обновление для моего приложения из-за это ошибки

Разработчик SDK Google Mobile Ads (GMA) SDK (com.google.android.gms:play-services-ads) сообщил, что версия 16.0.0 устарела. Чтобы опубликовать рабочую версию приложения, перейдите на новую версию SDK (19.4.0+).
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот