НачатьРедактированиеЭлемента()

1. 22.06.22 11:10 Сейчас в теме
Сделал свою форму ввода, которая должна оповестить основную форму, если НачатьРедактированиеЭлемента() не использовать то основная форма оповещается, через НачатьРедактированиеЭлемента не работает оповещение...


&НаКлиенте
Процедура Принять(Команда)
ОповеститьОВыборе(КоличествоОтсканировано);
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
#Если МобильныйКлиент Тогда
НачатьРедактированиеЭлемента();
#КонецЕсли
КонецПроцедуры

&НаКлиенте
Процедура КоличествоОтсканированоОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, СтандартнаяОбработка)
ОповеститьОВыборе(КоличествоОтсканировано);
КонецПроцедуры

&НаКлиенте
Процедура КоличествоОтсканированоОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
ОповеститьОВыборе(КоличествоОтсканировано);
КонецПроцедуры
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. IvanovIvan 22.06.22 11:12 Сейчас в теме
Хотя погодите, походу я вру
3. IvanovIvan 22.06.22 11:17 Сейчас в теме
Оповещение происходит, гдето я просто не принимаю значение чтоли
4. IvanovIvan 22.06.22 11:33 Сейчас в теме
Оповещение происходит только источник = 0, как так??? хотя без этого НачатьРедактированиеЭлемента(); все работает
5. IvanovIvan 22.06.22 11:53 Сейчас в теме
Я понял форма источник закрывается быстрее. короче хер значаешь передашь если кто знает как напишите
6. IvanovIvan 22.06.22 11:54 Сейчас в теме
7. waitklassik 23.06.22 14:13 Сейчас в теме
сам спросил и сам ответил =)
Оставьте свое сообщение
Вакансии
Разработчик 1С
Балашиха
зарплата от 180 000 руб. до 230 000 руб.
Полный день

Руководитель проектов внедрения 1С:УХ
Краснодар
зарплата от 150 000 руб.
Полный день

Консультант-аналитик 1С
Москва
зарплата от 120 000 руб. до 190 000 руб.
Полный день

Ведущий аналитик-разработчик 1С
Москва
зарплата от 230 000 руб. до 270 000 руб.
Полный день

1С:Эксперт по производительности
Москва
зарплата от 400 000 руб. до 950 000 руб.
Полный день