НачатьРедактированиеЭлемента()

1. 22.06.22 11:10 Сейчас в теме
Сделал свою форму ввода, которая должна оповестить основную форму, если НачатьРедактированиеЭлемента() не использовать то основная форма оповещается, через НачатьРедактированиеЭлемента не работает оповещение...


&НаКлиенте
Процедура Принять(Команда)
ОповеститьОВыборе(КоличествоОтсканировано);
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
#Если МобильныйКлиент Тогда
НачатьРедактированиеЭлемента();
#КонецЕсли
КонецПроцедуры

&НаКлиенте
Процедура КоличествоОтсканированоОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, СтандартнаяОбработка)
ОповеститьОВыборе(КоличествоОтсканировано);
КонецПроцедуры

&НаКлиенте
Процедура КоличествоОтсканированоОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
ОповеститьОВыборе(КоличествоОтсканировано);
КонецПроцедуры
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. IvanovIvan 22.06.22 11:12 Сейчас в теме
Хотя погодите, походу я вру
3. IvanovIvan 22.06.22 11:17 Сейчас в теме
Оповещение происходит, гдето я просто не принимаю значение чтоли
4. IvanovIvan 22.06.22 11:33 Сейчас в теме
Оповещение происходит только источник = 0, как так??? хотя без этого НачатьРедактированиеЭлемента(); все работает
5. IvanovIvan 22.06.22 11:53 Сейчас в теме
Я понял форма источник закрывается быстрее. короче хер значаешь передашь если кто знает как напишите
6. IvanovIvan 22.06.22 11:54 Сейчас в теме
7. waitklassik 23.06.22 14:13 Сейчас в теме
сам спросил и сам ответил =)
8. eeeio 120 05.08.22 09:44 Сейчас в теме
можно использовать ПодключитьОбработчикОжидания("имяпроцедуры", 0.1, истина)
Оставьте свое сообщение
Вакансии
Разработчик 1С
Москва
зарплата от 180 000 руб. до 200 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству

Архитектор 1С
Москва
зарплата от 260 000 руб.
Полный день

Начальник отдела архитектуры
Москва
зарплата от 300 000 руб.
Полный день

Эксперт по технологическим вопросам
Москва
зарплата от 250 000 руб.
Полный день