1. yakdenitdn 10.10.16 17:09 Сейчас в теме

Нарушение прав доступа к операции Web-сервиса

Помогите пожалуйста разобраться с проблемой: При вызове веб-сервиса произошла ошибка. Ошибка SOAP сервера: Нарушение прав доступа к операции Web-сервиса:

Версия 1С:УНФ 1.6.1.64
Версия мобильного клиента (1.2.50.5)
С полными правами работает и синхронизируется. Ткните носом куда копать, права доступа пользователя ставил (Продажи, Закупка, Деньги) не помогло.
Прикрепленные файлы:
Ответы
Избранное Подписка Сортировка: Древо
2. bubus 11.10.16 11:57 Сейчас в теме
Права на сам вебсервис выставили?
3. yakdenitdn 11.10.16 12:08 Сейчас в теме
Я уже четвертый день, бьюсь, уже и платформу обновил, но столкнулся с проблемой, в мобильном приложении не работают разграничение прав на контрагентов, если выставлять права (Продажи, Закупка, Деньги) то почему то справочник становиться общим даже у ЦБ УНФ (

Сейчас начал пробовать 1С:УТ + 1С:Заказы (для Android) но не могу их подружить. Предполагаю, что это из за версии для Украины (((
4. yakdenitdn 12.10.16 14:15 Сейчас в теме
Наша песня хорошо так сказать

Что можно сделать, отладчик не предлагать потому как сервер и клиент в разных сетях(
Прикрепленные файлы:
5. yakdenitdn 12.10.16 14:18 Сейчас в теме
Судя по всему ошибка на мобильном клиенте.
Вот процедура которая формирует ответ
Процедура ВыгрузитьНастройкиДляОбмена(УзелОбмена, СтруктураОтвета) Экспорт
	
	РеквизитыУзла = МобильноеПриложениеЗаказыКлиентов.РеквизитыУзла(УзелОбмена);
	
	ТекстНаборКонстант = "ИспользоватьЗаказыКлиентов,
		|ИспользованиеСоглашенийСКлиентами, ИспользоватьДоговорыСКлиентами,
		|ИспользоватьПартнеровКакКонтрагентов, ИспользоватьКомиссиюПриПродажах, ИспользоватьРучныеСкидкиВПродажах,
		|ИспользоватьСкладыВТабличнойЧастиДокументовПродажи, ИспользоватьРасширенныеВозможностиЗаказаКлиента,
		|ИспользованиеЗаданийТорговымПредставителям, ДетализироватьЗаданияТорговымПредставителямПоНоменклатуре,
		|ЕдиницаИзмеренияВеса, ИспользоватьЗаявкиНаВозвратТоваровОтКлиентов";
	//+ УП 2.2.
	ТекстНаборКонстант = ТекстНаборКонстант + "ИспользоватьДополнительныеРеквизитыИСведения,
		|ИспользоватьОбщиеДополнительныеЗначения, ИспользоватьОбщиеДополнительныеРеквизитыИСведения";
	//- УП 2.2.
		
	НаборКонстант = Константы.СоздатьНабор(ТекстНаборКонстант);
	НаборКонстант.Прочитать();
	
	ДоступныеФункции = ПроверкаПользователяМобильногоПриложения();
	
	СтруктураОтвета.Вставить("AddChangeCustomer", ДоступныеФункции.ИзменениеКлиентов);
	СтруктураОтвета.Вставить("AddChangeCustomerOrders",
		НаборКонстант.ИспользоватьЗаказыКлиентов И ДоступныеФункции.ЗаказыКлиентов);
	ИспользованиеСоглашенийСКлиентами = ?(ЗначениеЗаполнено(НаборКонстант.ИспользованиеСоглашенийСКлиентами),
		Перечисления.ИспользованиеСоглашенийСКлиентами.Индекс(НаборКонстант.ИспользованиеСоглашенийСКлиентами), 0);
	СтруктураОтвета.Вставить("UsingCustomerAgreement", ИспользованиеСоглашенийСКлиентами);
	СтруктураОтвета.Вставить("UsePricesInOrderLine", Истина);
	СтруктураОтвета.Вставить("UseCustomerContract", НаборКонстант.ИспользоватьДоговорыСКлиентами);
	СтруктураОтвета.Вставить("UseGoodsBalance", Истина);
	СтруктураОтвета.Вставить("PartnersHowContractors", НаборКонстант.ИспользоватьПартнеровКакКонтрагентов);
	СтруктураОтвета.Вставить("UseCommission", НаборКонстант.ИспользоватьКомиссиюПриПродажах);
	СтруктураОтвета.Вставить("UseManualDiscounts", НаборКонстант.ИспользоватьРучныеСкидкиВПродажах);
	СтруктураОтвета.Вставить("UseStoreInOrderLine", НаборКонстант.ИспользоватьСкладыВТабличнойЧастиДокументовПродажи);
	СтруктураОтвета.Вставить("UseOrderStatus", НаборКонстант.ИспользоватьРасширенныеВозможностиЗаказаКлиента);
	СтруктураОтвета.Вставить("ChangePriceInOrder", ДоступныеФункции.ИзменениеЦен);
	СтруктураОтвета.Вставить("FrequencyExchangeRates", 0);
	СтруктураОтвета.Вставить("FrequencyExchangeBalance", 0);
	СтруктураОтвета.Вставить("PrefixIB", РеквизитыУзла.ПрефиксДляДанныхМобильногоУстройства);
	СтруктураОтвета.Вставить("MessageNumberIn", РеквизитыУзла.НомерПринятого);
	СтруктураОтвета.Вставить("MessageNumberOut", РеквизитыУзла.НомерОтправленного);
	Если ДоступныеФункции.Задания Тогда
		ИспользованиеЗаданий = ?(ЗначениеЗаполнено(НаборКонстант.ИспользованиеЗаданийТорговымПредставителям),
			Перечисления.ИспользованиеЗаданийТорговымПредставителям.Индекс(
				НаборКонстант.ИспользованиеЗаданийТорговымПредставителям), 0);
	Иначе
		ИспользованиеЗаданий = 0;
	КонецЕсли;
	СтруктураОтвета.Вставить("UsingJobTargets", ИспользованиеЗаданий);
	СтруктураОтвета.Вставить("DetailJobTargets", НаборКонстант.ДетализироватьЗаданияТорговымПредставителямПоНоменклатуре);
	СтруктураОтвета.Вставить("UseCashPayment",
		(ДоступныеФункции.Касса
			И ?(РеквизитыУзла.ИспользоватьПКОДляРегистрацииОплаты = Неопределено, Ложь,
					РеквизитыУзла.ИспользоватьПКОДляРегистрацииОплаты))
		ИЛИ (ДоступныеФункции.Доверенности
			И ?(РеквизитыУзла.ИспользоватьДоверенностиДляРегистрацииОплаты = Неопределено, Ложь,
					РеквизитыУзла.ИспользоватьДоверенностиДляРегистрацииОплаты)));
	СтруктураОтвета.Вставить("UseCashRegister", ДоступныеФункции.Касса
		И ЗначениеЗаполнено(РеквизитыУзла.Касса));
	СтруктураОтвета.Вставить("UseCardPayment", ДоступныеФункции.ПлатежнаяКарта
		И ЗначениеЗаполнено(РеквизитыУзла.ЭквайринговыйТерминал));
	СтруктураОтвета.Вставить("CardsTypes", "");
	СтруктураОтвета.Вставить("UsePushNotifications", ?(РеквизитыУзла.ОтправляютсяPushУведомления = Неопределено,
		Ложь, РеквизитыУзла.ОтправляютсяPushУведомления));
	СтруктураОтвета.Вставить("GoogleCloudProjectNumber", РеквизитыУзла.НомерПриложенияGoogleCloud);
	СтруктураОтвета.Вставить("UseImages", ?(РеквизитыУзла.ПередаватьИзображенияТоваров = Неопределено,
		Ложь, РеквизитыУзла.ПередаватьИзображенияТоваров));
	СтруктураОтвета.Вставить("UseWeight", ?(РеквизитыУзла.ИспользоватьВесовыеХарактеристики = Неопределено,
		Ложь, РеквизитыУзла.ИспользоватьВесовыеХарактеристики));
	Если ЗначениеЗаполнено(НаборКонстант.ЕдиницаИзмеренияВеса) Тогда
		СтруктураОтвета.Вставить("UnitWeight", СокрЛП(НаборКонстант.ЕдиницаИзмеренияВеса.УникальныйИдентификатор()));
	Иначе
		СтруктураОтвета.Вставить("UnitWeight", МобильноеПриложениеЗаказыКлиентовПовтИсп.ПустойИдентификатор());
	КонецЕсли;
	СтруктураОтвета.Вставить("UseRequestsToReturnOfGoodsByClient",
		ДоступныеФункции.ЗаявкиНаВозврат И НаборКонстант.ИспользоватьЗаявкиНаВозвратТоваровОтКлиентов);
	
	//+ УП 2.2.
	СтруктураОтвета.Вставить("UseSimplifiedClientInput", ПартнерыИКонтрагенты.УпрощенныйВводДоступен());
	СтруктураОтвета.Вставить("CheckTINRussianRules", НЕ ПартнерыИКонтрагенты.УпрощенныйВводДоступен());
	
	СтруктураОтвета.Вставить("UseAdditionalProps", НаборКонстант.ИспользоватьДополнительныеРеквизитыИСведения);
	СтруктураОтвета.Вставить("UseCommonAdditionalValues", НаборКонстант.ИспользоватьОбщиеДополнительныеЗначения);
	СтруктураОтвета.Вставить("UseCommonAdditionalProps", НаборКонстант.ИспользоватьОбщиеДополнительныеРеквизитыИСведения);
	//- УП 2.2.
	
	СтруктураОтвета.ResultMessage = "";
	СтруктураОтвета.Success = Истина;
КонецПроцедуры

Показать
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Консультант-аналитик 1С (ЗУП)
Санкт-Петербург
Полный день

Программист 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день

Руководитель группы сервисов ЭДО, ЭЦП и криптографии
Москва
зарплата от 150 000 руб.
Полный день

Руководитель группы интеграций (1С)
Москва
зарплата от 150 000 руб.
Полный день

Руководитель группы сервисов FRM на 1С
Москва
зарплата от 150 000 руб.
Полный день