1. DeniNikitin 34 25.08.16 08:53 Сейчас в теме

Установка главного узла?

Здравствуйте!

Есть конфигурация мобильного приложения, пропал главный узел у плана обмена! Подскажите как его восстановить заново?
	пГлавныйУзел = ПланыОбмена.ОбменСМобильнымиУстройствами.НайтиПоКоду("1");
	ПланыОбмена.УстановитьГлавныйУзел(пГлавныйУзел);

Данный код не помогает, т.к. не установлено свойство распределённая база и не даёт установить. На форме при редактировании галка этот узел тоже не доступна! Подскажите как сделать?

Заранее благодарен!
Ответы
Избранное Подписка Сортировка: Древо
2. DeniNikitin 34 25.08.16 08:58 Сейчас в теме
Может сделал неправильно, но помогло удалил план обмена и создал новый и главный узел появился сам! Если всё таки как то можно обойти этот способ, то пишите!
3. kasper076 45 25.08.16 10:10 Сейчас в теме
(2) DeniNikitin, возможно у первоначального плана обмена не стоял признак "Распределенная база"
4. DitriX 1636 25.08.16 12:47 Сейчас в теме
Дай угадаю - обновился с 8.3.8 на 8.3.9?
Если да, то надо выполнить вот такой код:
	СисИнфо = Новый СистемнаяИнформация;
	Если Лев(СисИнфо.ВерсияПриложения,5) = "8.3.9" Тогда
		
		
		Запрос = Новый Запрос;
		Запрос.Текст = 
		"ВЫБРАТЬ
		|	ОС_ОбменСМобильнымиУстройствами.Ссылка
		|ИЗ
		|	ПланОбмена.ОС_ОбменСМобильнымиУстройствами КАК ОС_ОбменСМобильнымиУстройствами
		|ГДЕ
		|	ОС_ОбменСМобильнымиУстройствами.Код = """"
		|;
		|
		|////////////////////////////////////////////////////////////­////////////////////
		|ВЫБРАТЬ
		|	ОС_ОбменСМобильнымиУстройствами.Ссылка
		|ИЗ
		|	ПланОбмена.ОС_ОбменСМобильнымиУстройствами КАК ОС_ОбменСМобильнымиУстройствами
		|
		|УПОРЯДОЧИТЬ ПО
		|	ОС_ОбменСМобильнымиУстройствами.Код УБЫВ";
		
		Пакеты = Запрос.ВыполнитьПакет();
		Если НЕ Пакеты[0].Выгрузить().Количество() Тогда Возврат КонецЕсли;
		ПланыОб = Пакеты[1].Выгрузить();
		Если НЕ ПланыОб.Количество() = 3 Тогда Возврат КонецЕсли;
		
		УстановитьПривилегированныйРежим(Истина);
		
		ВрОб = ПланыОб[0].Ссылка.ПолучитьОбъект();
		ВрКод = ВрОб.Код;
		ВрОб.Код = "999";
		ВрОб.Записать();
		
		ВрОб = ПланыОб[2].Ссылка.ПолучитьОбъект();
		ВрОб.Код= ВрКод;
		ВрОб.Записать();
	КонецЕсли;
Показать
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Специалист техподдержки 1С
Иркутск
зарплата от 28 000 руб. до 34 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 48 000 руб. до 96 000 руб.
По совместительству

Программист 1С
Ставрополь
зарплата от 40 000 руб. до 60 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Программист 1С
Благовещенск (Амурская область)
зарплата от 40 000 руб. до 70 000 руб.
Полный день