1. rchshark 8 27.05.16 20:39 Сейчас в теме

Задача: Автоматическое добавление строк в документ при считывание штрих-кода сканером (ТСД на андроиде, мобильное приложение)

Добрый день!
На текущий момент у меня реализован следующий принцип ввод данных по штрих-коду.
1. Пользователь создает документ.
2. Пользователь добавляет новую строку (тыкает стикиром или пальцем "Добавить").
3. Пользователь активирует поле "Номенклатура" для ввода данных (стикиром или пальцем)
4. Сканирует штрих-код, цифры попадают в поле, систем в подсказке находит эту позицию в справочнике (исходим из того, что вся номенклатура есть в справочнике и штрих-коды уникальны).
5. Пользователь тыкает в подсказку и выбирается номенклатура найденная по штрих-коду.
6. Пользователь тыкает в поле количество и вводит данные (ну пусть товар штучный, вводит всегда 1)
Есть желание оптимизировать следующим образом:
1. Пользователь создает документ.
2. Пользователь сканирует товар.
3. Система автоматически добавляет новую строку, подставляет найденный товар по штрих-коду, в поле количество записывается 1.
и так далее... Т.е. пользователь только считывает штрих-коды, все остальное автоматом, как в супермаркете.
Не могу обработчиками добраться до события сканера. Кто-нибудь решал такую задачу? У сканера есть возможность слать префиксы до и после штрих кода.

Спасибо за советы!
Ответы
Избранное Подписка Сортировка: Древо
2. Xershi 414 27.05.16 20:59 Сейчас в теме
(1) rchshark, а подсмотреть в типовых?
3. rchshark 8 27.05.16 21:06 Сейчас в теме
Где посмотреть конфу мобильного приложения, подскажи? Меня интересует именно мобильно приложение для андроида, а не типовая для компа (ТиС и прочее)
4. rchshark 8 27.05.16 21:14 Сейчас в теме
Скачал БСП для мобильных устройств, читаю документацию. Может уже кто-то что-то подобное делал? Я так понял нужно копать в сторону "Устройства ввода данных"
18. inf012 05.10.16 11:01 Сейчас в теме
(4) rchshark, а где вы взяли БСП для мобильных устройств?
Я на сайте обновлений 1с вижу только,например:
1С:Библиотека стандартных подсистем, редакция 2.3

Она и для мобильных подходит?
5. rchshark 8 27.05.16 22:33 Сейчас в теме
Все не то... У меня на ТСД есть БОЛЬШАЯ красная кнопка SCAN, как мне из 1С мобильного приложения перехватить результат нажатия этой кнопки в форме? Кто-нибудь такое делал?
6. DitriX 1614 28.05.16 02:41 Сейчас в теме
7. ipoloskov 64 28.05.16 02:56 Сейчас в теме
Может быть, сделать на форме в шапке текстовое поле "Штрих-код", считывать ШК туда, и по событию "ПриИзменении" создавать все, что нужно?
8. DitriX 1614 28.05.16 03:03 Сейчас в теме
(7) в моильной нет активного поля, и не всегда мобильная сводит активность при завершении сканирования
9. Xershi 414 28.05.16 10:20 Сейчас в теме
(8) DitriX, а вы курс по мобильной платформе прошли? Там был момент про сканирование, но я его пропустил за не надобностью.
10. DitriX 1614 28.05.16 14:03 Сейчас в теме
(9) Ага.
И пока решений не особо много, как вариант - можно взять из БСП утилиту и реализовать на ее основе.
В курсах были рассмотрены варианты с использованием утилит ACODE, но они подходят только для блютуз сканеров или терминалов акоде.
Раньше, когда выпускалась первая версия курса - можно было управлять активностью элемента, т.е. перемещать программно курсор в нужное поле, а теперь - увы, такое нельзя сделать.
11. rchshark 8 28.05.16 20:51 Сейчас в теме
Спасибо! Я пока упрости так: вывел в шапку документа текстовое поле, к нему добавил обработчик "ИзменениеТекстаРедактирования", пользователь тыкает туда пальцем, оно активируется (не получилось у меня программно активировать поле при создании документа), затем жмет кнопку SCAN, результат попадает в это поле, срабатывает обработчик, вызывает процедуру на сервере, вот как-то так, уже легче... Только каждый раз пальцем в это поле тыкать надо, после каждого сканированя.

&НаКлиенте
Процедура ВводШтрихКодаИзменениеТекстаРедактирования(Элемент, Текст, СтандартнаяОбработка)
ВводШтрихКодаИзменениеТекстаРедактированияНаСервере(Текст);
КонецПроцедуры


&НаСервере
Процедура ВводШтрихКодаИзменениеТекстаРедактированияНаСервере(ШтрихКод)
Если СтрДлина(ШтрихКод) = 13 Тогда
СпрСсылка = Справочники.Номенклатура.НайтиПоРеквизиту("ШтрихКод", ШтрихКод);

Если ЗначениеЗаполнено(СпрСсылка) Тогда
НоваяСтрока = Объект.СписокНоменклатуры.Добавить();
НоваяСтрока.Номенклатура = СпрСсылка;
НоваяСтрока.Количество = 1;
Иначе
Сообщить("Отсутствует штрихкод!");
КонецЕсли;
КонецЕсли;
КонецПроцедуры
12. DitriX 1614 28.05.16 21:23 Сейчас в теме
(11) rchshark, но и это не вариант :) А что за ТСД если не секрет?
13. rchshark 8 29.05.16 11:31 Сейчас в теме
Сам понимаю что коряво, но лучше пока не придумал :))) Буду думать.

Девайс "SMART Mobile Terminal", http://atol.ru/products/barcode/terminal/atol/atol_571.html#video
На работе купили, дали, сказали сделай чтоб хорошо было кладовщикам :) Там софт идет свой, но мне хочется простенький, свой, понятный, без лишний сервисов на сервере, вот решил на мобильной приложении написать, все сделал, все классно, только вот одна загвоздка с этой красной кнопкой. Я так думаю, должна быть какая-то внешняя компонента, которая перехватывается через "Процедура ВнешнееСобытие(Источник, Событие, Данные)"
14. rchshark 8 29.05.16 11:38 Сейчас в теме
Пообщаюсь на следующей неделе с Атолом опять. Может подскажут что или файлик дадут. Ведь их софт работает отлично с этой кнопкой!
15. DitriX 1614 30.05.16 20:45 Сейчас в теме
(14) 1с просто не умеет общаться с внешним оборудованием, вот и все. Она вообще не умеет в андроид толком. Что бы реализовать то, что вам надо, на нативном приложении - это 10 строк кода, грубо говоря. А вот 1С так не умеет.
16. Бугор 6 30.05.16 21:17 Сейчас в теме
>В курсах были рассмотрены варианты с использованием утилит ACODE, но они подходят только для блютуз сканеров или терминалов акоде.

Подскажите, о каком курсе речь? В курсе "Разработка мобильных приложений на 1С:Предприятии 8.3 (2016)", только про сканирование камерой, старый курс не купить.
Две недели уже пытаюсь подружить 1С, Acode tools и сканер ACODE, никак не выходит перехват сканирования, только ввод в активное поле работает.
17. DitriX 1614 30.05.16 22:02 Сейчас в теме
(16) в сканере АКОДЕ не нужны утилиты, сканирование работает не через них.
Вот вам демо конфа, там есть обработка Тестирование ТСД. Можете ее установить на терминал и все протестировать.
Там не надо вообще никаких активных полей, все происходит в фоне.
Если будут проблемы /вопросы - пишите в личку
Прикрепленные файлы:
AcodeTools.cf
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Консультант-аналитик 1С (ЗУП)
Санкт-Петербург
Полный день

Программист 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день

Руководитель группы сервисов ЭДО, ЭЦП и криптографии
Москва
зарплата от 150 000 руб.
Полный день

Руководитель группы интеграций (1С)
Москва
зарплата от 150 000 руб.
Полный день

Руководитель группы сервисов FRM на 1С
Москва
зарплата от 150 000 руб.
Полный день