1. alexdarh 12 20.09.14 21:02 Сейчас в теме

Сохранить полученную с камеры картинку в ХранилищеЗначения

Доброй ночи :) Столкнулся со следующей проблемой:

В Мобильном приложении получаю с камеры фото. Помещаю его в форму
Процедура ПолучитьФото(Команда)
        
#Если МобильноеПриложениеКлиент Тогда

    Если СредстваМультимедиа.ПоддерживаетсяФотоснимок()     Тогда
        ДанныеКартинки = СредстваМультимедиа.СделатьФотоснимок();
        Фото = ПоместитьВоВременноеХранилище(ДанныеКартинки.ПолучитьДвоичныеДанные());
    Иначе    
         Сообщить(НСтр("ru = 'Съемка фото не поддерживается.'", "ru"));
    КонецЕсли; 
#КонецЕсли

КонецПроцедуры
Показать


На форме в реквизите фото (строковый с видом "Поле картинки") оно появляется. затем по кнопке записать:

Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    ФотоФайл=ПоместитьВоВременноеХранилище(Фото);
    Если ЭтоАдресВременногоХранилища(ФотоФайл) Тогда
        ДвДанные=ПолучитьИзВременногоХранилища(ФотоФайл);
    ТекущийОбъект.ДанныеКартинки = Новый ХранилищеЗначения(ДвДанные, Новый СжатиеДанных(9));
    КонецЕсли;    
КонецПроцедуры


При открытии формы считываю:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
        Фото=ПолучитьНавигационнуюСсылку(ТекущийОбъект.Ссылка, "ДанныеКартинки");


Никаких ошибок не пишет, но вместо картинки в поле ФОТО крест (( Где я не так что сделал?
Ответы
Избранное Подписка Сортировка: Древо
2. Salavat 12 20.09.14 21:07 Сейчас в теме
(1) alexdarh,
Никаких ошибок не пишет, но вместо картинки в поле ФОТО крест (( Где я не так что сделал?
крест обычно говорит о том, что фото отсутствует.
чтото с сохранением (или извлечением оттуда) нето, видать.

деталей не знаю.
8. rougudz 29.09.16 17:33 Сейчас в теме
(1) alexdarh, у меня теже грабли....

когда отладчиком смотришь в ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
то в ЭтоАдресВременногоХранилища(СсылкаНаКартинку)показывает что там действительно чтото есть,
но ФотоДанные = ПолучитьИзВременногоХранилища(СсылкаНаКартинку);
в ФотоДанные уже ничего нету.
куда оно девается непонятно...
если сразу после фото сделать вызов сервера то ПолучитьИзВременногоХранилища(СсылкаНаКартинку)
возвращает данные нормально. но все равно при
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	размер = ПолучитьРазмерДанных(Объект.Ссылка.ДанныеФото);
	ССылкаНаКартинку = ПолучитьНавигационнуюССылку(Объект.Ссылка,"ДанныеФото");
КонецПроцедуры               

в ДанныеФото ничего нету.
засада.

а вообще должно временное хранилище доживать до "ПередЗаписьюНаСервере" ???
кто знает? сделал все также только запускал не на мобильной платформе. правда в сыбором фото. все гуд. на планшете ни в какую... платформа 8_3_8_58
9. bubus 03.10.16 14:25 Сейчас в теме
(8) rougudz, реквизит типа Хранилище делали? Не реквизитом формы сделали?
10. rougudz 06.10.16 21:33 Сейчас в теме
(9) bubus, да делал. теже грабли. пытаюсь сделать как в мобильной торговле с хранением фото в отдельном справочнике, ибо можно несколько фото прицепить.
3. alexdarh 12 20.09.14 21:16 Сейчас в теме
(( А как проверить сохранение?
4. Salavat 12 20.09.14 21:35 Сейчас в теме
(3) alexdarh, я реально не знаю. не смотрел даже никогда.
какая конфа хоть?
в типовых УТ/УПП/... картинки хранятся в справочнике "Хранилище дополнительной информации".
как они там хранятся было (года 2 назад) смотрел (чтоб сохранять нужное), но уже не помню.
лучше сами посмотрите в типовой - организацию этого процесса.
принципы работы в мобильном приложении - думаю несильно отличаются.
5. alexdarh 12 20.09.14 21:39 Сейчас в теме
6. Salavat 12 20.09.14 21:58 Сейчас в теме
(5) alexdarh, значит - взять типовую (УТ/КА/УПП/...)и сделать как там.

ну или/и ждать, когда придёт знающий (я с доп-файлами - точно не из них) человек и скажет/покажет.
11. flyer 213 08.10.16 06:10 Сейчас в теме
попробуйте платформу ниже версии например 8.3.7
12. rougudz 12.10.16 12:58 Сейчас в теме
(11) flyer, спасибо. попробую наверное. больше вариантов не осталось.
13. rougudz 24.10.16 11:50 Сейчас в теме
(11) flyer, спасибо. помогло. все стало работать как надо. версия 8.3.4. единственно в этой версии нет возможности отладки. надо попробовать более новое, отладка появилась вроде с версии 8.3.5. кстати и интерфес в 8.3.4 намного отличается от последнего релиза, как неуправляемые формы от управляемых. мне намного большо старый интерфес понравился. новый напроч не выразительный...
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Специалист техподдержки 1С
Иркутск
зарплата от 28 000 руб. до 34 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 48 000 руб. до 96 000 руб.
По совместительству

Программист 1С
Ставрополь
зарплата от 40 000 руб. до 60 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Программист 1С
Благовещенск (Амурская область)
зарплата от 40 000 руб. до 70 000 руб.
Полный день