Мобильное приложение. Фоновые задания.

1. 28.07.14 15:19 Сейчас в теме
Коллеги, добрый день. Никто не пробовал юзать в мобильном приложении фоновые задания?
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. dj_serega 377 28.07.14 15:27 Сейчас в теме
(1) Dimon93dimon, Только думал попользовать :) руки еще не доходили.
3. Dimon93dimon 28.07.14 17:11 Сейчас в теме
(2) dj_serega, а я вот попробовал. Удобно, правда приложение вылетает. Грешу на тестовую версию.
4. dj_serega 377 28.07.14 17:19 Сейчас в теме
(3) Dimon93dimon, а от чего вылетает? В процессе или время от времени?
у меня вот регулярно вылетает при получении смс.
даже если при получении смс приложение не запущено выскакивает сообщение "Работа приложение завершена".
5. flyer 233 28.07.14 20:27 Сейчас в теме
(4) dj_serega, это в 63 релизе исправили. я начал тестить фоновые но потом забил. юзеры все равно вручную клацают :)
7. Dimon93dimon 29.07.14 11:14 Сейчас в теме
(4) dj_serega, вылетает при выполнении фонового задания несколько раз.
6. flyer 233 28.07.14 20:37 Сейчас в теме
вот тему отдельную тоже создать? у кого получалось с МенеджерВременныхТаблиц работать.
8. white_tiger 11.08.14 07:09 Сейчас в теме
здравствуйте, уважаемые.
у меня мобильное приложение вылетает сразу же,ругаясь на фоновые задания. 8.3.4.22 их вообще поддерживает?
9. flyer 233 11.08.14 08:45 Сейчас в теме
нет только с 8.3.5. как раз начну разбираться с фоновыми заданиями. попробую реализовать.
10. EugeneSemyonov 21 17.03.16 17:49 Сейчас в теме
Добрый вечер! Оживлю ветку пожалуй.
Здесь написано, что синхронизацию на мобильной платформе можно запускать в фоновом задании: http://v8.1c.ru/o7/201404mob/index.htm

Кто подскажет, как сделать, чтобы это запускалось автоматически с заданным периодом?
11. dj_serega 377 17.03.16 18:36 Сейчас в теме
(10) EugeneSemyonov,
Модуль управляемого приложения
Процедура ПриНачалеРаботыСистемы()
	
	Попытка
		ПодключитьОбработчикОжидания("ОбработчикОжиданияПроверитьСостояниеФоновогоЗадания", ПолныеПрава.ПолучитьПериодАвтообмена(), Ложь);
	Исключение
		Сообщить(ОписаниеОшибки());
	КонецПопытки;

КонецПроцедуры
Показать

Глобальный клиентский модуль
Процедура ОбработчикОжиданияПроверитьСостояниеФоновогоЗадания() Экспорт 
	
	Если ОбработчикиОбменаДанными.ФоновыйОбменЗапущен() Тогда
		
		ОтключитьОбработчикОжидания("ОбработчикОжиданияВыполнитьФоновыйОбмен");
		
	Иначе
		
		ПодключитьОбработчикОжидания("ОбработчикОжиданияВыполнитьФоновыйОбмен", 1, Ложь);
		
	КонецЕсли;
	
КонецПроцедуры // ОбработчикОжиданияПроверитьСостояниеФоновогоЗадания
Показать
Dimon93dimon; +1 Ответить
Оставьте свое сообщение
Вопросы с вознаграждением