INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Снитковский Алексей | Исполнительный директор | 1С-Румыния

«Есть ли 1С:Жизнь за пределами Садового Кольца?»

В контексте данного доклада - "Садовое Кольцо" это метафора, охватывающая довольно-таки обширные географические пространства, на которых говорят по-русски (кое где - всё ещё говорят...) Для многих 1С:Наблюдателей "с Земли" всё, что находится за пределами этих территорий, по-прежнему видится бесконечно далёким и непонятным. И хотя многие из них уже серьёзно интересуются вопросом "есть ли жизнь на Марсе", для большинства наших коллег уход с привычной орбиты и полёт к этим неизведанным мирам остаётся несбыточной мечтой. Вашему вниманию будет предложен очередной репортаж о работе небольшой опытной экспедиции, отправленной в дальний космос с миссией распространения 1С:Культуры.

4. tindir 27.03.12 11:33 Сейчас в теме

Как получить название месяца по номеру ? :)

А есть ли методы или объекты выбора только месяца в виде как на прикрепленном файле (выбор месяца как в Вин7 в календаре)? Просто встал вопрос о выборе месяца в текущем году,а список значения на мой взгляд не нагляден.
Прикрепленные файлы:
Ответы
Сортировка: Древо
5. luns 3 27.03.12 13:03 Сейчас в теме
10. fromtomike 29 05.09.16 13:16 Сейчас в теме
(4) tindir, А чем стандартный диалог "ДиалогРедактированияСтандартногоПериода" не устраивает (я про УФ) ?
Вроде красиво, выделение мышкой работает, вариант редактирования настраивается
Прикрепленные файлы:
11. axelerleo 259 05.09.16 14:37 Сейчас в теме
(10) fromtomike,
Например, если нужно выбрать просто месяц, например "январь", и сформировать отчет за все январи, неважно какого года.
Такие задачи встречаются в основном при сравнении чего-нибудь (продаж, закупок, дебиторки и т.п.) по периодам.
6. Rishat7 2 21.12.12 11:52 Сейчас в теме
НаименованиеМесяца = Формат(НовДата, "ДФ=MMMM");
user1003854; Slashsm; +2 Ответить
7. Dunda 48 30.10.14 07:15 Сейчас в теме
я обычно вывожу дату какая она есть а потом пишу

//ДатаМ-это моя дата, которую надо сформатировать

МесяцМ=ПредставлениеПериода(НачалоМесяца(ДатаМ),КонецМесяца(КонецДня(ДатаМ)));
8. axelerleo 259 12.11.14 17:07 Сейчас в теме
Для СчМ = 1 по 12 Цикл
	М = Формат(Дата("0002" + Формат(счМ,"ЧЦ=2; ЧВН=") + "01"),"ДФ=ММММ");
КонецЦикла

Дата начинается с 0002, т.к. для января с 0001 будет пустая дата. Можно любой другой год указывать. Я это по-быстрому накидал, когда нужно было в контекстное меню добавить названия месяцев без привязки к дате.
9. Alever 4 05.09.16 11:33 Сейчас в теме
(8) axelerleo,

Немного переделал твой код.. получилось получаю все месяцы исходя ихз текущего года. Используя текущую дату в качестве строки для обработки формата.

	Для н =1 по 12 Цикл
		
		ТекущийГод = СтрЗаменить(Строка(Год(ТекущаяДата())), " ", "");
		
		Если СтрДлина(н)=1 Тогда
			ПорядковыйМесяц = "0"+н;
		Иначе
			ПорядковыйМесяц = н;
		КонецЕсли;
		
		Если СтрДлина(День(ТекущаяДата())) = 1 Тогда
			ТекущийДень = "0"+День(ТекущаяДата());
		Иначе
			ТекущийДень = День(ТекущаяДата());
		КонецЕсли;

		Данные = Формат(Дата(ТекущийГод + ПорядковыйМесяц + ТекущийДень),"ДФ=ММММ") + " " + ТекущийГод;
		
		ЭлементыФормы.Месяц.СписокВыбора.Добавить(Данные);
		
	КонецЦикла;
Показать
13. antz 12.01.17 11:06 Сейчас в теме
(9) Зачем такие мучения?

Для н = 1 по 12 Цикл
    	Данные = Формат(Дата(Год(ТекущаяДата()), н, 1), "ДФ='ММММ гггг'");
    	Элементы.Месяц.СписокВыбора.Добавить(Данные);
КонецЦикла;	
12. SLukin 17 12.01.17 10:53 Сейчас в теме
/// Как инициализировать дату отдельными компонентами в 1с 8.3, 8.2

Дата = Дата(2013, 07, 24); // 24.07.2013


К примеру зная отдельно: Год, Месяц и День

ТекущийГод   = Год(ТекущаяДата());
ТекущийМесяц = Месяц(ТекущаяДата());
ТекущийДень  = День(ТекущаяДата());

Дата = Дата(ТекущийГод, ТекущийМесяц, ТекущийДень); 
14. v3rter 12.01.17 11:45 Сейчас в теме
В копилку:
СокрП(Сред("        январь  февраль март    апрель  май     июнь    июль    август  сентябрьоктябрь ноябрь  декабрь ",Месяц*8+1,8))
bonya_by; kuzev; +2 Ответить
15. usparts@inbox.ru 14.05.09 14:53 Сейчас в теме
Задачка простенькая.. но просто интересно
Чтобы не писать:
Если НомерМесяца = 1 Тогда Возврат "Январь";
Иначе Если НомерМесяца = 2 Тогда Возврат "февраль";
...
КонецЕсли;

Можно как-то тоже самое получить системно ?

ЗЫ
Через Формат(Дата, " ") сделать не получается... Мне надо чтобы месяц был в именительном падеже :)

Подскажите можно как-то это сделать пользуясь системными функциями ? :)
16. elerian 14.05.09 15:05 Сейчас в теме
Можно!
Как раз через Формат(Дата,"ДФ=ММММ");
have fun
17. usparts@inbox.ru 14.05.09 17:02 Сейчас в теме
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Одесса (Украина)
зарплата от 40 000 руб.
Полный день

Программист 1С
Санкт-Петербург
Полный день

Аналитик 1С
Москва
зарплата от 80 000 руб. до 120 000 руб.
Полный день

1С Developer
Одесса (Украина)
зарплата от 60 000 руб. до 120 000 руб.
Полный день

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 70 000 руб. до 90 000 руб.
Полный день