0. hobi 551 26.07.12 22:32 Сейчас в теме

Использование функций внешнего отчета в вычисляемых полях системы компоновки данных. Добавлена поддержка расшифровки.

Нужно ли при необходимости использования новой функции в вычисляемых полях СКД всякий раз описывать её в общем модуле ?
НЕТ ! Если один раз описать в общем модуле универсальную функцию.
По предложению sam441 добавлена поддержка расшифровки в отчете.
В демонстрационном примере расшифровка открывается для всех полей отчета.

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. fixin 3876 29.07.12 00:05 Сейчас в теме
(0) Блжад, а ведь к этому методу я пришел самостоятельно... ;-)
Но рад что молодёжь тоше открыла его.
3. vec435 15 01.08.12 15:02 Сейчас в теме
вообще все не основные функ/проц можно вынести во внешнюю обработку. тогда в общем модуле получим код для вызова функ внешней обработки общиймодуль.во().внешняяфунк(парам1)
4. Flashback1979SE 15.08.12 04:15 Сейчас в теме
Вообще, клевый обход ограничения)). Спасибо за статью, теперь не придется "придумывать велосипед"). Побольше бы таких фишек, особенно для СКД.
5. powerpc 217 15.08.12 09:12 Сейчас в теме
Сорри, почему у меня ошибка как на скриншоте ???
Прикрепленные файлы:
6. sam441 46 23.08.12 09:18 Сейчас в теме
Спасибо, получилось, но есть момент не получается добавить расшифровку, формирование делаю так:
в модуле отчета процедура

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
	
	СтандартнаяОбработка = Ложь;
	
	Настройки = СхемаКомпоновкиДанных.НастройкиПоУмолчанию;
	ЭлементыНастроек = Настройки.ПараметрыДанных.Элементы;
	Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Отчет", ЭтотОбъект);
	
	КомпановщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
	МакетКомпановки = КомпановщикМакета.Выполнить(СхемаКомпоновкиДанных,Настройки,ДанныеРасшифровки);
	
	ПроцессорКомпановки = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпановки.Инициализировать(МакетКомпановки,,ДанныеРасшифровки,Истина);
	
	ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
	ПроцессорВывода.Вывести(ПроцессорКомпановки);
	
КонецПроцедуры
Показать

Выходит: Ошибка отображения типов:
Отсутствует отображение для типа 'ВнешнийОтчетОбъект.Тест'

Без параметра ДанныеРасшифровки работает, но ес-но расшифровка нет
10. hobi 551 01.01.13 13:44 Сейчас в теме
(6) sam441, (7) powerpc, публикацию поправил.
В последней выгрузке была ошибка с вызовом экспортной функции менеджера справочника.
Разбираться особо не стал, поскольку это экзотический вариант использования, на практике
нужны вызовы функций из модуля самого внешнего отчета. Просто убрал вызов функции менеджера
справочника.
Но прикрутил работу с расшифровкой , спасибо sam441 за замечания.
Отчет тоже слегка изменил - изменил источник данных с запроса на объект и использовал макет.
По поводу источника: с объектом,по моему мнению,работать удобнее, поскольку полностью контролируется процесс
получения данных (можно посмотреть ТЗ, временные таблицы и пр.). А запрос в схеме компоновки данных -
своего рода "черный ящик", внутрь которого особо не заглянешь.
И еще один нюанс - столкнулся в ЗУПе как-то с ситуацией, когда в обычном приложении, на SQL базе были проблемы
с правами при исполнении запроса внутри схемы компоновки данных. Поскольку (цитата из справки к платформе по методу УстановитьПривилегированныйРежим): "В клиент-серверном варианте при выполнении на клиенте данный метод не выполняет никаких действий"). Так вот, запрос внутри схемы компоновки данных, выполняется именно на клиенте (если клиент - толстый, обычное приложение).
После переноса запроса в модуль отчета и передачи результата (ТЗ) в виде объекта, всё чудесным
образом разрешилось. Это я все к тому, зачем изменил источник на объект.
7. powerpc 217 18.10.12 11:01 Сейчас в теме
У меня не работает все равно
8. powerpc 217 18.10.12 11:05 Сейчас в теме
9. hobi 551 18.10.12 21:52 Сейчас в теме
С расшифровкой отчет не пробовал, надо посмотреть, как прикрутить.
11. nanik 5 19.03.13 14:23 Сейчас в теме
С коллегами разбираем как раз вопросы об вычисляемых полях в компоновке данных, вернее ограничения (минимум функций, которые можно использовать). В Платформе 8.3 их уже конечно больше, но переходим на 8.2, да и 8.3 не покроет потребности, а выносить каждый раз их в общий модуль не выход.
12. nanik 5 19.03.13 14:25 Сейчас в теме
Подобная мысль была, а теперь есть и факт и реализация.
13. legrey 66 26.04.13 16:25 Сейчас в теме
Просто бобмба ! Очень кстати. Сэкономил кучу времени
14. Svb84 21.03.14 09:48 Сейчас в теме
Как в функции-посреднике вызывается функция модуля отчета?
15. Патриот 239 04.04.14 15:31 Сейчас в теме
(14) Svb84, я так написал:
//Данная функция позволяет использовать в вычисляемых полях СКД экспортные функции самого отчета
//Объект - ОтчетОбъект
//НаименованиеФункции - Имя экспортной функции этого объекта
//Парам1 - Парам9 - Параметры, которые будут переданы в эту функцию
Функция _Фу(Объект, НаименованиеФункции, Парам1 = Неопределено, Парам2 = Неопределено, Парам3 = Неопределено, Парам4 = Неопределено, Парам5 = Неопределено, Парам6 = Неопределено, Парам7 = Неопределено, Парам8 = Неопределено, Парам9 = Неопределено)Экспорт
	Результат = Неопределено;
	Если Не Объект = Неопределено Тогда 
		Попытка
			СписокПараметров = "";
			Для Итератор = 1 По 9 Цикл
				Если Не Вычислить("Парам" + Итератор + " = Неопределено") Тогда
					СписокПараметров = СписокПараметров + "Парам" + Итератор + ",";	
				КонецЕсли;
			КонецЦикла;
			СписокПараметров = Лев(СписокПараметров, СтрДлина(СписокПараметров) - 1);
			Результат = Вычислить("Объект." + НаименованиеФункции + "(" + СписокПараметров + ")");
		Исключение
			Сообщить("Ошибка при попытке нахождения вычисляемого поля. Ошибка в функции """ + НаименованиеФункции + """" + Символы.ПС + ОписаниеОшибки());
		КонецПопытки;
	Иначе
		Сообщить("Ошибка при попытке нахождения вычисляемого поля. Не задан Объект.");	
	КонецЕсли;
	Возврат Результат; 	
КонецФункции	
Показать
16. Патриот 239 04.04.14 15:46 Сейчас в теме
(0) Штука очень полезная, автору однозначно плюс. Но нужно было указать один важный момент - при закрытии отчета ссылку на объект (которую мы поместили в параметр компоновщика настроек) надо убить (присвоить этому параметру "неопределено"), иначе, после закрытия отчета, старый объект будет жить вплоть до завершения сеанса 1С. Кроме того, что это в принципе зло, это может помешать отладке отчета, т.к. все время будет запускаться старая версия (т.к. по факту отчет не будет перезапускаться).
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Рязань
зарплата от 90 000 руб.
Полный день

Бизнес-архитектор 1С, ведущий консультант
Санкт-Петербург
Полный день

Руководитель проектов 1С
Санкт-Петербург
Полный день


Программист 1С
Краснодар
зарплата от 80 000 руб. до 160 000 руб.
Полный день