1. TOlikRx 07.07.12 22:05 Сейчас в теме

Запретить ПриАктивизацииСтроки при обращении к элементу формы

Для динамического списка создан обработчик ПриАктивизацииСтроки. В обработчике вызываю процедуру "СоздатьДанныеПараметров":

&НаСервере
Процедура СоздатьДанныеПараметров()
ДанныеИмя = "Поле_1";
ДанныеТип = Новый ОписаниеТипов("Строка");
ДанныеПуть = "";
ДанныеЗаголовок = "Тип";
ПолеДанных = Новый РеквизитФормы(ДанныеИмя, ДанныеТип, ДанныеПуть, ДанныеЗаголовок);
ДанныеМассив = Новый Массив;
ДанныеМассив.Добавить(ПолеДанных);
ИзменитьРеквизиты(ДанныеМассив);
КонецПроцедуры

После выполнения данной процедуры, почему то обработчик возвращается к ПриАктивизацииСтроки и все зацикливается и соответственно вылетает. Почему так происходит и как решить проблему правильно ?
Ответы
Избранное Подписка Сортировка: Древо
2. TOlikRx 07.07.12 23:21 Сейчас в теме
Сделал так:

&НаКлиенте
Процедура СписокПриАктивизацииСтроки(Элемент)
ПодключитьОбработчикОжидания("ВывестиДанныеТекущегоЭлемента", 0.1, Истина);
КонецПроцедуры

&НаКлиенте
Процедура ВывестиДанныеТекущегоЭлемента()
<Вызов_Процедуры_Создания_Элементов>
ОтключитьОбработчикОжидания("ВывестиДанныеТекущегоЭлемента")
КонецПроцедуры

Все работает, но только в ПодключитьОбработчикОжидания указал в 3м параметре Истина, а она повторяется. Хотя в минуале написано, что 3й параметр если истина, то повторяется однократно. Пришлось по окончании действий прописать ОтключитьОбработчикОжидания("ВывестиДанныеТекущегоЭлемента")
3. basicm 08.07.12 21:51 Сейчас в теме
Зачем может понадобиться пересоздавать реквизиты формы при активизации строки?)
4. Chameleon1980 25.09.16 07:08 Сейчас в теме
вот еще на подобную тему от Гилева
Прикрепленные файлы:
Warning-2011-02-24-OnActivateRow.avi
tigcorp; KrakoZyabl; RibD; levante90; Rudakov_D; morbus; +6 Ответить
6. morbus 21.12.16 17:53 Сейчас в теме
(4) Спасибо огромное, сразу на несколько вопросов получил ответ!
И избавился от зацикливания!
7. levante90 19.05.17 12:53 Сейчас в теме
(4) Спс, очень помогло видео)
10. KrakoZyabl 77 11.12.18 21:10 Сейчас в теме
(4) Спасибо автору за поднятую тему, а Chameleon1980 за ссылку на видео. Мне помогло, оказывается я вызывал серверный метод в котором использовался запрос, а в запросе была ошибка, и ту ошибку мне не показывало 1С. Благодарю вас ребята!!!
5. Chameleon1980 25.09.16 07:19 Сейчас в теме
СП говорит жеж:

ТаблицаФормы.ПриАктивизацииСтроки (FormTable.OnActivateRow)
ТаблицаФормы (FormTable)
ПриАктивизацииСтроки (OnActivateRow)
Синтаксис:

ПриАктивизацииСтроки()
Описание:

Вызывается при активизации строки таблицы.
Примечание:

В обработчике данного события нельзя использовать серверные методы формы с директивой компиляции &НаСервере.
dreamerr7; acanta; levante90; sommid; morbus; +5 Ответить
8. baracuda 2 29.09.18 14:32 Сейчас в теме
(5) поясните пож-та, что значит серверные методы формы с директивой компиляции &НаСервере

серверные процедуры у меня вызываются
9. acanta 71 29.09.18 14:51 Сейчас в теме
При активизации строки обращение к данным не должно быть. Один и тот же код вычисления итогов по выделенным строкам в толстом клиенте на форме регистра сведений зацикливается, в обработке нормально. Полагаю, что в динамическом списке тоже должно работать, если источник списка запрос, а не сам регистр.
motorsoft; +1 Ответить
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Москва
зарплата до 160 000 руб.
Полный день

Ведущий программист 1С; Оплачиваемый переезд в Ростов-на-Дону
Краснодар
зарплата от 50 000 руб. до 120 000 руб.
Полный день

Ведущий программист 1С; Оплачиваемый переезд в Ростов-на-Дону
Екатеринбург
зарплата до 120 000 руб.
Полный день

Ведущий программист 1С
Ростов-на-Дону
зарплата от 50 000 руб. до 120 000 руб.
Полный день

Консультант 1С
Москва
зарплата от 100 000 руб. до 140 000 руб.
Временный (на проект)