Алексей Королев | Principal IT Risk Manager | Wirecard Technologies GmbH

«Можно ли автоматизировать не только родину или Как специалист 1С может найти работу за рубежом?»

Возможно кто-то из участников конференции иногда задумывается о том, что было бы интересно попробовать поработать за границей. Но, как правило, все эти раздумывания достаточно быстро заканчиваются, так как не очень понятно, как именно это можно осуществить. В своем докладе я постараюсь ответить на следующие вопросы: * Как специалист 1С может найти работу за рубежом? (на примере нескольких кейсов, в том числе личном) * Что необходимо учитывать при переезде? * Как понять, над чем нужно работать, и что можно использовать в поиске работы? * Насколько релевантен опыт с 1С в иностранных компаниях? * Так ли важны soft-skills, как о них говорят? * Какие инструменты можно использовать?

Запретить ПриАктивизацииСтроки при обращении к элементу формы

1. TOlikRx 07.07.12 22:05 Сейчас в теме
Для динамического списка создан обработчик ПриАктивизацииСтроки. В обработчике вызываю процедуру "СоздатьДанныеПараметров":

&НаСервере
Процедура СоздатьДанныеПараметров()
ДанныеИмя = "Поле_1";
ДанныеТип = Новый ОписаниеТипов("Строка");
ДанныеПуть = "";
ДанныеЗаголовок = "Тип";
ПолеДанных = Новый РеквизитФормы(ДанныеИмя, ДанныеТип, ДанныеПуть, ДанныеЗаголовок);
ДанныеМассив = Новый Массив;
ДанныеМассив.Добавить(ПолеДанных);
ИзменитьРеквизиты(ДанныеМассив);
КонецПроцедуры

После выполнения данной процедуры, почему то обработчик возвращается к ПриАктивизацииСтроки и все зацикливается и соответственно вылетает. Почему так происходит и как решить проблему правильно ?
Ответы
Сортировка: Древо
2. TOlikRx 07.07.12 23:21 Сейчас в теме
Сделал так:

&НаКлиенте
Процедура СписокПриАктивизацииСтроки(Элемент)
ПодключитьОбработчикОжидания("ВывестиДанныеТекущегоЭлемента", 0.1, Истина);
КонецПроцедуры

&НаКлиенте
Процедура ВывестиДанныеТекущегоЭлемента()
<Вызов_Процедуры_Создания_Элементов>
ОтключитьОбработчикОжидания("ВывестиДанныеТекущегоЭлемента")
КонецПроцедуры

Все работает, но только в ПодключитьОбработчикОжидания указал в 3м параметре Истина, а она повторяется. Хотя в минуале написано, что 3й параметр если истина, то повторяется однократно. Пришлось по окончании действий прописать ОтключитьОбработчикОжидания("ВывестиДанныеТекущегоЭлемента")
3. basicm 08.07.12 21:51 Сейчас в теме
Зачем может понадобиться пересоздавать реквизиты формы при активизации строки?)
4. Chameleon1980 25.09.16 07:08 Сейчас в теме
вот еще на подобную тему от Гилева
Прикрепленные файлы:
Warning-2011-02-24-OnActivateRow.avi
RibD; levante90; Дмитрий Рудаков; morbus; +4 Ответить
6. morbus 21.12.16 17:53 Сейчас в теме
(4) Спасибо огромное, сразу на несколько вопросов получил ответ!
И избавился от зацикливания!
7. levante90 19.05.17 12:53 Сейчас в теме
(4) Спс, очень помогло видео)
5. Chameleon1980 25.09.16 07:19 Сейчас в теме
СП говорит жеж:

ТаблицаФормы.ПриАктивизацииСтроки (FormTable.OnActivateRow)
ТаблицаФормы (FormTable)
ПриАктивизацииСтроки (OnActivateRow)
Синтаксис:

ПриАктивизацииСтроки()
Описание:

Вызывается при активизации строки таблицы.
Примечание:

В обработчике данного события нельзя использовать серверные методы формы с директивой компиляции &НаСервере.
levante90; sommid; morbus; +3 Ответить
Оставьте свое сообщение

Вакансии

Программист 1С
Москва
Полный день

Программист 1С
Москва
Полный день

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 80 000 руб. до 100 000 руб.
Полный день

Руководитель проектов по внедрению 1С документооборота
Санкт-Петербург
зарплата от 100 000 руб. до 130 000 руб.
Полный день

Руководитель по сопровождению и внедрению 1С
Санкт-Петербург
зарплата от 100 000 руб. до 120 000 руб.
Полный день