0. snikers44 12 12.05.12 14:44 Сейчас в теме

Получение иерархии справочника "Номенклатура"

Элементарная обработка для получения иерархии групп справочника "Номенклатура" без дублей.

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. anig99 2703 15.05.12 11:50 Сейчас в теме
Техническая сложность исполнения и практическая значимость данной обработки равно 0
2. snikers44 12 15.05.12 18:01 Сейчас в теме
(1) anig99, если для вас она не представляет практической значимости, - это не значит, что не представляет ни для кого... насчет технической сложности, - не все гуру программирования 1С и для кого-то это может представлять сложность...
5. anig99 2703 16.05.12 07:57 Сейчас в теме
(2) данная обработка не представляет ценности ни для кого, кроме Вас. Так как обучаться нужно по учебникам, курсам и гораздо более сложным разработкам.
3. cinfo 16.05.12 02:19 Сейчас в теме
4. Necytij 16.05.12 07:28 Сейчас в теме
К сожалению, у меня не достаточно рейтинга чтобы ставить минусы.
Ваш супер функционал не гуру может сформировать типовой отчет "универсальный", который в типовых уже очень давно в наличии...
6. kser87 1962 16.05.12 10:52 Сейчас в теме
А я скажу: спасибо за обработку.
7. V.Nikonov 119 16.05.12 12:23 Сейчас в теме
Элементарная обработка для получения иерархии групп справочника "Номенклатура" без дублей.

Вообще-то это отчет. А что Значит "БЕЗ ДУБЛЕЙ"?

Теоретически запуск мог бы встраиваться в какую нибудь форму-список или Форму элемента...(для справочников в которых отсутствует доп.окно с деревом). Или дополнение к обработке результатов запроса возвращающего список элементов, а просмотреть желательно иерархию этих элементов...

Только, если это есть учебное пособие, то удобнее опубликовать в тексте фрагменты кода с комментариями поясняющие логику...
Если это есть полезная примочка к программе, то есть смысл расписать случаи полезности...

P.S. Соответственно для Публикации в таком виде хочется поставить минус!
8. snikers44 12 16.05.12 13:09 Сейчас в теме
(7) V.Nikonov, Согласен, вид публикации оставляет желать лучшего, просто первая публикация, - не судите строго... Отчет создал на скорую руку для себя, так как не нашел такого на инфостате, решил поделиться, чтоб народ мог легко получить иерархию справочника "Без дублей", тех, которые создаются при группировке итогов по иерархии. Очистка дублей производится дополнительной функцией.
Функция обУбратьОшибкиИтоговПоИерархии(Строки, Поле="Ссылка", Родитель=Неопределено) Экспорт 
    //Убираем все элементы, равные текущему
    Всего=Строки.Количество();
    Для Инд=1 По Всего Цикл
        Стр=Строки[Всего-Инд];
        Зн=Стр[Поле];
        Если Родитель<>Неопределено И Зн=Родитель Тогда
            Строки.Удалить(Стр);
        Иначе
            обУбратьОшибкиИтоговПоИерархии(Стр.Строки, Поле, Зн);
        КонецЕсли;
    КонецЦикла;
КонецФункции
Показать
9. V.Nikonov 119 16.05.12 21:11 Сейчас в теме
(8) И что? Редактировать Публикацию не будем?

Оставим её для галочки? :-(
11. snikers44 12 17.05.12 13:30 Сейчас в теме
(9) V.Nikonov, Отредактировал чуток=) спасибо за адекватную помощь в публикации...
P.S. Просто от нахлынувших негативных отзывов хотелось просто закрыть публикацию, и, возможно, не сэкономить пару минут действительно нуждающимся людям...
10. DrAku1a 1305 17.05.12 02:39 Сейчас в теме
Ну-ка-дети-скажем-дружно "НА-ФИГА-НАМ ЭТО НУЖНО?"
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Администратор БД 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день

Программист 1С Документооборот
Санкт-Петербург
зарплата от 110 000 руб.
Полный день

Программист 1С БП / ЗУП
Санкт-Петербург
зарплата от 110 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Программист/Cтарший программист 1С
Москва
зарплата от 100 000 руб. до 250 000 руб.
Полный день