0. CalvinK 37 21.03.12 18:12 Сейчас в теме

Справка 2-НДФЛ. Делаем удержанный и перечисленный равным исчисленному

Простенькая обработка. Делает НДФЛ удержано и перечислено равным исчисленному в документах "Справка 2-НДФЛ для передачи в ИФНС" и "Справка о заработке (2-НДФЛ) сотрудникам".

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. Slavez 24 21.03.12 18:12 Сейчас в теме
Спасибо. Актуально.
Зачем придумали этот "перечисленный"...
2. rassss 23.03.12 06:43 Сейчас в теме
Спасибо. да конечно перечисленный налог это такое же извращение как ив пенссионном фонде тоже.Но что касаеться обработке,не всегда же удержанный должен быть равен начисленному?я бы сказал что наоборот в большинстве случаев он не должен быть равен исчисленному налогу,не понятно почему это так пугает и людей и налоговые органы .К нам приезжала проверка и тетя с налоговой незнала что такое НДФЛ удержанный))))))))))))))))))))))))
3. CalvinK 37 23.03.12 16:32 Сейчас в теме
Согласен, что удержанный может быть не равен исчисленному даже при устан галочке в параметрах учета, например, при переходящем отпуске (Я своих клиентов приучаю отражать весь НДФЛ в мес начисления (законодат не нарушается, есть 2 позиции)). Большинство организаций предпочитают ставить галочку исч=удерж в параметрах учета и платят по исч, забывая про удержанный, а вот в программе пользователи то эту галочку в параметрах учета поперетыкивают, то исправления всякие повносят. Врезультате по факту всё ровно, а в программе неразбериха, отчёт на носу. Вот сначала отчёт ровненький сдаем, а потом разбираюсь с их ошибками:)
user658272_i.savtsova; +1 Ответить
4. Attest 3 23.03.12 17:48 Сейчас в теме
Спасибо за обработку! Нужна как воздух, бухи заставляют проверять перечисления НДФЛ по 600 сотрудником, у них не бьёт, а виноваты программисты! Надоело!
5. capt_nemo 24.03.12 19:39 Сейчас в теме
Попал в четверг к клиенту, стоит ЗУП 8.2, расчетчик 2-ой день на работе, ей сказали сдаешь НДФЛ, работай дальше!!! Сотрудников 800. Обработка спасла человека, плюсую.
6. Alex Star 10 29.03.12 09:51 Сейчас в теме
Бухи тоже попросили, сделал, но как обработку заполнения табличных частей, я думаю так было-бы удобнее, без выбора документа, а непосредственно в сам документ подключить
Кстати вот:
Процедура Инициализировать(Объект, СотрудникиОрганизации, ТабличноеПоле = Неопределено) Экспорт
	//Объект = Документы.СправкаПоНДФЛВНалоговыйОрган.СоздатьДокумент();
	Табл = Объект.СотрудникиОрганизации;
	Для Каждого Стр Из Табл Цикл
		Стр.Перечислено = Стр.Исчислено;
	КонецЦикла;
	Табл = Объект.СуммыНалогов;
	Для Каждого Стр Из Табл Цикл
		Стр.Перечислено = Стр.Исчислено;
	КонецЦикла;
КонецПроцедуры
Показать
Abbra; Spirit11; elvis1917; +3 Ответить
7. CalvinK 37 29.03.12 15:24 Сейчас в теме
Да, у меня тоже сначала кнопка в документе была. Программный код у меня не сложнее:)
9. Bruk 50 23.04.13 20:52 Сейчас в теме
Спасибо Огромное!! Очень нужная обработка, а главное ко времени)
10. Seba 23.02.14 17:23 Сейчас в теме
Спасибо! Очень пригодилась обработка!
11. Gasilin 17 26.02.16 16:56 Сейчас в теме
12. FVK 04.03.16 10:53 Сейчас в теме
13. CalvinK 37 10.03.16 08:04 Сейчас в теме
14. user658272_i.savtsova 27.01.17 08:24 Сейчас в теме
спасибо) очень нужная обработка, только жаль в ЗУП 3.1 не открывается... Можно ли ее как то подогнать?
15. Agema 27.01.17 18:41 Сейчас в теме
(14)нет, там свосем другие регистры и справочники.
16. irina_ph 15.03.19 23:07 Сейчас в теме
скажите а для ЗКГУ 3. есть такая обработка?
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Ведущий программист 1С
Санкт-Петербург
зарплата от 130 000 руб.
Полный день

Ведущий программист 1С
Омск
зарплата от 70 000 руб. до 110 000 руб.
Полный день

Консультант-аналитик 1С ЗУП 3.1
Белгород
зарплата от 40 000 руб. до 50 000 руб.
Полный день

Программист 1С
Москва
зарплата от 130 000 руб. до 200 000 руб.
Полный день