0. Арчибальд 2708 01.01.70 03:00 Сейчас в теме

Ликбез 7.7: Инициализация переменных во внешнем отчете.

Хотя апологеты самодокументированных программ категорически не рекомендовали передавать в процедуры параметры-ссылки, все же иногда хочется.

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. Арчибальд 2708 25.06.10 12:24 Сейчас в теме
2. hogik 430 25.06.10 20:13 Сейчас в теме
(0)
Лишний текст: "пКолСсылок=0" ;-)

глОтчетСоСсылками(пФайл, СписПар="", п1="", п2="", п3="",..., пN="")
...
СписПар.ВставитьЗначение(1,п1);
СписПар.ВставитьЗначение(2,п2);
СписПар.ВставитьЗначение(3,п3);
...
СписПар.ВставитьЗначение(N,пN);
3. Арчибальд 2708 28.06.10 07:27 Сейчас в теме
(2) пКолСсылок - это не количество параметров, а именно количество "ссылочных" параметров, т.е. которые будут изменяться внешним отчетом. Вставить, конечно, можно и так. Но получить потом значения для присвоения - по количеству.
4. hogik 430 28.06.10 14:00 Сейчас в теме
(3)
Угу. ;-)
А которые НЕ будут меняться надо класть в "СписПар" после трех первых?
Думаю, и текст "СписПар=""," лишний...
5. Арчибальд 2708 28.06.10 14:46 Сейчас в теме
(4) Большое количество существующих внешних отчетов получают в качестве "аргумента" именно список значений - например, стандартные ВПФ, помощники заполнения документов и т.п. И если я захочу в готовом отчете что-то дополнительно сделать, мне не придется ничего разрушать.
Кстати, из такой хотелки и появилась эта процедурка, реально встроенная в одну заказанную мне конфу.
6. hogik 430 28.06.10 15:15 Сейчас в теме
(5) "...в готовом отчете...не придется ничего разрушать"
А цель "Ликбеза": "Формировать список значений парамеров, передавать его, получать значения...". Не понимаю. Жарко у нас... ;-)
Процедура глОтчетСоСсылками(пФайл, п1="", п2="", п3="") Экспорт
                Перем СписПар, лИмя;
                Если ПустаяСтрока(пФайл) = 1 Тогда
                               Сообщить("Не задано имя файла отчета!");
                               Возврат;
                КонецЕсли;
                Если ФС.СуществуетФайл(пФайл) = 0 Тогда
                               Сообщить("Не найден файл "+пФайл+" !");
                               Возврат;
                КонецЕсли;
                СписПар = СоздатьОбъект("СписокЗначений");
                СписПар.ВставитьЗначение(1,п1);
                СписПар.ВставитьЗначение(2,п2);
                СписПар.ВставитьЗначение(3,п3);
                ОткрытьФормуМодально("Отчет", СписПар, пФайл);
                п1 = СписПар.ПолучитьЗначение(1,лИмя);
                п2 = СписПар.ПолучитьЗначение(2,лИмя);
                п3 = СписПар.ПолучитьЗначение(3,лИмя);
КонецПроцедуры
Показать
7. hogik 430 28.06.10 19:10 Сейчас в теме
(0)"...ибо не только ссылки, как правило, должны передаваться в отчет..."
Да, надо передавать список и сразу затирать его другими параметрами... ;-)
8. hogik 430 28.06.10 22:40 Сейчас в теме
(0)
Александр.
Жара у нас спала? ;-)
Задаю вопрос.
В Вашем первом тексте смысл - поставить параметры-ссылки в начало списка "СписПар", а все остальные параметры-значения поместить в этот список заранее (и потом сдвинуть к концу списка), и тем самым "запретить" их изменение во "внешнем отчете"? Тогда - да. Всё верно. Хотя, думаю, и не имеет большого смысла, т.к. "внешний отчет" всегда должен точно "знать" порядок параметров и "понимать" их смысл в части возможности возвращаемого значения. Ну, а если "внешний отчет" это не "понимает", то это уже к доктору... Или к тексту из (6) сообщения.
9. Арчибальд 2708 29.06.10 07:31 Сейчас в теме
(8) Ну да, такой смысл я и вкладывал. В особенности, с учетом того, что во внешних "стандартных" отчетах манипуляция параметрами происходит по именам, а не по позициям (Установить/Получить).
Поясню еще свою позицию насчет количества ссылок. В давние Фортрановские времена слиталось опасным обращаться к процедуре с числовым литералом в качестве параметра, поскольку некоторые трансляторы все литералы превращали в константы и передавали их адреса. В результате после вызова SQRT(3) далее можно получить 2*3 = стеариновая свечка. По слухам, из-за подобной ситуации упал Апполон-10 (по другим источникам - из-за точки вместо запятой в операдоре DO).
Так что у меня присутствует генетическое неприятие записи результата "в никуда". Да и по Клипперной практике - удобно первым параметром процедуры/функции всегда иметь количество аргументов :)
10. hogik 430 29.06.10 14:18 Сейчас в теме
(9)
Вот теперь "Ликбез 7.7" "Для новичков" удался. :-)
Только, думаю, новички уже не начинают программировать со среды "1С 7.7".
Да и про "Клиппер" с Фортраном уже не знают...
11. Арчибальд 2708 29.06.10 14:27 Сейчас в теме
(10)
Да и про "Клиппер" с Фортраном уже не знают...
В этом и беда их. Абсолютная зашоренность. Новую платформу считают неким прорывом - это при том, что в программировании с 85 года ("японский вызов - 6 поколение") ничего нового не произошло.
12. ne_en 49 30.06.10 05:02 Сейчас в теме
Пример как я обычно поступаю:

// Запросим пароль
Параметры=СоздатьОбъект("СписокЗначений");
Параметры.Установить("Статус","Отмена");
Параметры.Установить("Пароль","");
Параметры.Установить("ЗаголовокОкна","Пароль на запрет отрицательных остатков по складу");
ОткрытьФормуМодально("Обработка.ВводПароля",Параметры);
Если Параметры.Получить("Статус")="ОК" Тогда
	Если Параметры.Получить("Пароль")<>"123456789" Тогда
		СтатусВозврата(0);
		Предупреждение("Изменения не записаны, изменен параметр разрешения отрицательных остатков по складу. Неправильный пароль.",20)
	КонецЕсли
Иначе
	Предупреждение("Изменения не записаны, изменен параметр разрешения отрицательных остатков по складу. Не введен пароль.",20)
КонецЕсли
Показать



А в обработке (универсальная форма ввода пароля)

Перем Параметры;

//*******************************************
Процедура Отменить()
	Параметры.Установить("Статус","Отмена");
	Параметры.Установить("Пароль","");
	СтрокаДействийФормы="#Закрыть";
КонецПроцедуры

//*******************************************
Процедура Выполнить()
	Параметры.Установить("Статус","ОК");
	Параметры.Установить("Пароль",Пароль);
	СтрокаДействийФормы="#Закрыть";
КонецПроцедуры

//*******************************************
Процедура ПриОткрытии()
	Параметры=Форма.Параметр;
	Если ПустоеЗначение(Параметры)=1 Тогда
		СтатусВозврата(0);
		Возврат
	КонецЕсли;
	Если ТипЗначенияСтр(Параметры)<>"СписокЗначений" Тогда
		СтатусВозврата(0);
		Возврат
	КонецЕсли;
	ЗаголовокОкна=Параметры.Получить("ЗаголовокОкна");
	Если ПустоеЗначение(ЗаголовокОкна)=1 Тогда
		ЗаголовокОкна="Ввод пароля"
	КонецЕсли;
	Форма.Заголовок(ЗаголовокОкна,0)
КонецПроцедуры
Показать


Так же я поступаю при вызове отчетов и обработок. Все просто и глобальную процедуру(функцию) можно нарисовать на раз два... Но надо ли оно...
13. Арчибальд 2708 30.06.10 08:04 Сейчас в теме
(12) Я когда пишу конфу "с нуля", начинаю с полудюжины любимых глобальных процедур, одна из которых - глВычислитьВнешний. Гораздо меньше одинаковых кусков писать приходится.
14. sss999 39 30.06.10 10:01 Сейчас в теме
Рассказ про апплон кончно скрасил статью),вот интересно а какие параметры передаете,что так ускоряет работу?единственно такой отчет не буде работать в друой конфигурации.
15. Арчибальд 2708 30.06.10 10:25 Сейчас в теме
(14) Это не отчет, а добавочка к глобальному модулю, которую полезно иметь при расширении функционала внешними отчетами с "перекрестными" вызовами.
16. ne_en 49 01.07.10 06:50 Сейчас в теме
(15) Посмотрел свои внешние отчеты с "перекрестными" вызовавами... В подавляющем большинстве случаев не обхожусь я тремя параметрами (ну это мелочи, но до коих пор расширять то список параметров...), а при выходе из обработки, чаще всего нужно для начала проанализировать один параметр (иногда два), что бы уже не получать значения остальных. При вот такой "глобализации" же приходится сначала получить значения всех параметров (даже тех, что не рассчитывались, а это бывают и списки и таблицы данных), а только после этого выяснять, нужно ли чего-то с ними делать или у обработки был отказ (ошибочные параметры/данные или пользователь отказался от каких-то действий). А ещё часть параметров нужно передать только туда, а обратно они не нужны (ну взять хотя бы ДатаНачала, ДатаКонца, а круче ТаблМПЗ), при этом на все эти возвраты требуется расходование процессорного времени и иногда значительного, а на сервере терминалов где одновременно может работать пара-тройка десятков пользователей такие вещи уже имеют значение. Вот всем этим (особенно экономией процессорных мощностей) и обусловлен мой выбор "индивидуального подхода" при передаче и получении параметров в отчеты и обработки, при этом совершенно не сложно заниматься копипастингом или создать шаблон(ы).

Выше сказанное не означает, что Ваш алгоритм непригоден, для него есть своя ниша функционала, и в небольших организациях, где работает не много пользователей, такой расход процресурсов не будет играть существенной роли, заставляющей раньше переходить на более дорогие сервера или даже на распределение нагрузки между несколькими серверами (и более "крутого" админа) для комфортной работы с базой данных.
Пожалуй я поддержу автора, но с оговоркой, что использование его ограниченно в связи с часто нерациональным использованием процресурсов.
Арчибальд; +1 Ответить
17. Арчибальд 2708 01.07.10 07:31 Сейчас в теме
(16) Отличный комментарий. Подписуюсь под каждым словом. Особенно
а при выходе из обработки, чаще всего нужно для начала проанализировать один параметр (иногда два)
У меня, на самом деле, в глобальнмке стоит функция, выдающая результат работы внешнего отчета, и до прошлого года ее (т.е. одного результата) хватало.
И, конечно же, использование внешних отчетов вместо внутренних процедур/функций жрет ресурсов немерено...
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Ведущий программист 1С
Омск
зарплата от 70 000 руб. до 110 000 руб.
Полный день

Программист 1С
Екатеринбург
зарплата до 120 000 руб.
Полный день

Консультант-аналитик 1С
Рязань
зарплата до 80 000 руб.
Полный день

Программист 1С
Калининград
зарплата от 60 000 руб. до 80 000 руб.
Полный день

Программист 1С
Рязань
зарплата от 90 000 руб.
Полный день