Свойство формы - "Только просмотр"

1. user2022268 05.06.24 12:07 Сейчас в теме
Добрый день! Пыталась закрыть все элементы на форме кроме одного, но по итогу, все элементы закрытые. Подскажи как еще можно прописать? Ниже приведу то, что пыталась сделать.
Прикрепленные файлы:
По теме из базы знаний
Найденные решения
2. spacecraft 05.06.24 12:17 Сейчас в теме
(1) установка Форма.ТолькоПросмотр = Истина главнее. И становится неважно, какие значения ТолькоПросмотр у отдельных элементов.
Разместить элементы по группам. Для них устанавливать отдельно
Разрешаемый на редактирование элемент вынести отдельно. для него соответственно отдельно.
user1671936; user2022268; +2 Ответить
Остальные ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. spacecraft 05.06.24 12:17 Сейчас в теме
(1) установка Форма.ТолькоПросмотр = Истина главнее. И становится неважно, какие значения ТолькоПросмотр у отдельных элементов.
Разместить элементы по группам. Для них устанавливать отдельно
Разрешаемый на редактирование элемент вынести отдельно. для него соответственно отдельно.
user1671936; user2022268; +2 Ответить
3. karamazoff 113 05.06.24 14:45 Сейчас в теме
вот так еще можно
		Для каждого эл из Элементы цикл  
			Если эл.Имя = "НомерУПД"  Тогда
				продолжить;
			КонецЕсли;	
			уд = Новый УникальныйИдентификатор;
			фильтр = Новый Структура("ТолькоПросмотр",уд);
			ЗаполнитьЗначенияСвойств(фильтр,эл);
			Если НЕ фильтр.ТолькоПросмотр = уд Тогда
				эл.ТолькоПросмотр = Истина;
			КонецЕсли;   
		КонецЦикла;

Показать


подстройте под себя, это при создании на сервере в форме
user2022268; +1 Ответить
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот