Выделение цветом строк отчета при условии

1. ShadowRun2012 05.06.24 00:10 Сейчас в теме
Люди добрые, ни как не могу разобраться как выделить строку в отчете по остатку на складе, если остаток < 3. Перерыл весь интернет, ни один из предложенных вариантов не подходит(((

Процедура КнопкаСформироватьНажатие(Кнопка)
	
    Номенклатура.Очистить();
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	РегистрСкладаОстатки.Организация,
		|	РегистрСкладаОстатки.Склад,
		|	РегистрСкладаОстатки.КоличествоОстаток КАК Количество,
		|	РегистрСкладаОстатки.Номенклатура КАК Номенклатура
		|ИЗ
		|	РегистрНакопления.РегистрСклада.Остатки КАК РегистрСкладаОстатки
		|ГДЕ
		|	РегистрСкладаОстатки.Организация = &Организация
		|	И РегистрСкладаОстатки.Склад = &Склад";

	Запрос.УстановитьПараметр("Организация", Организация);
	Запрос.УстановитьПараметр("Склад", Склад);

	Результат = Запрос.Выполнить();

	ВыборкаДетальныеЗаписи = Результат.Выбрать();

	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		ЭлементыФормы.Номенклатура.ДобавитьСтроку();
		ЭлементыФормы.Номенклатура.ТекущаяСтрока.Номенклатура = ВыборкаДетальныеЗаписи.Номенклатура;
		ЭлементыФормы.Номенклатура.ТекущаяСтрока.ПолноеНаименование = ВыборкаДетальныеЗаписи.Номенклатура.ПолноеНаименование;
		ЭлементыФормы.Номенклатура.ТекущаяСтрока.ЕдИзмерения = ВыборкаДетальныеЗаписи.Номенклатура.ЕдиницаИзмерения;
		ЭлементыФормы.Номенклатура.ТекущаяСтрока.Остаток = ВыборкаДетальныеЗаписи.Количество;

		Если ВыборкаДетальныеЗаписи.Количество < 3 Тогда
			ЭлементыФормы.Номенклатура.Оформление.УстановитьЗначениеПараметра("ЦветФона", WebЦвета.Красный); 
					КонецЕсли
	КонецЦикла;

	
КонецПроцедуры
Показать
По теме из базы знаний
Найденные решения
6. independ 1542 05.06.24 21:43 Сейчас в теме
(5)
Прикрепленные файлы:
Остальные ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
4. independ 1542 05.06.24 20:51 Сейчас в теме
(1) Обычные формы, событие
Процедура ........ПолученииДанных(Элемент, ОформленияСтрок)
	Для каждого ОформлениеСтроки из ОформленияСтрок Цикл
		ДанныеСтроки=ОформлениеСтроки.ДанныеСтроки;
		Если  ДанныеСтроки.Количество<3 Тогда
			ОформлениеСтроки.ЦветФона = WebЦвета.Красный;
		КонецЕсли;	
	КонецЦикла;
КонецПроцедуры
5. ShadowRun2012 05.06.24 21:13 Сейчас в теме
(2)
(4)
Если ДанныеСтроки.Количество<3 Тогда
ОформлениеСтроки.ЦветФона = WebЦвета.Красный;
КонецЕсли;

Этот вариант в интернете тоже находил, но ответ всегда один:
{Отчет.ОстаткиНаСкладах.Форма.ФормаОтчета.Форма(36,4)}: Переменная не определена (ОформлениеСтроки)
<<?>>ОформлениеСтроки.ЦветФона = WebЦвета.Красный; (Проверка: Толстый клиент (обычное приложение))
6. independ 1542 05.06.24 21:43 Сейчас в теме
(5)
Прикрепленные файлы:
7. ShadowRun2012 05.06.24 22:14 Сейчас в теме
Спасибо огромное, а я ни как не мог понять почему получалось. Прям выручили
(6)
3. ShadowRun2012 05.06.24 20:06 Сейчас в теме
(2)
(2)Нет у меня Условного оформления, я об этом читал. Но в 8.3 нет его
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот