Помещение во временное хранилище

1. Dermidont 11 31.05.24 11:12 Сейчас в теме
Доброе утро, коллеги! Пытаюсь поместить массив строк во временное хранилище, выдаёт ошибку: Ошибка помещения значения во временное хранилище. Скрин массива представлен на вложенном файле. Не подскажете, что можно предпринять в этом случае?
Прикрепленные файлы:
По теме из базы знаний
Вознаграждение за ответ
Показать полностью
Найденные решения
10. SlavaKron 31.05.24 11:47 Сейчас в теме +0.8 $m
(9) Если вы потом хотите использовать адрес временного хранилища, например в родительской форме, то его следует либо изначально сгенерировать и помещать в параметр открываемой формы, либо в открываемой форме хранить адрес, полученный методом ПоместитьВоВременноеХранилище, в реквизите формы и далее передавать, куда требуется.
Остальные ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. SlavaKron 31.05.24 11:15 Сейчас в теме
(1) Предъявите, пожалуйста, полный текст ошибки и код помещения во временное хранилище.
3. Dermidont 11 31.05.24 11:20 Сейчас в теме
Код:

Если Добавляем Тогда    
			
			МассивСтруктур.Добавить(СокрЛП(Строка(Таблица.Область(НомСтроки, 2).Текст)) + ";" + СокрЛП(Строка(Таблица.Область(НомСтроки, 3).Текст)) + ";" + СокрЛП(Строка(Таблица.Область(НомСтроки, 6).Текст)) + ";" + СокрЛП(Строка(Таблица.Область(НомСтроки, 7).Текст)) + ";");
			
		КонецЕсли;
		
	КонецЦикла;	 
	
	Если МассивСообщенийОбОшибках.Количество() = 0 Тогда   
		Если ЗначениеЗаполнено(ЭтаФорма.Параметры.АдресВХранилище) Тогда 
		    ПоместитьВоВременноеХранилище(МассивСтруктур, ЭтаФорма.Параметры.АдресВХранилище);
		КонецЕсли;  
		Оповестить("ЗавершениеЗагрузки");
		ЭтаФорма.Закрыть();
Показать



Ошибка

Ошибка помещения значения во временное хранилище
{Обработка.ЕДК_Заполнение.Форма.СписокНоменклатуры.Форма(164)}:ПоместитьВоВременноеХранилище(МассивСтруктур, ЭтаФорма.Параметры.АдресВХранилище);
{Обработка.ЕДК_Заполнение.Форма.СписокНоменклатуры.Форма(939)}:Загрузить();

по причине:
Ошибка помещения значения во временное хранилище
4. spacecraft 31.05.24 11:26 Сейчас в теме
(3)
ЭтаФорма.Параметры.АдресВХранилище

Что в отладке показывает содержимое?
5. Dermidont 11 31.05.24 11:31 Сейчас в теме
(4) Туда передаю уникальный идентификатор формы, из которой открываю другую форму для загрузки. АдресВХранилище - ключевой параметр открываемой формы.
Прикрепленные файлы:
7. spacecraft 31.05.24 11:34 Сейчас в теме
(5)
Туда передаю уникальный идентификатор формы

Это не УникальныйИдентификатор. Это Строка. Это недопустимый тип.
6. Dermidont 11 31.05.24 11:34 Сейчас в теме
(4) Блин, наверное надо строку к уникальному идентификатору преобразовать. Сейчас попробую.
8. SlavaKron 31.05.24 11:36 Сейчас в теме
Только в коде смысла не прибавится, если не получить сгенерированный адрес временного хранилища.
9. Dermidont 11 31.05.24 11:44 Сейчас в теме
(8) Адрес = Новый УникальныйИдентификатор ?
10. SlavaKron 31.05.24 11:47 Сейчас в теме +0.8 $m
(9) Если вы потом хотите использовать адрес временного хранилища, например в родительской форме, то его следует либо изначально сгенерировать и помещать в параметр открываемой формы, либо в открываемой форме хранить адрес, полученный методом ПоместитьВоВременноеХранилище, в реквизите формы и далее передавать, куда требуется.
11. Dermidont 11 31.05.24 14:06 Сейчас в теме
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот