Ошибка при выводе печатной формы

1. user1502659 19.02.24 10:33 Сейчас в теме
Здравствуйте, при выводе печатной формы на печать из двух разных документов было написано условие, в первом документе условие проходит и выполняется
Во втором документе при выводе формы жалуется на строчку в иначе:
Не удалось сформировать внешнюю печатную форму!
Преобразование значения к типу Булево не может быть выполнено

СуммаКПрописи = Сумма + ?(Шапка.СуммаВключаетНДС, 0, СуммаНДС);
	    //Вывести ИтогоНДС
		Если ПараметрыПечати.УчитыватьНДС = Истина Тогда
			СуммаКПрописи = Сумма + ?(Шапка.СуммаВключаетНДС, 0, СуммаНДС);
			Сообщить(СуммаКПрописи);
		Иначе
			Сообщить ("Произошло ИНАЧЕ");
			СуммаКПрописи = Сумма + ?(Шапка.СуммаВключаетНДС, 0, СуммаНДС); //ошибка во втором документе
			Сообщить(СуммаКПрописи);
		КонецЕсли;
Показать
По теме из базы знаний
Найденные решения
4. soft_wind 19.02.24 15:01 Сейчас в теме
так просто уберите эту проверку
        //Вывести ИтогоНДС
        Если ПараметрыПечати.УчитыватьНДС = Истина Тогда
            СуммаКПрописи = Сумма + ?(Шапка.СуммаВключаетНДС, 0, СуммаНДС);
            Сообщить(СуммаКПрописи);
        Иначе
            Сообщить ("Произошло ИНАЧЕ");
            //СуммаКПрописи = Сумма + ?(Шапка.СуммаВключаетНДС, 0, СуммаНДС); //ошибка во втором документе
            СуммаКПрописи = Сумма; //здесь же без учета НДС
            Сообщить(СуммаКПрописи);
        КонецЕсли;
Показать
Остальные ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. user1880116 19.02.24 13:51 Сейчас в теме
(1)
Произошло ИНАЧЕ
Ну, надо наверно, поставить точку останова, посмотреть на значение переменной, подумать, откуда оно такое берется и что-то сделать, не?

Хотя зачем это всё... куда проще написать на форум.
3. Sashares 35 19.02.24 14:19 Сейчас в теме
(2)
и что-то сделать, не?

не =)
4. soft_wind 19.02.24 15:01 Сейчас в теме
так просто уберите эту проверку
        //Вывести ИтогоНДС
        Если ПараметрыПечати.УчитыватьНДС = Истина Тогда
            СуммаКПрописи = Сумма + ?(Шапка.СуммаВключаетНДС, 0, СуммаНДС);
            Сообщить(СуммаКПрописи);
        Иначе
            Сообщить ("Произошло ИНАЧЕ");
            //СуммаКПрописи = Сумма + ?(Шапка.СуммаВключаетНДС, 0, СуммаНДС); //ошибка во втором документе
            СуммаКПрописи = Сумма; //здесь же без учета НДС
            Сообщить(СуммаКПрописи);
        КонецЕсли;
Показать
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот