Отчёт не выводит поля

1. talengek 17.09.23 16:46 Сейчас в теме
Добрый день!
Странная проблема нарисовалась с отчётом на СКД.
Объясняю: Есть типовой отчёт: "уатКарточкаРаботыТСрасширенный". на СКД. Работающий нормально.
Эзеру нужно было добавить новое поле. Добавил отчёт в расширение. Завёл новое СКД, методом копирования. Добавил нужное поле. Ничего сложного. Но какого было моё удивление когда я открыл отчёт.
Пропали абсолютно все поля. В пользовательских настройках во вкладе "Поля" все поля видны, на них стоял галки, запрос в СКД работает нормально, проверял консолью. Откатываю на типовую СКД, поля появляются.
Сохраняю мой изменённый отчет во внешний отчёт, запускаю - поля выводятся нормально! Как такое может быть?
Из интересного:
Добавляю детальные записи, поля выводятся, но не в таком виде, в котором нужно юзеру.
Кэш чистил.
Конфа Управление автотранспортом Проф, редакция 2.2 (2.2.18.1)
Какие предположения?
Первый скрин: Отчёт без полей;
Второй скрин: Этот же отчёт, но как внешний;
Третий скрин с полями;
Прикрепленные файлы:
По теме из базы знаний
Ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
3. пользователь 17.09.23 17:11
Сообщение было скрыто модератором.
...
4. talengek 17.09.23 17:12 Сейчас в теме
7. karamazoff 113 17.09.23 17:19 Сейчас в теме
Много не понятного, но можно пойти от простого - если отчет, как внешний, работает как надо, то чего бы его не подключить как внешний и сэкономить себе нервы?
11. talengek 17.09.23 17:29 Сейчас в теме
(7) Хороший ответ. Думал об этом, но всё же лучше сделать через расширение. На будущее облегчит жизнь.
12. karamazoff 113 17.09.23 17:55 Сейчас в теме
(11)Не факт, что лучше, в расширении нормально даже конструктор запросов не работает, пока туда не позаимствуешь все что он хочет, здесь явно где-то сидят сохраненные настройки юзера, если есть рвение и упорство, можно покопать, смотреть в сторону юзера, пробовать под другим, пробовать скопировать базу на другой ресурс. В любом случае - желаю удачи!
Sejix; talengek; +2 Ответить
16. talengek 18.09.23 05:11 Сейчас в теме
(12) Спасибо, буду копать дальше. Кстати, настройки юзера присутствовали, скинул на дефолтные, но к сожалению не работает(
14. пользователь 17.09.23 23:09
Сообщение было скрыто модератором.
...
2. пользователь 17.09.23 17:10
Сообщение было скрыто модератором.
...
5. talengek 17.09.23 17:12 Сейчас в теме
(2)С такими вопросами вам на ОтветыMail
6. пользователь 17.09.23 17:14
Сообщение было скрыто модератором.
...
8. talengek 17.09.23 17:21 Сейчас в теме
(6)Какие компасы, о чём ты?
Боже мой, думал тут таких нет...
9. пользователь 17.09.23 17:22
Сообщение было скрыто модератором.
...
10. talengek 17.09.23 17:27 Сейчас в теме
13. Dr.HiHi 2 17.09.23 19:17 Сейчас в теме
возможно где-то в модуле отчета или менеджера отчета идет изменение текста запроса скд
15. пользователь 17.09.23 23:30
Сообщение было скрыто модератором.
...
17. talengek 18.09.23 09:16 Сейчас в теме
ДОБАВИЛ ЭТОТ ОТЧЁТ КАК ВНЕШНИЙ, РЕШЕНИЕ НЕ НАЙДЕНО.
18. Sejix 18.09.23 10:12 Сейчас в теме
(17) Схема при открытии ошибок не показывает?
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот