Заполнение табличной части документа

1. user1986928 07.09.23 14:24 Сейчас в теме
Добрый день! Помогите, пожалуйста) Как можно реализовать (обычные формы)- при добавлении новой строки тех. операции "Наладка" в табличную часть документа , сумма должна заполниться автоматически - это должна быть сумма предыдущих строк, но только тех строк, где тех. операция "Слесарная".
Прикрепленные файлы:
По теме из базы знаний
Ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. user1619761 07.09.23 14:47 Сейчас в теме
Добрый день. Пример. Можете использовать ОбработкаВыбора.
Процедура ТехнологическаяОперацияОкончаниеВводаТекста(Элемент, Текст, Значение, СтандартнаяОбработка)
	Если Текст = "Наладка" Тогда
		КопияТаблицы = ВашаТабличнаяЧасть.Выгрузить(Новый Структура("Сумма", "Слесарная210(Упаковка)"));
		ИтогоСумма = КопияТаблицы.Итог("Сумма");
                ЭтаФорма.ТекущийЭлемент.ТекущиеДанные.Сумма = ИтогоСумма ;
	КонецЕсли;
КонецПроцедуры
3. user5300 1034 07.09.23 16:49 Сейчас в теме
Процедура ТаблицаТехОперацияПриИзменении()
	
	ТекущиеДанные = Элементы.ТаблицаТехОперация.ТекущиеДанные;
	Если ТекущиеДанные = Неопределено Тогда
		Возврат;
	КонецЕсли;
	
	Результат = ТаблицаТехОперацияПриИзмененииСервер(ТекущиеДанные.ТехнологическаяОперация);
	Если Результат = Неопределено Тогда
		возврат;
	КонецЕсли;
	
	ТекущиеДанные.Сумма = Результат;
		
КонецПроцедуры
	
&НаСервере	
Функция ТаблицаТехОперацияПриИзмененииСервер(ТехОперация)
	
	Если НЕ ТехОперация = Справочники.ТехнологическиеОперации.НайтиПоНаименованию("Накладка") Тогда
	    Возврат Неопределено;
	КонецЕсли;

	МассивСтрок = Объект.ТаблицаТехОперация.НайтиСтроки(Новый Структура("ТехнологическаяОперация",Справочники.ТехнологическиеОперации.НайтиПоНаименованию("Слесарная210"));
	НоваяТаблица = Объект.ТаблицаТехОперация.Выгрузить(МассивСтрок);
	
	Возврат НоваяТаблица.Итог("Сумма");
	
КонецФункции
Показать
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот