Переменная не определена? Подскажите,пожалуйста

1. Гость 26.05.23 12:00
Процедура ВычислитьСумму(СтрокаТаблицы)Экспорт
СтрокаТаблицы.Сумма=СтрокаТаблицы.Количество*СтрокаТаблицы.Цена;
КонецПроцедуры


&НаКлиенте
Процедура изделияКоличествоПриИзменении(Элемент)
// Вставить содержимое обработчика.
СтрокаТаблицы=Элементы.Изделия.ТекущиеДанные;
СобытияДокументов.ВычислитьСумму(СтрокаТаблицы);
КонецПроцедуры

Выдаёт ошибку
{Документ.ПриходнаяНакладная.Форма.ФормаДокумента.Форма(6,1)}: Переменная не определена (СобытияДокументов)
<<?>>СобытияДокументов.ВычислитьСумму(СтрокаТаблицы); (Проверка: Тонкий клиент)
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. user1826630 26.05.23 12:55 Сейчас в теме
Серверные модули с клиента не видны.
3. user-z99999 65 26.05.23 13:17 Сейчас в теме
&НаКлиенте
Процедура ВычислитьСумму(СтрокаТаблицы) 
СтрокаТаблицы.Сумма=СтрокаТаблицы.Количество*СтрокаТаблицы.Цена;
КонецПроцедуры


не хватает сверху директивы НаКлиенте
Внимание! Не забывайте отмечать решение на ваш вопрос, если оно найдено. Это повысит ваш рейтинг на форуме.
Оставьте свое сообщение
Вакансии
1С-Программист (интегратор Битрикс24)
Санкт-Петербург
зарплата от 150 000 руб. до 250 000 руб.
Полный день

Разработчик 1С
Москва
зарплата от 100 000 руб.
Временный (на проект)

Разработчик 1С
Москва
зарплата от 150 000 руб.
Полный день

Программист
Санкт-Петербург
зарплата от 180 000 руб. до 240 000 руб.
Полный день

Разработчик 1С
Москва
зарплата от 150 000 руб. до 250 000 руб.
Полный день