Пользовательские настройки в СКД обычные формы

1. user1608137 21.03.23 13:48 Сейчас в теме
Добрый день.

Конфигурация УПП 1.3.

Встал вопрос по управлению пользовательскими настройками для отчетов СКД на обычных формах.

Был выбран вариант решения переход на работу с регистром СохраненныеНастрйок (про это много статей есть на форуме).

Но остался не решенный вопрос, как перенести ранее сохраненные настройки ?

Хотелось бы выйти хотя бы на вариант, что "Пользователь в настройках нажимает 1 кнопку и все его сохраненные настройки копируются в регистр СохраненныеНастройки".

Кто-то решал похожую проблему ?

При попытки вернуть ХранилищеПользовательскихНастроекОтчетов - возвращает Неопределено.

ЗначениеНастройки = ХранилищеПользовательскихНастроекОтчетов.Загрузить(НазваниеОбъекта);
Где НазваниеОбъекта строка - "Отчет.НазваниеОтчета"
Прикрепленные файлы:
Найденные решения
6. user1608137 22.03.23 15:26 Сейчас в теме
(5) Я и планирую использовать механизм работы с Регистром Сохраненные настройки, и он полностью устраивает. Для обычных форм.

У меня только проблема - как извлечь ранее сохраненные настройки.

То что вы перечислили Хранилища дефолтные я их все проверял, как раз с отбором по пользователю. в первом моем посте указал ... там ничего нет к сожалению, хотя я на это очень рассчитывал. Других идей нет, где это искать.

Собственные Хранилища не установлены. Я проверял. Должны работать дефолтные. Но в в них данных нет.

Судя по всему это не выковыривается :(

"Будь проклят тот день когда я сел за баранку этого пылесоса!"
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
7. spacecraft 22.03.23 16:16 Сейчас в теме
(1) посмотрите код формы отчета. ПриОткрытии должен быть код по восстановлению настроек.
Нет УПП, но для УТ 10:
Процедура ПриОткрытии()
	
	УниверсальныйОтчет.мДействиеПолеВводаВидСравненияПриИзменении = Новый Действие("ПолеВводаВидСравненияПриИзменении");
	УниверсальныйОтчет.мДействиеПолеВводаЗначениеПриИзменении = Новый Действие("ПолеВводаЗначениеПриИзменении");
	УниверсальныйОтчет.мДействиеКоманднаяПанельФормыПечать = Новый Действие("КоманднаяПанельФормыПечать");
	
	УниверсальныйОтчет.ФормаПриОткрытии(УниверсальныйОтчет, ЭтотОбъект, ЭтаФорма);
	
КонецПроцедуры // ПриОткрытии()
Показать


Вот как раз смотрите: УниверсальныйОтчет.ФормаПриОткрытии(УниверсальныйОтчет, ЭтотОбъект, ЭтаФорма);
Там далее будет код по загрузке настроек.
2. user1608137 21.03.23 15:50 Сейчас в теме
Есть стандартные хранилища настроек:

Например ХранилищеСистемныхНастроек возвращает какие-то настройки.

Выборка = ХранилищеСистемныхНастроек.Выбрать(МойПользователь);
Выборка.Следующий();



А вот ХранилищеПользовательскихНастроекОтчетов не возвращает ничего

Выборка = ХранилищеПользовательскихНастроекОтчетов.Выбрать(Отбор);
Выборка.Следующий();


Где хранятся пользовательские настройки отчета СКД (на обычных формах) ?
3. Dr.HiHi 3 21.03.23 16:29 Сейчас в теме
(1) посмотрите отчет типа анализа мпз ;)) скопируйте его и засуньте туда свой скд ;))
4. user1608137 21.03.23 16:50 Сейчас в теме
(3) не понимаю как это решит мой вопрос вытаскивание ранее сохраненных пользовательских настроек
5. Dr.HiHi 3 22.03.23 09:13 Сейчас в теме
(4) никак, но, как по мне, в нем более приятный интерфейс чем тот, что у Вас на скрине + реализованы механизмы сохранения настроек

по сабжу
никак не можно достать настройки программным путем(( как-то 1с не особо над этим подумала
проверьте у себя... возможно где-то и есть настройки, но сомневаюсь
	Выборка = ХранилищеСистемныхНастроек.Выбрать();
	Пока Выборка.Следующий() Цикл
	КонецЦикла;

	Выборка = ХранилищеВариантовОтчетов.Выбрать();
	Пока Выборка.Следующий() Цикл
	КонецЦикла;

	Выборка = ХранилищеНастроекДанныхФорм.Выбрать();
	Пока Выборка.Следующий() Цикл
	КонецЦикла;

	Выборка = ХранилищеОбщихНастроек.Выбрать();
	Пока Выборка.Следующий() Цикл
	КонецЦикла;

	Выборка = ХранилищеПользовательскихНастроекОтчетов.Выбрать();
	Пока Выборка.Следующий() Цикл
	КонецЦикла;
Показать

возможно у Вас в конфигураторе есть хранилище настроек и там что-то есть и его тоже пройдитесь и посмотрите ;))
p.s. добавьте какой-то отбор по пользователю, чтобы не пересматривать всех пользователей
6. user1608137 22.03.23 15:26 Сейчас в теме
(5) Я и планирую использовать механизм работы с Регистром Сохраненные настройки, и он полностью устраивает. Для обычных форм.

У меня только проблема - как извлечь ранее сохраненные настройки.

То что вы перечислили Хранилища дефолтные я их все проверял, как раз с отбором по пользователю. в первом моем посте указал ... там ничего нет к сожалению, хотя я на это очень рассчитывал. Других идей нет, где это искать.

Собственные Хранилища не установлены. Я проверял. Должны работать дефолтные. Но в в них данных нет.

Судя по всему это не выковыривается :(

"Будь проклят тот день когда я сел за баранку этого пылесоса!"
Оставьте свое сообщение
Вакансии
Консультант-программист по информационным системам 1С
Москва
зарплата от 150 000 руб. до 200 000 руб.
Полный день

Системный архитектор 1С
Москва
зарплата от 250 000 руб.
Полный день

Руководитель группы 1С
Екатеринбург
зарплата от 200 000 руб.
Полный день

Программист 1С
Уфа
зарплата от 110 000 руб.
Полный день

Функциональный архитектор
Москва
зарплата от 200 000 руб. до 300 000 руб.
Полный день