Отображение всех движений связанных документов в РеализацияТоваровУслуг БП 3.0

1. Trambon 11.10.22 16:57 Сейчас в теме
Добрый день!

Я новичок в 1с и хотел бы попросить помощи в реализации задачи(Если можно с объяснением).
Нужно вывести все движения связанных документов с документом реализации, в документе реализации по кнопке дт/кт. Так же движения счетов фактур.
Функция ОбъектыПоКритериюОтбора(ЗначениеКритерияОтбора)
        
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
    |    СвязанныеДокументы.Ссылка
    |ИЗ
    |    КритерийОтбора.СвязанныеДокументы(&ЗначениеКритерияОтбора) КАК СвязанныеДокументы";
    
    Запрос.УстановитьПараметр("ЗначениеКритерияОтбора", ЗначениеКритерияОтбора);
    Возврат Запрос.Выполнить().Выгрузить();
    
КонецФункции 
Показать


Это у меня функция по поиску свячзанных документов,а вот что я пишу в обработке проведения документа РеализацияТоваровУслуг.

 ДокументОбъект = Ссылка.ПолучитьОбъект(); 
    СвязанныеДокументы = ОбъектыПоКритериюОтбора(Ссылка);
    Для каждого докСсылка Из СвязанныеДокументы Цикл
        ДокОбъект = ДокСсылка.Ссылка.ПолучитьОбъект();
        НаборДвиженияДокумента = ДокОбъект.Движения;
        Для каждого СтрНабор ИЗ НаборДвиженияДокумента Цикл  
            Если СтрНабор = НаборДвиженияДокумента.Хозрасчетный Тогда 
            Движение = Движения.Хозрасчетный.Добавить();
            Движение.Период = Дата;                        
              КонецЕсли; 
        КонецЦикла;    
    КонецЦикла;     
Показать

Прошу помочь,не понимаю как действовать дальше
Ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. Prikum 3 11.10.22 17:01 Сейчас в теме
(1)
Нужно вывести все движения связанных документов с документом реализации
Так нужно вывести все движения или создать движения?
(1)
Движение = Движения.Хозрасчетный.Добавить();
3. Trambon 11.10.22 17:04 Сейчас в теме
(2)Нужно перехватить движения связанных документов и записать всю информацию о движениях в документ реализации, а я видимо создаю движение.А как его перехватить?
4. Prikum 3 11.10.22 17:06 Сейчас в теме
(3)если честно ничего непонятно, но очень интересно! Нужно чтобы движения связанных документов были в движениях документа реализации? Или нужен отчет, который покажет движения всех связанных документов?
5. Trambon 11.10.22 17:13 Сейчас в теме
(4)Все правильно, нужно чтобы движения связанных документов были в движениях документа реализации. То есть они бы отображались по нажатию дт/кт
6. Prikum 3 11.10.22 17:18 Сейчас в теме
(5)
То есть они бы отображались по нажатию дт/кт
Лучше написать свой отчет.
7. Trambon 11.10.22 17:20 Сейчас в теме
(6)Можно тогда объяснить как сделать свой отчет?)
8. Prikum 3 11.10.22 17:25 Сейчас в теме
(7)К сожалению у меня не столько много свободного времени, чтобы описать все те действия по созданию внешнего отчета. Сама мысль правильная, но вместо добавить нужно просто вывести движение. Это кстати имеет практическую пользу или это тестовое задание?
9. Trambon 11.10.22 17:33 Сейчас в теме
(8)Спасибо вам тогда за ориентир! Это тестовое задание.
10. Asya.Ozerova 41 11.10.22 17:57 Сейчас в теме
(5)
по нажатию дт/кт

Тут особо ни чего мудрить не надо, по нажатию открывается ФормаСписка Регистра бухгалтерии с Отбором по Регистратору = "Текущий объект", Вам просто надо поменять Отбор, т.е. добавить Регистратор.ДокументОснование;
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот