Авторизация на сайте 1с через https програмно

1. gddonline 04.08.22 13:26 Сейчас в теме
Добрый день, подскажите может кто сталкивался, пытаюсь скачать обновления с сайта https://releases.1c.ru/ через https соедениение, не получается получить файл обновления с промежуточного сайта dl04.1c.ru.

СерверАвторизации = "login.1c.ru";
				
				Соединение = Новый HTTPСоединение(СерверАвторизации, , , , эсЗагрузкаИнформацииИзИнтернетаСервер.ПолучитьПараметрыПрокси(), 25, SSL);
				
				Запрос = Новый HTTPЗапрос("login?service=https://" + ИмяСервера + Суффикс);
				
				Ответ = Соединение.Получить(Запрос);
				
				ТелоКакСтрока = Ответ.ПолучитьТелоКакСтроку();
				
				Значение_lt        = эсРаботаСоСтрокамиКлиентСервер.ПолучитьСтрокуМеждуПодстроками(ТелоКакСтрока, "name=""lt"" value="""       , """/>", Ложь, Ложь, Ложь, Ложь);
				Значение_execution = эсРаботаСоСтрокамиКлиентСервер.ПолучитьСтрокуМеждуПодстроками(ТелоКакСтрока, "name=""execution"" value=""", """/>", Ложь, Ложь, Ложь, Ложь);
				
				ЗаголовкиСервера = Новый Соответствие;
				
				ЗаголовкиСервера.Вставить("Cookie"      , Ответ.Заголовки.Получить("set-cookie"));
				ЗаголовкиСервера.Вставить("Content-Type", "application/x-www-form-urlencoded");
				
				Заголовки.Вставить(ИмяСервера, ЗаголовкиСервера);
				
				ТелоКакСтрока = "inviteCode=<=" + Значение_lt + "&execution=" + Значение_execution + "&_eventId=submit&username=" + ИмяПользователя + "&password=" + Пароль;
				
				Соединение = Новый HTTPСоединение(СерверАвторизации, , , , эсЗагрузкаИнформацииИзИнтернетаСервер.ПолучитьПараметрыПрокси(), 25, SSL);
				
				Запрос = Новый HTTPЗапрос("/user/serviceInfo?serviceNick=Сервис+" + ИмяСервера);
				
				Ответ = Соединение.Получить(Запрос);
				
				Запрос = Новый HTTPЗапрос("login?service=https://" + ИмяСервера + Суффикс, Заголовки.Получить(ИмяСервера));
				
				Запрос.УстановитьТелоИзСтроки(ТелоКакСтрока, КодировкаТекста.ANSI);
				
				Ответ = Соединение.ОтправитьДляОбработки(Запрос);
					
				Значение_Location = Ответ.Заголовки.Получить("location");
				
				Если эсРаботаСоСтрокамиКлиентСервер.НайтиПодстрокуВСтрокеБезУчетаРегистра(Значение_Location, "https://" + ИмяСервера + Суффикс + "?ticket=") <> 0 Тогда
					
					SSL = Новый ЗащищенноеСоединениеOpenSSL();
					
					Соединение = Новый HTTPСоединение(ИмяСервера, , , , эсЗагрузкаИнформацииИзИнтернетаСервер.ПолучитьПараметрыПрокси(), 25, SSL);
					
					Поз = эсРаботаСоСтрокамиКлиентСервер.НайтиПодстрокуВСтрокеБезУчетаРегистра(Значение_Location, "ticket");
					
					ТелоКакСтрока = Сред(Значение_Location, Поз);
					Если ИмяСервера = "dl03.1c.ru" Или ИмяСервера = "dl04.1c.ru" Тогда 
						Запрос = Новый HTTPЗапрос("/public/security_check" +Сред(Значение_Location, Поз - 1));
					Иначе
						Запрос = Новый HTTPЗапрос(Сред(Значение_Location, Поз - 1));
					КонецЕсли;
					Запрос.УстановитьТелоИзСтроки(ТелоКакСтрока, КодировкаТекста.ANSI);
					
					Ответ = Соединение.Получить(Запрос);
					
					Заголовки.Получить(ИмяСервера).Вставить("Cookie", Ответ.Заголовки.Получить("Set-Cookie"));
					//Заголовки.Получить(ИмяСервера).Вставить("Cookie", ЗаголовкиСервера.Получить("Cookie"));	
					
					Возврат Истина;
					
				КонецЕсли;
				
			КонецЕсли;
Показать



но почему то не могу получить Куки, к сайта релизов этот код нормально собирает куки, а с промежуточного не получается.
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
4. makfromkz 31 05.08.22 10:59 Сейчас в теме
(1)
не могу получить Куки


Можно ламерский вопрос, а зачем нужны куки?
5. gddonline 05.08.22 11:10 Сейчас в теме
(4) что бы сохранить авторизацию на сайте, когда буду кидать запрос на скачку файла
2. gddonline 05.08.22 08:43 Сейчас в теме
Не уж то никто не сталкивался?
3. papami 53 05.08.22 10:05 Сейчас в теме
6. gddonline 05.08.22 14:55 Сейчас в теме
(3) Погуглил, не нашел ничего что подходило бы под 1с, что это?
7. papami 53 05.08.22 16:14 Сейчас в теме
Ну селениум гуглится хорошо. Ищите как код C# на 1с выполнить. Тут на инфостарте много примеров
Оставьте свое сообщение
Вакансии
Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству

Архитектор 1С
Москва
зарплата от 260 000 руб.
Полный день

Начальник отдела архитектуры
Москва
зарплата от 300 000 руб.
Полный день

Эксперт по технологическим вопросам
Москва
зарплата от 250 000 руб.
Полный день

Ведущий разработчик 1С
Ростов-на-Дону
зарплата от 200 000 руб.
Полный день