событие активации строки в списке значений на форме 1с7

1. 04.08.22 11:39 Сейчас в теме
Добрый день. подскажите. можно ли как-то отследить событи активации строки в списке занчений?
Найденные решения
4. BarsukM 04.08.22 12:43 Сейчас в теме
Вставить на форму пустое текстовое поле. В формулу забить типа "ПриОбновленииФормы()". Будет срабатывать при каждом перемещении фокуса на форме.

В функции проверять активный элемент
Функция ПриОбновленииФормы()
	Если Форма.АктивныйЭлемент()="СписокСЗ" Тогда

	КонецЕсли;
КонецФункции //ПриОбновленииФормы()
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. ivan65 04.08.22 12:01 Сейчас в теме
насколько я понимаю списокзначений.ТекущаяСтрока(), наверное еще можно списокзначений.пометка()
3. kostya_77 04.08.22 12:33 Сейчас в теме
(2) Это при клике мышой, а при перемещении как?
6. VictorRGB2 13 04.08.22 12:49 Сейчас в теме
(3) самое простое, сделать список выпадающим, т.е. заменить список на поле со списком
тогда любое изменение текущей строки будет отслеживаться легко и просто
7. kostya_77 04.08.22 13:06 Сейчас в теме
4. BarsukM 04.08.22 12:43 Сейчас в теме
Вставить на форму пустое текстовое поле. В формулу забить типа "ПриОбновленииФормы()". Будет срабатывать при каждом перемещении фокуса на форме.

В функции проверять активный элемент
Функция ПриОбновленииФормы()
	Если Форма.АктивныйЭлемент()="СписокСЗ" Тогда

	КонецЕсли;
КонецФункции //ПриОбновленииФормы()
5. kostya_77 04.08.22 12:44 Сейчас в теме
8. CheBurator 3073 05.08.22 20:29 Сейчас в теме
Можно даже отловить не только активацию строки, но и активацию ячейки в строке...
9. Иваныч 23 09.08.22 13:09 Сейчас в теме
Добрый день! хотел поинтересоваться, как это вообще выглядит и для чего. Может пригодится
10. CheBurator 3073 09.08.22 18:15 Сейчас в теме
(9) например чтобы во второй тЗ отобразить список, соответствующий текущей строке в первой ТЗ
Оставьте свое сообщение
Вакансии
Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству

Архитектор 1С
Москва
зарплата от 260 000 руб.
Полный день

Начальник отдела архитектуры
Москва
зарплата от 300 000 руб.
Полный день

Эксперт по технологическим вопросам
Москва
зарплата от 250 000 руб.
Полный день

Ведущий разработчик 1С
Ростов-на-Дону
зарплата от 200 000 руб.
Полный день