не работает вывод даты на ПФ

1. Palm 02.08.22 16:42 Сейчас в теме
как вывести в печатную форму этот параметр ?


   ОбластьМакета = Макет.ПолучитьОбласть("СрокДействия");    
   
    Если ТипЗнч(СсылкаНаОбъект) = Тип("ДокументСсылка.ЗаказКлиента") Тогда
		ДанныеДокумента = Новый Структура("");
		ДанныеДокумента.Вставить("", СсылкаНаОбъект.Дата);			
	КонецЕсли;  
   ТабДок.Вывести(ОбластьМакета);
Показать
Прикрепленные файлы:
По теме из базы знаний
Найденные решения
4. winapi 60 02.08.22 16:48 Сейчас в теме
(3) выше указал же. Нужно заполнить параметры области макета, естественно у вас в макете должен быть этот параметр, как-то так:

ОбластьМакета = Макет.ПолучитьОбласть("СрокДействия");

Если ТипЗнч(СсылкаНаОбъект) = Тип("ДокументСсылка.ЗаказКлиента") Тогда
ДанныеДокумента = Новый Структура("");
ДанныеДокумента.Вставить("", СсылкаНаОбъект.Дата);
ОбластьМакета.Параметры.Дата = ДанныеДокумента.Дата;
КонецЕсли;
ТабДок.Вывести(ОбластьМакета);
Остальные ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. winapi 60 02.08.22 16:43 Сейчас в теме
ОбластьМакета.Параметры.Дата = ДанныеДокумента.Дата; у вас нет заполнения области в макете
3. Palm 02.08.22 16:45 Сейчас в теме
4. winapi 60 02.08.22 16:48 Сейчас в теме
(3) выше указал же. Нужно заполнить параметры области макета, естественно у вас в макете должен быть этот параметр, как-то так:

ОбластьМакета = Макет.ПолучитьОбласть("СрокДействия");

Если ТипЗнч(СсылкаНаОбъект) = Тип("ДокументСсылка.ЗаказКлиента") Тогда
ДанныеДокумента = Новый Структура("");
ДанныеДокумента.Вставить("", СсылкаНаОбъект.Дата);
ОбластьМакета.Параметры.Дата = ДанныеДокумента.Дата;
КонецЕсли;
ТабДок.Вывести(ОбластьМакета);
5. Palm 02.08.22 16:52 Сейчас в теме
(4)ага теперь работает спасибо
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот