комплект документов с настройкой

1. 23.06.22 15:16 Сейчас в теме
Комплект документов с настройкой. Как туда добавить форму. Добавил в обычный список печати кодом с 1 скрина, но в комплекте она не появилась. Подозреваю что её ещё нужно и туда добавить, но не понял как. Если есть пример кода, поделитесь. Я так понимаю тут из бсп что-то заюзать надо. УТ 11.5, док реализации. Все делается в расширении.
Прикрепленные файлы:
Найденные решения
7. FatPanzer 16 23.06.22 17:11 Сейчас в теме
(4) Зачем полностью менять, если можно если можно сделать аналог &После ???

&Вместо("КомплектПечатныхФорм")
Функция МойКомплектПечатныхФорм() Экспорт
    
    // Получаем типовой комплект (и пусть там в типовой меняют что хотят)
    МойКомплект = КомплектПечатныхФорм();

    // Дополняем своими формами
    // РегистрыСведений... Вот это вот все, как на скриншоте, только со своими именами форм

   Возврат МойКомплект;

КонецФункции
Показать


Ну или просто внешку, тогда и расширение не нужно.
unknown181538; +1 Ответить
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. Lemmonbri 23.06.22 15:37 Сейчас в теме
Нашел, что заполнение комплекта идет в функции в модуле менеджера документа. Однако я же не могу дописать её, добавив нужную мне строку. Есть идеи?
Прикрепленные файлы:
3. unknown181538 70 23.06.22 15:39 Сейчас в теме
(2) А почему не можете? Можно в расширении заменить эту процедуру на расширенную.
4. Lemmonbri 23.06.22 15:43 Сейчас в теме
(3) Заменить то конечно хорошо, но при обновлении если 1сные прогеры её поменяют, то изменения не отобразятся.
7. FatPanzer 16 23.06.22 17:11 Сейчас в теме
(4) Зачем полностью менять, если можно если можно сделать аналог &После ???

&Вместо("КомплектПечатныхФорм")
Функция МойКомплектПечатныхФорм() Экспорт
    
    // Получаем типовой комплект (и пусть там в типовой меняют что хотят)
    МойКомплект = КомплектПечатныхФорм();

    // Дополняем своими формами
    // РегистрыСведений... Вот это вот все, как на скриншоте, только со своими именами форм

   Возврат МойКомплект;

КонецФункции
Показать


Ну или просто внешку, тогда и расширение не нужно.
unknown181538; +1 Ответить
9. Nigmatul 24.06.22 11:05 Сейчас в теме
(7)
&Вместо("КомплектПечатныхФорм")
Функция МойКомплектПечатныхФорм() Экспорт

// Получаем типовой комплект (и пусть там в типовой меняют что хотят)
МойКомплект = КомплектПечатныхФорм();

// Дополняем своими формами
// РегистрыСведений... Вот это вот все, как на скриншоте, только со своими именами форм

Возврат МойКомплект;

КонецФункции


У меня падает с ошибкой 1С, зацикливается &Вместо ("КомплектПечатныхФорм") МойКомплект = КомплектПечатныхФорм();
10. FatPanzer 16 24.06.22 11:17 Сейчас в теме
(7) Накосячил. Конечно же надо
МойКомплект = ПродолжитьВызов();
Nigmatul; +1 Ответить
5. EVKash 13 23.06.22 16:41 Сейчас в теме
(1) а почему не хотите сделать внешнюю печатную форму? Они в комплект попадают.
6. Lemmonbri 23.06.22 16:56 Сейчас в теме
(5) Потому что придется тянуть заполнение печатной формы данными, а тут все само, хотя я уже подумываю что нужно заморочиться и создать внешнюю. Думал, может другой способ есть.
8. Lemmonbri 23.06.22 18:04 Сейчас в теме
(7) А слона то я и не приметил...
Оставьте свое сообщение
Вакансии
Консультант-аналитик 1С
Москва
зарплата от 120 000 руб. до 190 000 руб.
Полный день

Ведущий аналитик-разработчик 1С
Москва
зарплата от 230 000 руб. до 270 000 руб.
Полный день

1С:Эксперт по производительности
Москва
зарплата от 400 000 руб. до 950 000 руб.
Полный день

Ведущий аналитик 1С (ERP, ЗУП)
Краснодар
зарплата от 150 000 руб.
Полный день

Разработчик 1С
Тверь
зарплата от 150 000 руб. до 250 000 руб.
Полный день