Появляются новые строки, помогите, пожалуйста

1. aalu14 22.06.22 13:31 Сейчас в теме
Добрый день! Столкнулся с проблемой: появляются пустые строки при сортировке поля табличной части документа.

Как сортирую: выгружаю из табличной части значения, сортирую, загружаю обратно.
Каждый раз добавляется новая пустая строка.

&НаСервере
Процедура УпорядочитьСтатусыУбываниеНаСервере()
	ТЗ = Новый ТаблицаЗначений;	
	ТЗ = Объект.Договоры.Выгрузить();
	ТЗ.Колонки.Добавить("Статусы");
	Стр = ТЗ.Добавить();
	
	Для каждого Стр Из ТЗ Цикл
		Стр.Статусы  = Стр.ЗаявлениеОВынесенииСудебногоПриказа.Статус;
	КонецЦикла;   
	
	ТЗ.Сортировать("Статусы Убыв");
	Объект.Договоры.Загрузить(ТЗ);
КонецПроцедуры

&НаКлиенте
Процедура УпорядочитьСтатусыУбывание(Команда)
	УпорядочитьСтатусыУбываниеНаСервере();
КонецПроцедуры
Показать


Подскажите, в чем может быть проблема?
Найденные решения
2. djsns 22.06.22 13:45 Сейчас в теме
3. Kongo2019 22.06.22 14:12 Сейчас в теме
(1)
Стр = ТЗ.Добавить();


Тут добавляешь пустую строку.

Стр.Статусы = Стр.ЗаявлениеОВынесенииСудебногоПриказа.Статус;


Тут тоже не сильно красиво. Стр с обоих сторон.
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
3. Kongo2019 22.06.22 14:12 Сейчас в теме
(1)
Стр = ТЗ.Добавить();


Тут добавляешь пустую строку.

Стр.Статусы = Стр.ЗаявлениеОВынесенииСудебногоПриказа.Статус;


Тут тоже не сильно красиво. Стр с обоих сторон.
2. djsns 22.06.22 13:45 Сейчас в теме
4. aalu14 22.06.22 14:48 Сейчас в теме
Оставьте свое сообщение
Вакансии
Консультант-аналитик 1С
Москва
зарплата от 120 000 руб. до 190 000 руб.
Полный день

Ведущий аналитик-разработчик 1С
Москва
зарплата от 230 000 руб. до 270 000 руб.
Полный день

1С:Эксперт по производительности
Москва
зарплата от 400 000 руб. до 950 000 руб.
Полный день

Ведущий аналитик 1С (ERP, ЗУП)
Краснодар
зарплата от 150 000 руб.
Полный день

Разработчик 1С
Тверь
зарплата от 150 000 руб. до 250 000 руб.
Полный день