Обфусцировщик

0. 562 15.06.22 18:38 Сейчас в теме
Обработка, позволяющая защитить модули, закрытые паролем. Протестировано на платформе 8.3.20.1710.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. SerVer1C 493 16.06.22 10:23 Сейчас в теме
Чем эта обработка отличается от антидекомпилятора?
3. ZhokhovM 562 16.06.22 11:27 Сейчас в теме
(1)отличие:
собирает файлы обратно из файлов epf и erf
выбирает любой файл bin, epf, erf и т. д.
добавляет опкоды "unknown"
изменяет константы, метки и т.д.
изменяет тексты запароленных модулей
авторство мое
2. sewell 16.06.22 11:26 Сейчас в теме
И все тестируют только на декомпиляторе AWA. Хотя декомпилировать файл уже сможет каждый второй и без его обработки.
Более менее неплохая от WiseAdvise, но и она не является непреодолимым препятствием.
Да и AWA очень неплохо свой декомпилятор обфусцировал.
Остальное, что я встречал - детский сад.
SerVer1C; +1 Ответить
4. capitan 2217 16.06.22 13:21 Сейчас в теме
(2)В подобного рода обработках не нужна 100% защита
Нужно чтобы затраты на декомпиляцию превышали желание на декомпиляцию
По большому счету обфускация текстов это уже действенная защита от копирования
WiseAdvise
не видел их обработки
В принципе я и декомпиляторов особо не видел в паблике каждых вторых, но особо и не искал
5. sewell 16.06.22 14:14 Сейчас в теме
(4). Значит вы просто не в теме.
В паблике я уже давно видел проект от Elisy, он сделан на C#.
Для себя я сделал на Python.
Сюда никакие обработки выкладывать не будут. Да и обработку писать неудобно для таких вещей.
6. ZhokhovM 562 17.06.22 11:51 Сейчас в теме
Пример защищенного модуля обработки.
Прикрепленные файлы:
Test.epf
7. SerVer1C 493 20.06.22 15:31 Сейчас в теме
(6)
Перем Рем;

Процедура Сообщыть(пер0 = " ", пер1 = "г", пер2 = "д", пер3 = "е", пер4 = "
	|") Экспорт
    Рем = Рем + ((((((("в" + "о") + "т") + пер0) + пер1) + пер2) + пер3) + пер4);
	прем = (((((("з" + "а") + "р") + "ы") + "т") + "а") + "!");
    Сообщить(((((Рем + Proc_9112080484()) + "к") + "а") + "
	|") + прем);
КонецПроцедуры

Функция Proc_9112080484()
	Если Истина Тогда
		Возврат ((((("с" + "о") + "б") + "а") + "-") + символы.ПС);
    КонецЕсли;
КонецФункции

Рем = "Т";
Рем = (Рем + "а") + "к";
Рем = Рем + " ";
Показать
8. ZhokhovM 562 20.06.22 17:34 Сейчас в теме
(7)ну пример был небольшой, а обфускация кода только начало. По мере обновления будет дополнительно обфусцироваться и улучшаться.
9. tofree 15 20.06.22 17:56 Сейчас в теме
Общие модули Расширения конфигурации может обрабатывать? или не планируете делать?
10. ZhokhovM 562 20.06.22 18:04 Сейчас в теме
(9)не проверял. файл cfe еще не делал.
11. ZhokhovM 562 21.06.22 00:58 Сейчас в теме
(9)сделал. пока только файлы image и bin для расширения конфигурации.
14. ZhokhovM 562 25.06.22 22:08 Сейчас в теме
(9)файл cfe сделал в версии 1.0.3.3.
12. maksa2005 363 24.06.22 15:38 Сейчас в теме
Обработка файла C:\игого.cf
Обработка файла C:\Users\litvinov\Desktop\игого.cf
Версия контейнера 1С: 216.0
Не удалось определить тип значения
h55/Mge2fMFztQsFisVlH3XXYBo/afhvXqqsee54Ki3K7GqjefSutU5iFD5G­FXc2
ANz7GLei9du1H2euYINWQg==
Неизвестный вид метаданных "9cd510cd-abfc-11d4-9434-004095e12fc7"
Неизвестный вид метаданных "9cd510cd-abfc-11d4-9434-004095e12fc7"
Неизвестный вид метаданных "9cd510cd-abfc-11d4-9434-004095e12fc7"
Неизвестный вид группы метаданных "e68182ea-4237-4383-967f-90c1e3370bc7"
Создан файл с открытыми модулями "C:\Users\litvinov\Desktop\игого_U.cf"
Обработка завершена!
Показать


Спасибо. закрыта))
ZhokhovM; +1 Ответить
13. ZhokhovM 562 24.06.22 16:19 Сейчас в теме
(12)пожалуйста. а cf корректно работает?
17. maksa2005 363 28.06.22 08:55 Сейчас в теме
18. maksa2005 363 28.06.22 09:04 Сейчас в теме
(13) при обновлении конфигурацию на конфигурацию с обновлением где закрыт модуль вашей обработкой выходит такая ошибка:
1С:Предприятие 8.3 (8.3.17.1549)
Прикрепленные файлы:
19. ZhokhovM 562 28.06.22 09:52 Сейчас в теме
(18)
при обновлении конфигурацию на конфигурацию с обновлением где закрыт модуль вашей обработкой

скачайте последнюю версию файла обработки и проверьте еще раз.
20. maksa2005 363 28.06.22 09:52 Сейчас в теме
15. tofree 15 27.06.22 10:29 Сейчас в теме
Скачалась не последняя версия файла обработки, без поддержки расширений. В публикации доступна по факту не последняя версия. Выложите новый файл. Автор пришлете ссылку в личку на новую версию?
Прикрепленные файлы:
16. ZhokhovM 562 27.06.22 12:57 Сейчас в теме
21. tofree 15 28.06.22 15:40 Сейчас в теме
Удалять тексты запароленных модулей (оставить окно ввода пароля) - данный переключатель делает поставку без исходных текстов с возможностью ввода пароля. При вводе корректного пароля не приведет к расшифровке исходных текстов.

в данном случае не работает
при вводе корректного пароля - пароль не принимается
Прикрепленные файлы:
22. ZhokhovM 562 28.06.22 16:50 Сейчас в теме
(21) данный переключатель удаляет исходный текст модуля, но при этом остается информация о том, что пароль установлен, но какой бы пароль не вводился он никогда не приведет к корректному расшифровыванию "того чего нет".
23. sytkosa 119 06.07.22 15:47 Сейчас в теме
(0) а как поправить ошибку в cfe при загрузке cfe в базу ругается ка хэш сумму ?
24. ZhokhovM 562 06.07.22 16:05 Сейчас в теме
(23) с ошибкой не сталкивался.
25. SerVer1C 493 28.07.22 17:40 Сейчас в теме
(23) Перепакуйте расширение с помощью утилиты onepack
Оставьте свое сообщение
Вакансии
Разработчик 1С
Москва
зарплата от 180 000 руб. до 200 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству

Архитектор 1С
Москва
зарплата от 260 000 руб.
Полный день

Начальник отдела архитектуры
Москва
зарплата от 300 000 руб.
Полный день

Эксперт по технологическим вопросам
Москва
зарплата от 250 000 руб.
Полный день