Невидимость помеченной на удаление номенклатуры и характеристики номенклатуры (ERP 2.5, УТ 11.5, КА 2.5, Розница 2.3)

0. 648 25.04.22 16:30 Сейчас в теме
Расширение для типовых конфигураций. Позволяет сделать невидимым помеченные на удаление номенклатуру и характеристику номенклатуры при выборе и подборе во всех документах, где нужно выбирать или подбирать Номенклатуру и Характеристику номенклатуры, например в документах: Заказ клиента, Заказ поставщику, Реализация товаров и услуг, Приобретение товаров и услуг и т.д.

Перейти к публикации

user595534_petrov; +1 Ответить
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. user595534_petrov 26.04.22 08:34 Сейчас в теме
Расширение супер, спасибо!
Это то, что было крайне необходимо!
aibasoft; skmMining; user1778480; SergAl; +4 Ответить
2. Dem0 11 26.04.22 09:42 Сейчас в теме
Задача нужная, несколько раз приходилось делать, под разные конфигурации.
Автор, напиши, как реализовано, рлс, условное оформление или еще как-то?
3. Vladimir_D 109 26.04.22 10:55 Сейчас в теме
(2)Раз в описании написано, что в подборе или выборе, то значит поправил текст запроса для подбора. А в выборе еще проще - в настройках поля настроить отбор, но тут уже тоже лучше добавить в запрос динамического списка дополнительное условие на пометку удаления. В целом, ничего сложного.
4. may1c 2 26.04.22 14:02 Сейчас в теме
Подскажите, а при вводе в в строке документа номенклатура и характеристика тоже не будет подбираться?
Student1C; +1 Ответить
5. SergAl 648 26.04.22 14:32 Сейчас в теме
(4) Добрый день! Вы имеете ввиду, что если знать наименование помеченной на удаление номенклатуры или характеристики и вводить в строке это наименование с клавиатуры, то возможно ли его выбрать?
10. may1c 2 28.04.22 08:46 Сейчас в теме
11. SergAl 648 28.04.22 08:56 Сейчас в теме
(10) если вводить с клавиатуры, зная при этом наименование, то расширение позволит это сделать.
18. PrinzOfMunchen 83 06.06.22 07:08 Сейчас в теме
(11) Впишитесь в обработку получения данных выбора
6. user595534_petrov 26.04.22 16:08 Сейчас в теме
Возникла ошибка у бухгалтерии при создании документа "Списание на расходы", просьба посмотреть.
Прикрепленные файлы:
7. SergAl 648 26.04.22 16:53 Сейчас в теме
13. user595534_petrov 28.04.22 12:27 Сейчас в теме
(7) Да, сейчас все работает, спасибо!
8. Sanario 22 28.04.22 03:18 Сейчас в теме
А как ведет себя расширение, если подбор не визуальный, а например через ввод по строке?
9. SergAl 648 28.04.22 08:08 Сейчас в теме
(8) Вы имеете ввиду, что если знать наименование помеченной на удаление номенклатуры или характеристики и вводить в строке это наименование с клавиатуры?
14. Student1C 43 02.05.22 19:57 Сейчас в теме
(8) Чуть выше уже ответили, что даст выбрать )
17. oldcopy 142 30.05.22 12:35 Сейчас в теме
(14) Для таких целей мы при установке пометки удаления сразу добавляем к наименованию префикс, которого точно нет и быть не может у нормальной позиции справочника, скажем, 000.

Получается вместо условных Хлеб Белый - 000Хлеб Белый. Подбором выбрать такое трудно и сразу визуально видно, что что-то пошло не так. Хотя народ у нас талантливый, их такие мелочи не смущают.
19. PrinzOfMunchen 83 06.06.22 07:15 Сейчас в теме
(17) Если формы управляемые, то всё намного проще.
Процедура ОбработкаПолученияДанныхВыбора(ДанныеВыбора, Параметры, СтандартнаяОбработка) Экспорт

	Если Не КонтролироватьВыборЭлементов() Тогда
		Возврат;
	КонецЕсли; 	
	
	Отбор = Новый Структура;
	Если НЕ Параметры.Свойство("Отбор") Тогда
		Параметры.Вставить("Отбор", Отбор);
	КонецЕсли; 
	
	Параметры.Отбор.Вставить("ПометкаУдаления", Ложь);
	
КонецПроцедуры

Процедура ОбработкаПолученияФормы(ВидФормы, Параметры, ВыбраннаяФорма, ДополнительнаяИнформация, СтандартнаяОбработка) Экспорт
	
	Если Не КонтролироватьВыборЭлементов() Тогда
		Возврат;
	КонецЕсли; 	
	
	Если ВидФормы = "ФормаВыбора" Тогда
		
		Отбор = Новый Структура;
		Если НЕ Параметры.Свойство("Отбор") Тогда
			Параметры.Вставить("Отбор", Отбор);
		КонецЕсли; 
		
		Параметры.Отбор.Вставить("ПометкаУдаления", Ложь);
			
	КонецЕсли; 
	
КонецПроцедуры
Показать
20. oldcopy 142 06.06.22 13:47 Сейчас в теме
(19) Это слишком радикально, бывают и ошибочные пометки на удаление.
12. Sanario 22 28.04.22 09:21 Сейчас в теме
Ну да. Например характеристику пометили на удаление. У них то наименования не уникальные, подбор вводом и как себя поведет расширение?
15. neverx6 10.05.22 22:54 Сейчас в теме
Добрый, будет ли работать с розницей 2.3?
16. SergAl 648 11.05.22 09:28 Сейчас в теме
(15) Добрый день! Создал расширение для Розницы 2.3.
Оставьте свое сообщение
Вакансии
Администратор 1С
Владивосток
зарплата от 150 000 руб.
По совместительству

Руководитель проектов внедрения 1С:УХ
Краснодар
зарплата от 150 000 руб.
Полный день

Консультант-аналитик 1С
Москва
зарплата от 120 000 руб. до 190 000 руб.
Полный день

Ведущий аналитик-разработчик 1С
Москва
зарплата от 230 000 руб. до 270 000 руб.
Полный день

Программист 1С + PHP
Москва
зарплата от 150 000 руб. до 180 000 руб.
Полный день