Обработка регистров сведений

0. 1682 10.10.09 19:01 Сейчас в теме
Обработка предназначена для обработки данных регистров сведений.
С ее помощью можно удалить записи, изменить значения реквизитов, выполнить произвольный код для каждой обрабатываемой записи.
РС, подчиненные регистратору не обрабатываются.

Для скачивания доступны варианты для обычных форм и для управляемых форм - 2 разных файла.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. MRAK 717 10.10.09 19:01 Сейчас в теме
плюсану авансом... позже гляну... делал как-то такую, тока без построителя... хотя по мне, лучше сюда СКД замутить...
2. Valerich 12.10.09 09:04 Сейчас в теме
(1) если обоснуете чем СКД для отбора круче построителя, замучу СКД :)
3. I_G_O_R 64 12.10.09 09:32 Сейчас в теме
можно вот такие отборы делать:
Прикрепленные файлы:
4. artbear 1306 12.10.09 09:58 Сейчас в теме
(3+) Точнее, можно делать даже группы отборов с условиями И, ИЛИ и т.д.
5. poZZitive 21.10.09 13:57 Сейчас в теме
Абалденная вещь. Лучшая из найденных (бесплатных)
6. dosen 33 13.11.09 20:42 Сейчас в теме
Спасибо, ибо ................................ (почему сам не сделал, каждый добавит или придумает ) :D
7. pri_hod 77 08.01.10 02:25 Сейчас в теме
Исправь ошибку

ИначеЕсли ДействиеУдалить = 1 Тогда //Нужно "2"
// выполнение алгоритма

За обработку +
Valerich; +1 Ответить
11. Valerich 1682 29.09.10 01:48 Сейчас в теме
(7) а почему нужно 2? где ошибается и на чем?

(5), (6), (7), (8), (9), (10). Вам всем спасибо за время , которое Вы потратили, чтобы выразить свое мнение.

Ваше мнение всегда очень важно для меня.
13. Збянтэжаны Саўка 245 21.04.11 17:22 Сейчас в теме
(11) Как правильно замечено в (7) и (12) Вариант:

ИначеЕсли ДействиеУдалить = 1 Тогда

повторяется дважды, т.е. 3-й вариант (ДействиеУдалить = 2) не сработает, нужно исправить

Очень ценю Ваши статьи и обработки, потому считаю данную ошибку мелкой опиской!
14. Valerich 1682 21.04.11 17:56 Сейчас в теме
(7), (12), (13)

Проверил, действительно опечатка вышла. Спасибо, коллеги.
Исправил, прикрутил фантик.

Пользуйтесь на здоровье
8. Leoway 163 10.06.10 10:41 Сейчас в теме
9. erderugina 17.08.10 13:07 Сейчас в теме
Благодарю. Обработка помогла.
10. Алексей-29 28.09.10 13:34 Сейчас в теме
Обработка отличная. Давно искал такую. :)
12. pri_hod 77 29.09.10 02:00 Сейчас в теме
ну не логично же

Если ДействиеУдалить = 0 Тогда

// удаление записей
ОбработаноЗаписей = 0;
УдалитьЗаписи(ТаблицаРезультат, ОбработаноЗаписей);
Предупреждение("Обработано " + ОбработаноЗаписей + " зап.", 15);
ИначеЕсли ДействиеУдалить = 1 Тогда
//Изменение записей
ОбработаноЗаписей = 0;
ИзменитьЗаписи(ТаблицаРезультат, Реквизиты, ОбработаноЗаписей);
Предупреждение("Обработано " + ОбработаноЗаписей + " зап.", 15);
ВыполнитьОтбор(); // заново считаем набор
ИначеЕсли ДействиеУдалить = 1 Тогда
// выполнение алгоритма
ТекстАлгоритма = ЭлементыФормы.ТекстПроизвольногоАлгоритма.ПолучитьВыделенныйТекст();
Если СтрДлина(ТекстАлгоритма) = 0 Тогда
ТекстАлгоритма = ЭлементыФормы.ТекстПроизвольногоАлгоритма.ПолучитьТекст();
КонецЕсли;
ОбработаноЗаписей = 0;
ВыполнитьАлгоритм(ТаблицаРезультат, ТекстАлгоритма, ОбработаноЗаписей);
Предупреждение("Обработано " + ОбработаноЗаписей + " зап.", 15);
ВыполнитьОтбор(); // заново считаем набор
КонецЕсли;
15. artbear 1306 11.08.11 10:09 Сейчас в теме
(0) Ошибка в обработке исключений при попытке записи неверных данных в регистр сведений
Вместо
				Исключение
					Сообщить("Строка таблицы " + СтрокаТаблицы.НомерСтроки + ": ошибка изменения записи " + ОписаниеОшибки());
				КонецПопытки;

Правильно писать
				Исключение
					Сообщить("Строка таблицы " + СтрокаТаблицы.Владелец().Индекс(СтрокаТаблицы) + ": ошибка изменения записи " + ОписаниеОшибки());
				КонецПопытки;

Иначе будет исключение и обработка остановится :(
16. artbear 1306 11.08.11 11:41 Сейчас в теме
(15) + Ну и вообще СтрокаТаблица.НомерСтроки там еще встречается, также нужно устранить.
18. Valerich 1682 03.10.11 14:12 Сейчас в теме
(15), (16) там же вроде как "СтрокаТаблицы" - это строка таблицы значений... или я чего-то неправильно помню ?
17. seandr 03.10.11 09:37 Сейчас в теме
Все не доходили руки сделать подобное.. но сейчас с успехом использую эту обработку. Спасибо огромное...
19. dmd 11.10.11 19:38 Сейчас в теме
Прекрасно работает. Очень пригодилась +100500
20. Maranet 11 18.10.11 14:27 Сейчас в теме
Спасибо, очень пригодилась...
21. vik77 15 20.10.11 15:03 Сейчас в теме
Спасибо, обработка очень выручила.
22. gusteleva 04.11.11 21:29 Сейчас в теме
Обработка замечательная, автору респект!
23. UJF 23.11.11 15:44 Сейчас в теме
Обработка реально очень полезная. Однозначно +
24. redgoll 01.12.11 08:57 Сейчас в теме
Большое спасибо. Очень помогло. Конечно, можно и самому было регистры обработать...но на программирование время бы ушло, а так быстро и хорошо. Не раз еще выручит.
25. nataon 07.03.12 14:07 Сейчас в теме
26. mdzen 238 28.03.12 03:53 Сейчас в теме
Пытаюсь выполнить код:
(Регистр сведений Штрихкоды - штрихкоду надо установить ед.измерения как у владельца базовая)

Объект.ЕдиницаИзмерения = Объект.Владелец.БазоваяЕдиницаИзмерения;
Объект.Записать(Истина);

что-то не взлетает...
27. Valerich 1682 28.03.12 05:14 Сейчас в теме
(26) Не знаю какая у вас конфигурация, но, возможно, идет несовпадение типов данных. Например, "ОКЕИ" и "Единицы измерения". Проверьте.
28. mdzen 238 28.03.12 10:56 Сейчас в теме
Точно, несовпадение типов...
4 утра - туплю однако ....
29. kuza_87 26 06.06.12 05:31 Сейчас в теме
Спасибо, пригодилось. Нужная в хозяйстве вещь
30. Adoms 151 25.07.12 15:43 Сейчас в теме
Большое спасибо!!! ооочень пригодилась!!!
31. irishka77 08.11.12 13:29 Сейчас в теме
Спасибо.Использовала для приведения в порядок штатного расписания
32. olsy 23 07.12.12 12:24 Сейчас в теме
Классная обработка! Давно искал, спасибо Поручику за наводку!
33. CaSH_2004 363 13.12.12 21:11 Сейчас в теме
Все замечательно! Но странно что не видно сколько записей то найдено. Это что никому не интересно сколько он чего грохнет или заменит? Или все выводят в список и смотрят что же там внизу за цифра :) Я конечно понимаю что бесплатное, но сам то как угадываеш то?

И вот еще интересно можно ли ее так универсально сделать чтобы например отобрать те записи у которых Измерение/Ресурс имеет указанный тип, например "Справочник.ДоговораКонтрагентов"? А то ведь и такие замутки встречаются, именно они создают сложность.
Если у кого идеи есть - выкладывайте, может кто и доработает.
84. WWWolfy 104 11.04.19 16:34 Сейчас в теме
34. ManyakRus 415 27.12.12 17:41 Сейчас в теме
работает отлично :)
сделал ширину колонок не более 25
35. _n26__ 15.01.13 15:07 Сейчас в теме
36. sanches 253 24.01.13 10:56 Сейчас в теме
Скажите, с помощью данной обработки я смогу убрать из значений регистра пробелы?
37. Valerich 1682 24.01.13 15:13 Сейчас в теме
(36) а что Вы понимаете под пробелами в регистре сведений ?
38. sanches 253 24.01.13 15:32 Сейчас в теме
(37) Конфигурация 1С Аптека.
В ней есть регистр сведений Штрихкоды, в нем есть измерение Штрихкод типа ПланВидовХарактеристик.
В самом плане видов характеристик хранятся строковые значения длиной 200 символов.
Сейчас у меня для номенклатуры штрихкоды представляют такое значение
"4607012390615       "
, из-за чего при печати этикеток выходит ошибка компоненты barcode о неверном штрихкоде. В ручную поправил несколько штрихкодов, после чего печать этикеток для них заработала. Вот, хочу исправить все значения теперь в регистре сведений.
39. Valerich 1682 24.01.13 15:37 Сейчас в теме
(38) из Вашего описания проблемы я понял, что править то надо не регистр сведений, а план видов характеристик.

Теоретически эта обработка может помочь: Отобрать записи РС, где реквизит ПВХ реквизита штрихкод содержит пробел. Далее с помощью выполнения произвольного кода можно получить объект ПВХ, обрезать пробелы и записать его обратно.
40. sanches 253 24.01.13 16:01 Сейчас в теме
41. ProkopyukIN 11 25.12.13 16:45 Сейчас в теме
старовата однако. надо бы уже модифицировать под 8.2, 8.3 и управляемое приложение
42. webresurs 191 19.02.15 14:04 Сейчас в теме
Подскажите пож... а можно устранить ошибку вашей обработкой в счетах?

Ошибка в прошлых годах :"Выполните повторно регламентную операцию "Закрытие счетов 20, 23, 25, 26" за тот месяц, в котором образовалось отрицательное сальдо"
43. Valerich 1682 20.02.15 02:41 Сейчас в теме
(42) тут дело не в счетах и не в регистрах сведений, а в проводках. Если у вас образовалось отрицательное сальдо на затратных счетах, то, либо как-то скорректировать вручную, либо перезакрывать соответствующий месяц с возможной пересдачей отчетности, если такое пеерзакрытие повлияет на финансовые результаты.
webresurs; +1 Ответить
44. RTesla 31.03.15 22:00 Сейчас в теме
45. Ольга_tmp 61 17.06.15 03:46 Сейчас в теме
Спасибо, отлично сработало для коррекции штрихкодов в УТ10
46. vanya201 11 20.10.15 16:20 Сейчас в теме
Поменяйте в коде (стр 310) Если НЕ СтрокаТаблицы.ПомМетка Тогда
на Если НЕ СтрокаТаблицы.Пометка Тогда
48. Valerich 1682 22.10.15 02:10 Сейчас в теме
(46) Уточните, пожалуйста, в какой версии обработки такой код и в каком модуле (формы, объекта).
47. ZyMik 21.10.15 22:12 Сейчас в теме
Не работает.
21.10.2015 22:09:56
Ошибка создания источника доступных настроек компоновки данных

1С:Предприятие 8.3 (8.3.6.2332)
Система проектирования прикладных решений, редакция 1.1 (1.1.10.4)
49. Valerich 1682 22.10.15 02:13 Сейчас в теме
(47) попробуйте запустить в толстом клиенте. Кажется такая ошибка случается в тонком
50. bsa1968 63 12.11.15 11:50 Сейчас в теме
Все просто и понятно. Спасибо за работу!
Версия для "управляемого приложения" работает только в "толстом клиенте"?
51. Valerich 1682 13.11.15 04:04 Сейчас в теме
(50) в толстом клиенте работает как было задумано. А в тонком наблюдаются какие-то необъяснимые спецэффекты - в отборе нельзя выбрать свойства измерений/ресурсов/реквизитов, если они являются ссылками на объекты; при смене регистра сведений вообще бывают ошибки инициализации СКД. Видимо у меня не хватает каких-то знаний и навыков для борьбы с этими багами.
52. Sergspectr 103 06.01.16 23:08 Сейчас в теме
53. White_and_Fluffy 16.02.16 02:28 Сейчас в теме
На УФ не читает регистр "ПрисоединенныеФайлы"
Прикрепленные файлы:
Valerich; +1 Ответить
54. Valerich 1682 16.02.16 08:24 Сейчас в теме
(53) Исправил ошибку, обработку перезалил. Спасибо за Ваше сообщение
55. dj_serega 377 16.02.16 12:59 Сейчас в теме
Все комменты не читал.

1. На скринах нашел "ЭтаФорма". В 8.3 без режима совмести "ЭтаФорма" уже "ЭтотОбъект".
2. Как обстоят дела с модальностью и асинхронностью?
56. Valerich 1682 17.02.16 05:52 Сейчас в теме
(55)
1. В 8.3 в управляемых формах не "ЭтотОбъект", а "Объект". А вот при выполнении на серере доступ к данным формы идет чере "ЭтаФорма". Вроде как все работает.
2. Модальных окон нет. Асинхронности тоже (во всяком случае пока).
57. dj_serega 377 17.02.16 11:50 Сейчас в теме
(56) 1.
Конфликт имен свойств

Нельзя использовать имена переменных, совпадающие с новыми свойствами, которые появились в "1С:Предприятии 8.3":

Новое свойство ЭтотОбъект в управляемых формах и общих модулях.
Новые свойства в управляемых формах:
АвтоНавигационнаяСсылка,
НавигационнаяСсылка,
ВертикальнаяПрокрутка,
ОписаниеОповещенияОЗакрытии,
ПараметрыВыбора.
Для устранения несовместимости необходимо найти переменные и реквизиты форм с такими названиями и переименовать их.

Что переименовано _____________Старое наименование _____Новое наименование
Свойство управляемой формы ____ ЭтаФорма (ThisForm) ______ ЭтотОбъект (ThisObject)

источник
58. Valerich 1682 18.02.16 06:25 Сейчас в теме
(57) а я и не объявляю эти переменные, просто подсказка как можно добраться до реквизитов формы. Если используется другая версия платформы, где произошла замена, следует пользоваться новыми свойствами формы и объекта
59. dj_serega 377 01.04.16 17:07 Сейчас в теме
Неизвестная ошибка. В ЖР пусто...
Прикрепленные файлы:
60. Valerich 1682 03.04.16 06:07 Сейчас в теме
(59) Попробуйте работать в толстом клиенте. В тонком клиенте многие операции с метаданными недоступны. Из-за этого и появляются такие странные ошибки.
61. dimaz666 20.04.16 10:10 Сейчас в теме
Платформа: 1С:Предприятие 8.3 (8.3.7.1993)
Режим: Файловый (без сжатия)
Приложение: Толстый клиент
Вариант интерфейса: Такси

Ошибки:
--------------------------------------------------------------------------------
Ошибка создания источника доступных настроек компоновки данных

Воспроизводится при удалении записей.
62. Valerich 1682 21.04.16 12:26 Сейчас в теме
(61) Уточните, пожалуйста в какой момент времени происходит ошибка: в момент после нажатия на кнопку "Выполнить чтение данных регистра" или при удалении после нажатия на кнопку "Выполнить удаление"?

Если работаете в стандартной конфигурации, то прошу так же уточнить конфигурацию, релиз, имя регистра и настройки отбора. Может быть мне удастся смоделировать ситуацию. До сих пор с такой ошибкой сталкивался только в тонком клиенте, но Вы указали, что режим запуска "Толстый клиент".
64. gull22 88 11.07.16 09:34 Сейчас в теме
(62)
Аналогичная ситуация. Происходит при нажатии кнопки "Выполнить удаление".
Удалял записи РС Аналитика учета НДС
Платформа: 1С:Предприятие 8.3 (8.3.8.1747)
Конфигурация: Бухгалтерия предприятия КОРП, редакция 3.0 (3.0.43.241)
Режим: Файловый (без сжатия)
Приложение: Тонкий клиент
Локализация: Информационная база: русский (Россия), Сеанс: русский (Россия)
Вариант интерфейса: Такси

Ошибки:
--------------------------------------------------------------------------------
11.07.2016 9:28:16
Ошибка создания источника доступных настроек компоновки данных
65. Valerich 1682 12.07.16 04:52 Сейчас в теме
(64) Это очень странно. При нажатии на кнопку "Выполнить удаление" начинается работа с таблицей данных на форме и регистром сведений. Компоновщик настроек при этом никак не используется.

Обратите внимание, что 29.04.2016 я разместил обновление обработки, которая корректно работает в тонком клиенте. Если Вы скачивали обработку ранее, попробуйте скачать обновленную

У меня ошибка никак не воспроизводится. Но где-то проскальзывало сообщение, что подобная ошибка возможна на некоторых релизах платформы. Чаще проявляется, если установлена низкая скорость соединения.
63. Si-ned 7 09.06.16 13:59 Сейчас в теме
Хорошая и полезная обработка. +1
66. andt 14.07.16 05:22 Сейчас в теме
Спасибо! Обработка помогла, но нужно поправить:
{Форма.ФормаУправляемая.Форма(316)}: Поле объекта не обнаружено (Помметка)
Если НЕ СтрокаТаблицы.Помметка Тогда
68. Valerich 1682 05.08.16 05:09 Сейчас в теме
(66) Ошибку исправил, большое спасибо
67. izidakg 161 04.08.16 13:58 Сейчас в теме
нужно было в регистре РезультатыОбменаДанными убить запись с пустой ссылкой, там их было 3 шт
не вышло - в обработке УФ написано ЭтотОбъект, а нужно было Объект (удалял в Рознице 2.0)
а потом выяснилось что отобранные объекты удаляются по одному и сначала прочитать, потом удалить - а прочитать вызывает ошибку - более 1 записи по ключевым полям
так что удаление не удалось, редактирование невозможно по тем же причинам
пришлось свою обработку использовать, там также ЭтотОбъект править пришлось, она всетаки была изначально для КА, УТ - все что на 8.2 с УФ
но вот процедура по удалению справилась:
Выборка = РегистрыСведений[РегистрСедений].Выбрать();
	
	Прогресс = 0;	
	Удалено = 0;	
	Пока Выборка.Следующий() Цикл
		
		Объект = Выборка.ПолучитьМенеджерЗаписи();								
		Рез = Истина;
		Если ПустаяСтрока(КодРегистраСодержит) Тогда
			Для каждого УсловиеОтбора Из Отбор Цикл		
				Если УсловиеОтбора.Отбирать Тогда
					Если Сравнить(Объект[УсловиеОтбора.Имя], УсловиеОтбора.Значение, УсловиеОтбора.Действие) Тогда
						Рез = Рез И Истина
					Иначе
						Рез = Рез И Ложь;
					КонецЕсли;				
				КонецЕсли;				
			КонецЦикла;
		Иначе
			Если Найти(Врег(Объект.Код), Врег(КодРегистраСодержит)) = 0 Тогда
				Рез = Рез И Ложь;
			КонецЕсли;	
		КонецЕсли;
		
		Если Рез Тогда			
			Объект.Удалить();		
			Удалено = Удалено + 1;
		КонецЕсли;
		
		Прогресс = Прогресс + 1;
		Если ТекущийРежимЗапуска() = РежимЗапускаКлиентскогоПриложения.ОбычноеПриложение Тогда
			#Если НЕ Сервер Тогда 
				Состояние("Обработано: "+Строка(Прогресс)+" записей...");
			#КонецЕсли
		КонецЕсли;
		
	КонецЦикла;
Показать
69. Valerich 1682 05.08.16 05:11 Сейчас в теме
(67) не очень понял что там с Объект или ЭтотОбъект: где и что надо исправлять

Что касается ошибки при попытке чтения записей регистра, так у вас получается данные практически нечитаемые. Можно было сделать тестирование и исправление ИБ. Система бы сама нашла такие дублирующиеся по ключевым полям записи и удалили их.
maikl007; +1 Ответить
70. maikl007 91 16.11.16 11:54 Сейчас в теме
Спасибо за обработку, НУЖНАЯ ВЕЩЬ В ХОЗЯЙСТВЕ )
71. snegovik 4 12.03.17 19:36 Сейчас в теме
Есть в БП 3.0 регистр сведений "Ставки налога на имущество по отдельным основным средствам". На начало года в нем вводятся ОС с льготными ставками. Можно с помощью вашей обработки отобрать на начало прошлого года все элементы и скопировать (создать) новые с другой льготной ставкой на начало текущего года ?

P.S. Попробовал изменить старые ставки - Выдает ошибку при попытке простого изменения на этом регистре - "Строка таблицы 1: Не смог идентифицировать запись". И так все остальные строки.
72. Valerich 1682 13.03.17 05:54 Сейчас в теме
(71) Обнаружил ошибку определения того, что регистр периодический Ошибку исправил. Скачайте обработку заново и попробуйте.

Но. Изменение реквизитов (период и ставка) может привести к тому, что у вас просто изменятся существующие записи. Попробуйте на одной.
Достоверно могу сказать, что можно использовать алгоритм для создания новых записей.
73. snegovik 4 13.03.17 08:20 Сейчас в теме
Я извиняюсь, программировал сам очень давно на 7.7 и 8.2 - можно пример простейшего кода создания элемента регистра сведений для вашей обработки ?
74. snegovik 4 13.03.17 19:42 Сейчас в теме
Вроде разобрался. На всякий случай оставлю это здесь - вдруг кому то еще пригодится:

Алгоритм по изменению ставки в справочнике по налогу на имущество
75. Valerich 1682 14.03.17 03:43 Сейчас в теме
(74) Можно и короче:
НоваяЗапись = РегистрыСведений.СтавкиНалогаНаИмуществоПоОтдельнымОсновнымСредствам.СоздатьМенеджерЗаписи(); 
ЗаполнитьЗначениеСвойств( НоваяЗапись, ЗаписьРС );
НоваяЗапись.Период = НачалоГода(ТекущаяДата()); 
НоваяЗапись.Записать(Истина);
76. snegovik 4 15.03.17 07:09 Сейчас в теме
Странная ситуация - на другом компьютере на новой версии обработки вышла такая же ошибка "Строка таблицы 1: Не смог идентифицировать запись".
На моем компьютере при запуске новой версии ошибка тоже выходила - не помню в какой момент она перестала выходить.
77. Valerich 1682 15.03.17 13:04 Сейчас в теме
(76) Ситуация действительно странная. Воспроизвести не могу
78. snegovik 4 15.03.17 21:08 Сейчас в теме
На демо базе последней версии 3.0 отрабатывает нормально, на типовой рабочей базе 3.0 последней версии (на этом же компьютере и этой же платформе) вылетает ошибка.
Прикрепленные файлы:
79. snegovik 4 15.03.17 21:45 Сейчас в теме
Понял в чем дело.... Если организация одна в базе, то реквизит "Организация" (и возможно какие-то другие) не заполняется.
Этот реквизит заполнится автоматом, если ввести еще одну организацию. В демо базе несколько организаций и все реквизиты заполнены.
В обработке, видимо, проверяются все реквизиты при попытке изменении и если чего-то не хватает, то вылетает эта ошибка "Строка таблицы : Не смог идентифицировать запись".
80. Valerich 1682 16.03.17 07:05 Сейчас в теме
(79) У меня немного устаревшая версия этой конфигурации. У измерения "Организация" стоит признак контроля заполненности.
При этом действительно, если организация одна, то она в регистре не заполняется.
Как они обходят это ограничение интересно... и зачем...?

При этом, когда создаешь объект "МенеджерЗаписи", заполняешь значения измерений из выборки (помним, что организация пустая) и пытаемся прочитать запись, она не находится в регистре :( МенеджерЗаписи.Выбран() = Ложь

Как обходить пока не знаю. Только если через набор записей и его отборы....
81. German_Tagil 27 23.03.17 14:31 Сейчас в теме
Поставлю себе на заметку
82. Arguleon 23.03.17 16:54 Сейчас в теме
За обработку +, думаю понадобится
83. AKV77 255 05.04.18 22:10 Сейчас в теме
86. WWWolfy 104 11.04.19 16:44 Сейчас в теме
согласен с "33"
Действительно нужен фильтр по типу объекта.
Потому что при попытке отфильтровать регистр по составному полю запрос валит сервер очень легко. Например в ERP только одних документов сотня типов, и в каждом куча элементов.
Без отборов типа таких, составные поля вешают SQL сервер:
ВЫРАЗИТЬ(ДанныеПоследнихОповещений.ИсточникОповещения КАК Документ.Заказ).ПометкаУдаления = ИСТИНА
Оставьте свое сообщение
Вопросы с вознаграждением