Почему документ не делает движения по регистру бухгалтерии?

1. 77 14.01.22 12:43 Сейчас в теме
Здравствуйте в БГУ 2.0.82.16, есть такой код:
Движения.ЖурналПроводокЕПСБУ.Записывать = Истина;
	Движения.ЖурналПроводокЕПСБУ.Очистить();
	
	Для Каждого ТекСтрокаВидыЗатрат Из ВидыЗатрат Цикл
		
		Движение = Движения.ЖурналПроводокЕПСБУ.Добавить();
		Движение.Регистратор = ЭтотОбъект.Ссылка;
		Движение.ИФО = ЭтотОбъект.Баланс;
		Движение.Период     = ЭтотОбъект.Дата;               
		Движение.Организация = Организация;
		Движение.КФО        = Перечисления.КВД.Внебюджет;
		
		//Дт 106 Кт 109
		Если ВидыОперацийПоВнутренним = Перечисления.ВидыОперацийПоВнутренним.ВводОстатковПоСтарым Тогда
			Движение.Содержание = "Ввод остатков по старым ";
		//Дт 109 Кт 106	
		ИначеЕсли ВидыОперацийПоВнутренним = Перечисления.ВидыОперацийПоВнутренним.ЗакрытиеСПлюсом Тогда
			Движение.Содержание = "Закрытие внутреннего  с положительным результатом";
		//Дт 401 Кт 106	
		Иначе
			Движение.Содержание = "Закрытие внутреннего  с отрицательным результатом";
		КонецЕсли;
		
		Движение.СчетДт = ТекСтрокаВидыЗатрат.СчетДебета;
		Движение.КПСДт = ТекСтрокаВидыЗатрат.КБКСчетДебета;
		Движение.КЭКДт         = ТекСтрокаВидыЗатрат.КОСГУСчетДебета;
		
		Если ТекСтрокаВидыЗатрат.СчетДебета = ПланыСчетов.ЕПСБУ.НайтиПоКоду("109.61") или ТекСтрокаВидыЗатрат.СчетДебета = ПланыСчетов.ЕПСБУ.НайтиПоКоду("106.3И") Тогда
			Движение.СубконтоДт[планыВидовХарактеристик.ВидыСубконто.Номенклатура] = ТекСтрокаВидыЗатрат.СубконтоСчетДебета2;
			Движение.СубконтоДт[планыВидовХарактеристик.ВидыСубконто.ВидыЗатрат]    = ТекСтрокаВидыЗатрат.СубконтоСчетДебета3;
		КонецЕсли;
		
		//Движение.СубконтоДт.ВидыЗатрат    = ТекСтрокаВидыЗатрат.СубконтоСчетДебета3; нет у 401.10
		
		Движение.СчетКт = ТекСтрокаВидыЗатрат.СчетКредита;
		Движение.КПСКт  = ТекСтрокаВидыЗатрат.КБКСчетКредита;
		Движение.КЭКДт = ТекСтрокаВидыЗатрат.КОСГУСчетКредита;
		
		Если ТекСтрокаВидыЗатрат.СчетКредита = ПланыСчетов.ЕПСБУ.НайтиПоКоду("109.61") или ТекСтрокаВидыЗатрат.СчетКредита = ПланыСчетов.ЕПСБУ.НайтиПоКоду("106.3И") Тогда
			Движение.СубконтоКт.Номенклатура  = ТекСтрокаВидыЗатрат.СубконтоСчетКредита2;
			Движение.СубконтоКт.ВидыЗатрат    = ТекСтрокаВидыЗатрат.СубконтоСчетКредита3;
		КонецЕсли;
	
		Движение.Сумма = ТекСтрокаВидыЗатрат.Сумма;
		
		//НУ
		Если ФормироватьПроводкиПоНУ Тогда
			
			Если ЗначениеЗаполнено(ТекСтрокаВидыЗатрат.СчетДебетаНУ) или ЗначениеЗаполнено(ТекСтрокаВидыЗатрат.СчетКредитаНУ) Тогда
				
				Движение = Движения.ЖурналПроводокЕПСБУ.Добавить();
				Движение.Период     = Дата;               
				Движение.Организация = Организация;
				Движение.Сумма      = ТекСтрокаВидыЗатрат.Сумма;
				
				Если ЗначениеЗаполнено(ТекСтрокаВидыЗатрат.СчетДебетаНУ) Тогда
					Движение.СчетДт = ТекСтрокаВидыЗатрат.СчетДебетаНУ;
					
					Если Лев(Движение.СчетДт.Код,2) = "Н2" Тогда
						Если ВидыОперацийПоВнутренним = Перечисления.ВидыОперацийПоВнутренним.ВводОстатковПоСтарым Тогда
							Движение.Содержание = "Ввод остатков по старым";
							Движение.СубконтоДт[(Движение.СчетДт.ВидыСубконто[0].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетДебетаНУ1;
							Движение.СубконтоДт[(Движение.СчетДт.ВидыСубконто[1].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетДебетаНУ2;
							
						ИначеЕсли ВидыОперацийПоВнутренним = Перечисления.ВидыОперацийПоВнутренним.ЗакрытиеСПлюсом Тогда
							Движение.Содержание = "Закрытие внутреннего с положительным результатом";
							Движение.СубконтоДт[(Движение.СчетДт.ВидыСубконто[0].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетДебетаНУ1;
							Движение.СубконтоДт[(Движение.СчетДт.ВидыСубконто[1].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетДебетаНУ2;
							
						Иначе
							Движение.Содержание = "Закрытие внутреннего с отрицательным результатом";
							Движение.СубконтоДт[(Движение.СчетДт.ВидыСубконто[0].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетДебетаНУ1;
							Движение.СубконтоДт[(Движение.СчетДт.ВидыСубконто[1].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетДебетаНУ2;
						КонецЕсли;
						
					ИначеЕсли Лев(Движение.СчетДт.Код,2) = "НЕ" Тогда
					Иначе
						Движение.СубконтоДт[(Движение.СчетДт.ВидыСубконто[0].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетДебетаНУ1;
						Движение.СубконтоДт[(Движение.СчетДт.ВидыСубконто[1].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетДебетаНУ2;
						
						//Движение.СубконтоКт[(Движение.СчетКт.ВидыСубконто[0].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетКредитаНУ1;
						//Движение.СубконтоКт[(Движение.СчетКт.ВидыСубконто[1].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетКредитаНУ2;
					КонецЕсли;
					
				КонецЕсли;
				
				Если ЗначениеЗаполнено(ТекСтрокаВидыЗатрат.СчетКредитаНУ) Тогда
					Движение.СчетКт = ТекСтрокаВидыЗатрат.СчетКредитаНУ;
					Если Лев(Движение.СчетКт.Код,2) = "Н2" Тогда
						Движение.СубконтоКт[(Движение.СчетКт.ВидыСубконто[0].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетКредитаНУ1;
						Движение.СубконтоКт[(Движение.СчетКт.ВидыСубконто[1].ВидСубконто)] = ТекСтрокаВидыЗатрат.СубконтоСчетКредитаНУ2;
					КонецЕсли;
				КонецЕсли;
			КонецЕсли;	
			
		КонецЕсли; //Если ФормироватьПроводкиПоНУ Тогда
		
	КонецЦикла;
Показать

По коду посмотрел, все заполняет, значение в движение подставляются, но в регистре бухгалтерии данные не появляются! Я смотрю через кнопку ДТКт, ну и вывел регистр в шапку, туда прохожу, там тоже пусто.
Через конструктор пробовал, аналогично!
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. Dимыч 14.01.22 13:08 Сейчас в теме
3. VID1234 77 14.01.22 13:48 Сейчас в теме
(2) Спасибо. Добавил Записать, все заработало.!
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Старший программист 1С
Новосибирск
зарплата от 100 000 руб. до 200 000 руб.
Полный день

Тестировщик 1С
Санкт-Петербург
зарплата от 60 000 руб. до 120 000 руб.
Полный день

Архитектор НСИ
Москва
зарплата от 250 000 руб. до 300 000 руб.
Полный день

1С Программист по 1С:Управление торговлей
Кострома
зарплата от 100 000 руб. до 110 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству