Программное объединение области табличного документа.

1. 13.01.22 16:32 Сейчас в теме
Здравствуйте. Есть табличный документ с программно созданной областью. В моем варианте текст записывается в каждую ячейку области. Подскажите, пожалуйста ,как объединить ячейки этой области в одну? Пробовал метод
 ОбластьТекста = Тдок.Область("R1C1:R1C6").Объединить();
но выдает ошибку "Обращение к процедуре объекта как к функции (Объединить)".

	 
ТДок = Новый ТабличныйДокумент;
ОбластьТекста = Тдок.Область("R1C1:R1C6");
ОбластьТекста.Текст = "Тест"
Найденные решения
2. antz 13.01.22 16:46 Сейчас в теме
Ну, правильно все пишет.

ТДок = Новый ТабличныйДокумент;
ОбластьТекста = Тдок.Область("R1C1:R1C6");
ОбластьТекста.Объединить();
ОбластьТекста.Текст = "Тест"
user1619761; +1 Ответить
5. STELEICE 13.01.22 17:23 Сейчас в теме
(1)Если нужно по такому принципу как на фото тогда так:
	  ПоследняяСтрока=100;
	 ОбъединениеНачало=6;
Для Строка=7 По ПоследняяСтрока Цикл
	Если ТабДок.Область("R"+Строка+"C2"+":R"+Строка+"C4").Текст=ТабДок.Область("R"+Строка(Строка-1)+"C2"+":R"+Строка+"C4").Текст ИЛИ ОбъединениеНачало=Строка  
		Тогда Продолжить;
	ИначеЕсли НЕ  ТабДок.Область("R"+Строка+"C2"+":R"+Строка+"C4").Текст="Итого:"  ИЛИ НЕ ТабДок.Область("R"+Строка(Строка-1)+"C2"+":R"+Строка+"C4").Текст="Итого:" 
		Тогда
ТабДок.Область("R"+ОбъединениеНачало+"C2"+":"+"R"+Строка(Строка-1)+"C4").Объединить();
ОбъединениеНачало=Строка;
КонецЕсли;
КонецЦикла;
Показать
Прикрепленные файлы:
user1619761; +1 Ответить
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
5. STELEICE 13.01.22 17:23 Сейчас в теме
(1)Если нужно по такому принципу как на фото тогда так:
	  ПоследняяСтрока=100;
	 ОбъединениеНачало=6;
Для Строка=7 По ПоследняяСтрока Цикл
	Если ТабДок.Область("R"+Строка+"C2"+":R"+Строка+"C4").Текст=ТабДок.Область("R"+Строка(Строка-1)+"C2"+":R"+Строка+"C4").Текст ИЛИ ОбъединениеНачало=Строка  
		Тогда Продолжить;
	ИначеЕсли НЕ  ТабДок.Область("R"+Строка+"C2"+":R"+Строка+"C4").Текст="Итого:"  ИЛИ НЕ ТабДок.Область("R"+Строка(Строка-1)+"C2"+":R"+Строка+"C4").Текст="Итого:" 
		Тогда
ТабДок.Область("R"+ОбъединениеНачало+"C2"+":"+"R"+Строка(Строка-1)+"C4").Объединить();
ОбъединениеНачало=Строка;
КонецЕсли;
КонецЦикла;
Показать
Прикрепленные файлы:
user1619761; +1 Ответить
6. user1619761 14.01.22 08:23 Сейчас в теме
2. antz 13.01.22 16:46 Сейчас в теме
Ну, правильно все пишет.

ТДок = Новый ТабличныйДокумент;
ОбластьТекста = Тдок.Область("R1C1:R1C6");
ОбластьТекста.Объединить();
ОбластьТекста.Текст = "Тест"
user1619761; +1 Ответить
3. user1619761 13.01.22 16:50 Сейчас в теме
4. soft_wind 13.01.22 16:59 Сейчас в теме
только учтите, после объединения, текст который выводили в каждую ячейку - продает
останется только то, что вы присваиваете после
user1619761; +1 Ответить
7. user1619761 14.01.22 08:24 Сейчас в теме
(4) спасибо, это понятно, мне такой результат и нужен)
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Тестировщик 1С
Санкт-Петербург
зарплата от 60 000 руб. до 120 000 руб.
Полный день

Архитектор НСИ
Москва
зарплата от 250 000 руб. до 300 000 руб.
Полный день

Программист 1С
Пенза
зарплата от 120 руб. до 130 руб.
Полный день

Аналитик 1С
Санкт-Петербург
зарплата до 150 000 руб.
Полный день

Руководитель отдела разработки
Москва
зарплата от 200 000 руб. до 230 000 руб.
Полный день