Ограничение видимости справочника

1. 13.01.22 13:51 Сейчас в теме
Имеется сотрудник у которого настроен запуск для работы чисто с инвентаризацией. Единственное но: требуется данному сотруднику закрыть доступ в справочник "Контрагентов". Как это сделать не трогая конфигурацию?
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
5. d.batovskiy 13.01.22 15:45 Сейчас в теме
2. user1203706 13.01.22 13:55 Сейчас в теме
(0) Найти подходящую роль
3. user1203706 13.01.22 13:57 Сейчас в теме
А так, если вы работаете в организации не уровня Газпрома, то все эти ограничения на просмотр клиентосов - полный бред и никому не нужные действия. Имхо.
4. user633533_encantado 10 13.01.22 14:34 Сейчас в теме
Это ж УТ10, там если нет роли и интерфейса кладовщика, без доступа к контрагентам, то без изменений никак.
6. AnryMc 830 14.01.22 12:00 Сейчас в теме
Наверно можно (но сам не делал):

Сделайте расширение. Добавить из основной конфигурации в него справочник Контрагенты.
Добавьте роль "Нельзя" (которую затем дадите нужному пользователю вместе с другими)

В расширении, свойства справочника Контрагенты поставьте галочку у МодульМенеджера - в нём что то типа:
&Перед("ОбработкаПолученияФормы")
Процедура ФП_ОбработкаПолученияФормы(ВидФормы, Параметры, ВыбраннаяФорма, ДополнительнаяИнформация, СтандартнаяОбработка)
	
	Если РольДоступна("Нельзя") Тогда
		СтандартнаяОбработка = Ложь;
		Возврат;
	КонецЕсли;
	
КонецПроцедуры
Показать


Или переопределить на форму из расширения типа с надписью: "Вход запрещён!" ("Не влезай - убьёт !")...

З.Ы. Это "закрыть доступ" - нельзя открывать. А если вообще не показывать Наименования контрагентов во всех отчётах то - намного сложнее, но тоже можно (но очень трудоёмко, хотя можно там же поиграться с "ОбработкаПолученияПредставления" поменяв его на "А Вам какое дело?")...
7. AnryMc 830 14.01.22 12:23 Сейчас в теме
(6) Проверил с ОбработкаПолученияФормы - работает!!!
8. AnryMc 830 14.01.22 12:26 Сейчас в теме
(6) Проверил с "ОбработкаПолученияПредставления" тоже работает:

&Перед("ОбработкаПолученияПредставления")
Процедура Расш1_ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
	Если РольДоступна("Нельзя") Тогда
	СтандартнаяОбработка = ЛОЖЬ;
	Представление = "А вам какое дело?";
	КонецЕсли;
КонецПроцедуры
Прикрепленные файлы:
9. AnryMc 830 14.01.22 16:46 Сейчас в теме
(8) Данное решение заменяет представление Контрагента в отчетах (вместо Ссылки на Контрагента), списках, документах (реквизитах типа КонтрагентСсылка) но ничего не мешает "продвинутому" пользователю вывести в отчет доп. поля: Наименование, ПолноеНаименование...
10. user1488313 17.01.22 11:30 Сейчас в теме
(9)

А в ут 10.3 разве расширения есть?
11. AnryMc 830 17.01.22 13:52 Сейчас в теме
(10) Если она на управляемых формах - есть...
12. user1488313 17.01.22 13:57 Сейчас в теме
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Аналитик 1С
Санкт-Петербург
зарплата до 150 000 руб.
Полный день

Руководитель отдела разработки
Москва
зарплата от 200 000 руб. до 230 000 руб.
Полный день

Программист 1С
Москва
зарплата от 150 000 руб. до 150 000 руб.
Полный день

Консультант-аналитик 1С
Москва
зарплата от 100 000 руб. до 120 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству