Заполнение макета

1. 13.01.22 08:10 Сейчас в теме
здравствуйте подскажите пожалуйста как это исправить у меня в колонках с 9 по 14ю значения выводятся не с 1 строчки а с 17ой.

Для каждого Строка из  ОбъединениеТаблиц6 цикл
		ОбластьСтрока = Макет.ПолучитьОбласть("Строка");
		
		Код = Строка.КодОперации1;
		Первая = Лев(Код,1);
		ОбластьСтрока.Параметры.ПП = ПП;
		ОбластьСтрока.Параметры.Дата = Формат(Строка.ВремяНачала,"ДФ=dd.MM.yyyy");
		Если Первая = "1" Тогда
			ОбластьСтрока.Параметры.ВрНачБ2 = Формат(Строка.ВремяНачала,  "ДЛФ=T");
			ОбластьСтрока.Параметры.ВрОконБ2 = Формат(Строка.ВремяОкончания,  "ДЛФ=T");
			ОбластьСтрока.Параметры.ТемпНачБ2 = Строка.ТемператураНачала;
			ОбластьСтрока.Параметры.ТемпОконБ2 = Строка.ТемператураОкончания;
			ОбластьСтрока.Параметры.КоличествоБ2 = Строка.КоличествоСырья2;
			ОбластьСтрока.Параметры.РазницаБ2 = Строка.ОбщееВремя;
			
		ИначеЕсли Первая = "2" Тогда
				ОбластьСтрока.Параметры.ВрНачБ5  = Формат(Строка.ВремяНачала,  "ДЛФ=T");
				ОбластьСтрока.Параметры.ВрОконБ5 = Формат(Строка.ВремяОкончания,  "ДЛФ=T");
				ОбластьСтрока.Параметры.ТемпНачБ5 = Строка.ТемператураНачала;
				ОбластьСтрока.Параметры.ТемпОконБ5 = Строка.ТемператураОкончания;
				ОбластьСтрока.Параметры.КоличествоБ5 = Строка.КоличествоСырья2;
				ОбластьСтрока.Параметры.РазницаБ5 = Строка.ОбщееВремя;
		КонецЕсли;
         ПП=ПП+1;
		ПечатнаяФорма.Вывести(ОбластьСтрока);
	Конеццикла;
Показать
Прикрепленные файлы:
Найденные решения
3. AnryMc 830 13.01.22 09:34 Сейчас в теме
(1)
ПечатнаяФорма.Вывести(ОбластьСтрока);


Не Вывести а Присоединить для нужных строк
5. user5300 753 13.01.22 11:28 Сейчас в теме
    Если Первая = "1" Тогда
            ПечатнаяФорма.Вывести(ОбластьСтрока);
    ИначеЕсли Первая = "2" Тогда
            ПечатнаяФорма.Присоеденить(ОбластьСтрока);
    КонецЕсли;
    ПП=ПП+1;     
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. nomad_irk 58 13.01.22 08:16 Сейчас в теме
(1)
1. В формировании ОбъединениеТаблиц6 сделать так, как нужно.
2. Разбить ОбъединениеТаблиц6 на 2 по какому-то признаку
3. AnryMc 830 13.01.22 09:34 Сейчас в теме
(1)
ПечатнаяФорма.Вывести(ОбластьСтрока);


Не Вывести а Присоединить для нужных строк
4. AnryMc 830 13.01.22 09:36 Сейчас в теме
(3) Наверно ещё желательно сделать "вертикальную" область (ОбластьКолонка) и выводить / присоединять: ОбластьСтрока|ОбластьКолонка
5. user5300 753 13.01.22 11:28 Сейчас в теме
    Если Первая = "1" Тогда
            ПечатнаяФорма.Вывести(ОбластьСтрока);
    ИначеЕсли Первая = "2" Тогда
            ПечатнаяФорма.Присоеденить(ОбластьСтрока);
    КонецЕсли;
    ПП=ПП+1;     
6. G_109644103709981335430 13.01.22 12:14 Сейчас в теме
7. гаврюша 2 13.01.22 12:42 Сейчас в теме
Вы строки выводите по разным параметрам: ВрНачБ2 и ВрНачБ5.
В макете у Вас это одна область "ОбластьСтрока".
Как у Вас в макете это сделано?
Нельзя все выводить в одинаковые параметры, если нужно чтобы выходило начиная с одной колонки?
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Тестировщик 1С
Санкт-Петербург
зарплата от 60 000 руб. до 120 000 руб.
Полный день

Архитектор НСИ
Москва
зарплата от 250 000 руб. до 300 000 руб.
Полный день

Программист 1С
Пенза
зарплата от 120 руб. до 130 руб.
Полный день

Аналитик 1С
Санкт-Петербург
зарплата до 150 000 руб.
Полный день

Руководитель отдела разработки
Москва
зарплата от 200 000 руб. до 230 000 руб.
Полный день