Не удалось сформировать внешнюю печатную форму! Итератор для значения не определен

1. 12.01.22 14:06 Сейчас в теме
Не удалось сформировать внешнюю печатную форму! Итератор для значения не определен.

На форуме не нашел решения, может кто поможет. Только учусь, не пинайте!
Прикрепленные файлы:
2. Процедуры.txt
1. Функции.txt
Найденные решения
9. qzma 12.01.22 16:16 Сейчас в теме
Вопрос решил, спасибо!
Была глупая ошибка в коде...
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. wladimirpav 12.01.22 14:20 Сейчас в теме
Вот тут ошибка Ссылка - лишнее
Для Каждого Строка Из СсылкаНаОбъект.Ссылка.ИтогиРевизии Цикл
3. soft_wind 12.01.22 14:23 Сейчас в теме
попробуйте такую процедуру, которая связана с Кнопкой: Печать у вас на форме
Процедура ПечатьДокумента()
	
	Если СсылкаНаОбъект <> Неопределено и ЗначениеЗаполнено(СсылкаНаОбъект) Тогда
	Иначе
		Соообщить("Не выбран документ!");
		Возврат;
	КонецЕсли; 
	
	ОприходованнаяСумма = СсылкаНаОбъект.ОприходованнаяСумма;
	СуммаРеализации = СсылкаНаОбъект.СуммаРеализации;
	СуммаСУчетомРозничнойЦены = СсылкаНаОбъект.СуммаСУчетомРозничнойЦены;
	СуммаНаСписание = СсылкаНаОбъект.СуммаНаСписание;

	
	ТабДок = Новый ТабличныйДокумент;
	Макет = ЭтотОбъект.ПолучитьМакет("МакетАкта");
	
	// Шапка
	ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
	ОбластьШапка.Параметры.НомерДокумента = СсылкаНаОбъект.Номер;	
	ОбластьШапка.Параметры.ДатаДокумента = СсылкаНаОбъект.Дата;	
	ОбластьШапка.Параметры.Контрагент = СсылкаНаОбъект.Контрагент;
	ОбластьШапка.Параметры.Склад = СсылкаНаОбъект.Склад;
	ОбластьШапка.Параметры.ОприходованнаяСумма = СсылкаНаОбъект.ОприходованнаяСумма;
	ОбластьШапка.Параметры.Договор = СсылкаНаОбъект.ДоговорКонтрагента;
	ОбластьШапка.Параметры.СуммаРеализации = СсылкаНаОбъект.СуммаРеализации;
	ОбластьШапка.Параметры.СуммаСУчетомРозничнойЦены = СсылкаНаОбъект.СуммаСУчетомРозничнойЦены;
	ОбластьШапка.Параметры.СуммаНаСписание = СсылкаНаОбъект.СуммаНаСписание;
	
	//Шапка.Параметры.Заполнить(ЭтотОбъект);
	ТабДок.Вывести(ОбластьШапка);
	
	
	//СсылкаНаОбъект.ИтогиРевизии - подразумевается что это Табличная часть с полями
	//Сотрудник, СуммаУдержания
	Для Каждого лкСтрока Из СсылкаНаОбъект.ИтогиРевизии Цикл
		
		ОбластьСотрудники = Макет.ПолучитьОбласть("Сотрудники");
		ОбластьСотрудники.Параметры.Сотрудник = лкСтрока.Сотрудник;
		ОбластьСотрудники.Параметры.СуммаУдержания = лкСтрока.СуммаУдержания;
		ТабДок.Вывести(ОбластьСотрудники);
		
	
	КонецЦикла;

	
	// Подвал
	ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
	ОбластьПодвал.Параметры.Комментарий = СсылкаНаОбъект.Комментарий;
	ОбластьПодвал.Параметры.Ответственный = СсылкаНаОбъект.Ответственный;
	//Подвал.Параметры.Заполнить(ЭтотОбъект);
	ТабДок.Вывести(ОбластьПодвал);

	ТабДок.ОтображатьСетку = Ложь;
	ТабДок.Защита = Ложь;
	ТабДок.ТолькоПросмотр = Ложь;
	ТабДок.ОтображатьЗаголовки = Ложь;
	ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
	ТабДок.Показать();

КонецПроцедуры
Показать
4. qzma 12.01.22 14:37 Сейчас в теме
(3)
Процедура ПечатьДокумента()

Если СсылкаНаОбъект <> Неопределено и ЗначениеЗаполнено(СсылкаНаОбъект) Тогда
Иначе
Соообщить("Не выбран документ!");
Возврат;
КонецЕсли;

ОприходованнаяСумма = СсылкаНаОбъект.ОприходованнаяСумма;
СуммаРеализации = СсылкаНаОбъект.СуммаРеализации;
СуммаСУчетомРозничнойЦены = СсылкаНаОбъект.СуммаСУчетомРозничнойЦены;
СуммаНаСписание = СсылкаНаОбъект.СуммаНаСписание;


ТабДок = Новый ТабличныйДокумент;
Макет = ЭтотОбъект.ПолучитьМакет("МакетАкта");

// Шапка
ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
ОбластьШапка.Параметры.НомерДокумента = СсылкаНаОбъект.Номер;
ОбластьШапка.Параметры.ДатаДокумента = СсылкаНаОбъект.Дата;
ОбластьШапка.Параметры.Контрагент = СсылкаНаОбъект.Контрагент;
ОбластьШапка.Параметры.Склад = СсылкаНаОбъект.Склад;
ОбластьШапка.Параметры.ОприходованнаяСумма = СсылкаНаОбъект.ОприходованнаяСумма;
ОбластьШапка.Параметры.Договор = СсылкаНаОбъект.ДоговорКонтрагента;
ОбластьШапка.Параметры.СуммаРеализации = СсылкаНаОбъект.СуммаРеализации;
ОбластьШапка.Параметры.СуммаСУчетомРозничнойЦены = СсылкаНаОбъект.СуммаСУчетомРозничнойЦены;
ОбластьШапка.Параметры.СуммаНаСписание = СсылкаНаОбъект.СуммаНаСписание;

//Шапка.Параметры.Заполнить(ЭтотОбъект);
ТабДок.Вывести(ОбластьШапка);


//СсылкаНаОбъект.ИтогиРевизии - подразумевается что это Табличная часть с полями
//Сотрудник, СуммаУдержания
Для Каждого лкСтрока Из СсылкаНаОбъект.ИтогиРевизии Цикл

ОбластьСотрудники = Макет.ПолучитьОбласть("Сотрудники");
ОбластьСотрудники.Параметры.Сотрудник = лкСтрока.Сотрудник;
ОбластьСотрудники.Параметры.СуммаУдержания = лкСтрока.СуммаУдержания;
ТабДок.Вывести(ОбластьСотрудники);


КонецЦикла;


// Подвал
ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
ОбластьПодвал.Параметры.Комментарий = СсылкаНаОбъект.Комментарий;
ОбластьПодвал.Параметры.Ответственный = СсылкаНаОбъект.Ответственный;
//Подвал.Параметры.Заполнить(ЭтотОбъект);
ТабДок.Вывести(ОбластьПодвал);

ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Ложь;
ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
ТабДок.Показать();

КонецПроцедуры
Показать


{ВнешняяОбработка.АктУдержанияПоРезультатамРевизии.Форма.Форма.Форма(70,3)}: Процедура или функция с указанным именем не определена (Соообщить)
<<?>>Соообщить("Не выбран документ!"); (Проверка: Толстый клиент (обычное приложение))

Вот такая ошибка выходит
5. soft_wind 12.01.22 14:43 Сейчас в теме
(4) так это же Опечатка!
надо, что бы было

Сообщить
6. qzma 12.01.22 14:45 Сейчас в теме
исправил, теперь пишет

Не удалось сформировать внешнюю печатную форму!
Поле объекта не обнаружено (Сотрудник)
7. qzma 12.01.22 14:45 Сейчас в теме
Сотрудник - это реквизит табличной части "ИтогиРевизии"
8. qzma 12.01.22 14:49 Сейчас в теме
С Сотрудником решил вопрос, теперь пишет

Не удалось сформировать внешнюю печатную форму!
Значение не является значением объектного типа (Параметры)
9. qzma 12.01.22 16:16 Сейчас в теме
Вопрос решил, спасибо!
Была глупая ошибка в коде...
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Тестировщик 1С
Санкт-Петербург
зарплата от 60 000 руб. до 120 000 руб.
Полный день

Архитектор НСИ
Москва
зарплата от 250 000 руб. до 300 000 руб.
Полный день

Программист 1С
Пенза
зарплата от 120 руб. до 130 руб.
Полный день

Аналитик 1С
Санкт-Петербург
зарплата до 150 000 руб.
Полный день

Руководитель отдела разработки
Москва
зарплата от 200 000 руб. до 230 000 руб.
Полный день