Заимствованные процедуры в расширении конфигурации

1. 22 12.01.22 13:30 Сейчас в теме
Всем доброго дня! Коллеги, никто не сталкивался с проблемой выполнения процедур в расширении "ИзменениеИКонтроль"?
После обновления на версию платформы 1С:Предприятие 8.3.19.1467 в расширении перестали работать заимствованные процедуры с директивой «ИзменениеИКонтроль». Расширение подключается, при выполнении проверки возможности применения ошибок не выдает. При исполнении кода вместо процедуры в расширении выполняется процедура основной конфигурации. Пробовал удалить процедуру из расширения и снова её добавить – результат тот же. При этом процедура с директивой «Вместо» выполняется без проблем. В режиме 1С:Предприятие периодически возникает предупреждение об ошибке применения расширения: Ошибка применения модуля "ОбщийМодуль.ИнтерфейсДокументовЭДОКлиент.Модуль". Текст модуля для метода "СохранитьФайлыВыгрузкиЭД" изменился. Я вот в упор не вижу различий.
Расширение:
&ИзменениеИКонтроль("СохранитьФайлыВыгрузкиЭД")
Процедура ст_СохранитьФайлыВыгрузкиЭД(Знач СоответствиеФайловВыгрузки)

	Если СоответствиеФайловВыгрузки.Количество() = 0 Тогда
		Возврат;
	КонецЕсли;
	#Вставка
	СохраняемыеФайлы = Новый Массив;
	#КонецВставки
	Для Каждого КлючЗначениеФайлВыгрузки Из СоответствиеФайловВыгрузки Цикл

		ДанныеФайлаВыгрузки = КлючЗначениеФайлВыгрузки.Ключ;
		СсылкаНаДвоичныеДанныеФайла = КлючЗначениеФайлВыгрузки.Значение;
		#Удаление
		РаботаСФайламиБЭДКлиент.СохранитьФайлВыгрузкиКак(ДанныеФайлаВыгрузки, СсылкаНаДвоичныеДанныеФайла);
		#КонецУдаления
		#Вставка
		СтруктураДанных = Новый Структура;
		СтруктураДанных.Вставить("Имя", ДанныеФайлаВыгрузки.ИмяФайла);
		СтруктураДанных.Вставить("Адрес", СсылкаНаДвоичныеДанныеФайла);
		СтруктураДанных.Вставить("ЭлектронныйДокумент", ДанныеФайлаВыгрузки.ЭлектронныйДокумент);
		СохраняемыеФайлы.Добавить(СтруктураДанных); 
		#КонецВставки
	КонецЦикла;
	#Вставка
	ОперацииСФайламиЭДКОКлиент.СохранитьФайлы(СохраняемыеФайлы);
	#КонецВставки
КонецПроцедуры
Показать

И в основной конфигурации:
Процедура СохранитьФайлыВыгрузкиЭД(Знач СоответствиеФайловВыгрузки)
	
	Если СоответствиеФайловВыгрузки.Количество() = 0 Тогда
		Возврат;
	КонецЕсли;
	
	Для Каждого КлючЗначениеФайлВыгрузки Из СоответствиеФайловВыгрузки Цикл
		
		ДанныеФайлаВыгрузки = КлючЗначениеФайлВыгрузки.Ключ;
		СсылкаНаДвоичныеДанныеФайла = КлючЗначениеФайлВыгрузки.Значение;
		
		РаботаСФайламиБЭДКлиент.СохранитьФайлВыгрузкиКак(ДанныеФайлаВыгрузки, СсылкаНаДвоичныеДанныеФайла);
		
	КонецЦикла;
	
КонецПроцедуры
Показать
Найденные решения
5. Sashares 19 12.01.22 13:50 Сейчас в теме
(4) С ИзменениеИКонтроль есть 2 ошибки в платформе
https://bugboard.v8.1c.ru/error/000116716
https://bugboard.v8.1c.ru/error/000115244
Они исправлены в 8.3.21.1140. Можно проверить на ней, например, работает или нет.


Коваленко Игорь (1С, Москва) вчера 13:31

Исправление войдет в следующие версии 8.3.20, 8.3.19, 8.3.18, 8.3.17

https://partners.v8.1c.ru/forum/t/2037512/m/2038135
arabesca; 7OH; marv-ua; +3 Ответить
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. user1278383 12.01.22 13:36 Сейчас в теме
мне кажется дело в пустых строках. Везде, где вставка и удаление, отсутствует пустая строка
3. user1278383 12.01.22 13:42 Сейчас в теме
(2) т.е. должно быть так:
&ИзменениеИКонтроль("СохранитьФайлыВыгрузкиЭД")
Процедура ст_СохранитьФайлыВыгрузкиЭД(Знач СоответствиеФайловВыгрузки)

    Если СоответствиеФайловВыгрузки.Количество() = 0 Тогда
        Возврат;
    КонецЕсли;
	
    #Вставка
    СохраняемыеФайлы = Новый Массив;
    #КонецВставки
    Для Каждого КлючЗначениеФайлВыгрузки Из СоответствиеФайловВыгрузки Цикл

        ДанныеФайлаВыгрузки = КлючЗначениеФайлВыгрузки.Ключ;
        СсылкаНаДвоичныеДанныеФайла = КлючЗначениеФайлВыгрузки.Значение;
		
        #Удаление
        РаботаСФайламиБЭДКлиент.СохранитьФайлВыгрузкиКак(ДанныеФайлаВыгрузки, СсылкаНаДвоичныеДанныеФайла);
        #КонецУдаления
        #Вставка
        СтруктураДанных = Новый Структура;
        СтруктураДанных.Вставить("Имя", ДанныеФайлаВыгрузки.ИмяФайла);
        СтруктураДанных.Вставить("Адрес", СсылкаНаДвоичныеДанныеФайла);
        СтруктураДанных.Вставить("ЭлектронныйДокумент", ДанныеФайлаВыгрузки.ЭлектронныйДокумент);
        СохраняемыеФайлы.Добавить(СтруктураДанных); 
        #КонецВставки
		
    КонецЦикла;
	
    #Вставка
    ОперацииСФайламиЭДКОКлиент.СохранитьФайлы(СохраняемыеФайлы);
    #КонецВставки
КонецПроцедуры
Показать
4. Rackhanot 22 12.01.22 13:46 Сейчас в теме
(3) сделал так, но результат не изменился. Да и это было бы странно конечно, учитывая, что пустые строки кода игнорируются. В 1С ответили максимально просто: "Проблема видимо в вашей реализации"... Вот и не понятно теперь какая проблема в нашей реализации.
5. Sashares 19 12.01.22 13:50 Сейчас в теме
(4) С ИзменениеИКонтроль есть 2 ошибки в платформе
https://bugboard.v8.1c.ru/error/000116716
https://bugboard.v8.1c.ru/error/000115244
Они исправлены в 8.3.21.1140. Можно проверить на ней, например, работает или нет.


Коваленко Игорь (1С, Москва) вчера 13:31

Исправление войдет в следующие версии 8.3.20, 8.3.19, 8.3.18, 8.3.17

https://partners.v8.1c.ru/forum/t/2037512/m/2038135
arabesca; 7OH; marv-ua; +3 Ответить
6. Rackhanot 22 12.01.22 14:00 Сейчас в теме
(5) Спасибо! Только платформу обновили... Никогда такого не было и вот опять.
7. marv-ua 12.01.22 22:18 Сейчас в теме
(5)спасибо добрый человек
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Аналитик 1С
Санкт-Петербург
зарплата до 150 000 руб.
Полный день

Руководитель отдела разработки
Москва
зарплата от 200 000 руб. до 230 000 руб.
Полный день

Программист 1С
Москва
зарплата от 150 000 руб. до 150 000 руб.
Полный день

Консультант-аналитик 1С
Москва
зарплата от 100 000 руб. до 120 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству