Получить документы из метаданных за определенный период

1. 25.11.21 09:03 Сейчас в теме
Доброе утро. Обычные формы, сделал обработку, на форме есть выбор периода, и таблица, куда добавляется определенный список документов по нажатию кнопки "ДобавитьДокументы". По кнопке "ВыполнитьПоиск" идет обход метаданных и ищутся документы из табличной части обработки. Подскажите, пожалуйста, как мне получить список документов из каждого объекта метаданных за выбранный период?

МояДата = НачПер;

Пока МояДата < КонПер Цикл

Период = Новый Массив;
Период.Добавить(МояДата);
МояДата = КонецДня(МояДата)+1;

КонецЦикла;

Для Каждого Дата Из Период Цикл

Для Каждого Стр Из СписокДокументов Цикл

НайденныйДок = Метаданные.Документы[Стр.ИмяДок];

КонецЦикла;

КонецЦикла;
Показать
Найденные решения
2. acces969 118 25.11.21 09:11 Сейчас в теме
Запрос = Новый Запрос("ВЫБРАТЬ Документ.Ссылка ИЗ Документ."+ИмяДокумента+" КАК Документ ГДЕ *");
6. acces969 118 25.11.21 09:39 Сейчас в теме
(4)
 МассивИменДокументов = Новый Массив;
МассивЧастейЗапроса = Новый Массив;
Для Каждого ИмяДокумента Из МассивИменДокументов Цикл
МассивЧастейЗапроса.Добавить("ВЫБРАТЬ Ссылка ИЗ " + ИмяДокумента....);
КонецЦикла;
ТекстЗапроса = СтрСоединить(МассивЧастейЗапроса, Символы.ПС + "ОБЪЕДИНИТЬ ВСЕ" + Символы.ПС);
Запрос.Выполнить();
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. acces969 118 25.11.21 09:11 Сейчас в теме
Запрос = Новый Запрос("ВЫБРАТЬ Документ.Ссылка ИЗ Документ."+ИмяДокумента+" КАК Документ ГДЕ *");
5. user1619761 25.11.21 09:38 Сейчас в теме
3. acces969 118 25.11.21 09:12 Сейчас в теме
Если же вам нужны все отмеченные документы за один период времени, то правильнее делать это не в цикле, а одним запросом ко всем документам сразу.
4. user1619761 25.11.21 09:27 Сейчас в теме
(3) если я правильно понял, вы имеете ввиду одним запросом все нужные документы выбрать, но у меня список документов постоянно меняется, или вы имеете ввиду прописать условие ГДЕ Документ В ИЕРАРХИИ(&МассивДокументов) ?
6. acces969 118 25.11.21 09:39 Сейчас в теме
(4)
 МассивИменДокументов = Новый Массив;
МассивЧастейЗапроса = Новый Массив;
Для Каждого ИмяДокумента Из МассивИменДокументов Цикл
МассивЧастейЗапроса.Добавить("ВЫБРАТЬ Ссылка ИЗ " + ИмяДокумента....);
КонецЦикла;
ТекстЗапроса = СтрСоединить(МассивЧастейЗапроса, Символы.ПС + "ОБЪЕДИНИТЬ ВСЕ" + Символы.ПС);
Запрос.Выполнить();
7. user1619761 25.11.21 09:40 Сейчас в теме
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Программист 1С
Ижевск
зарплата от 120 000 руб. до 160 000 руб.
Временный (на проект)

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству

Разработчик 1С
Москва
зарплата от 150 000 руб.
Полный день

Разработчик 1С
Москва
зарплата от 150 000 руб.
Полный день

Преподаватель 1С
Санкт-Петербург
зарплата от 100 000 руб. до 120 000 руб.
Временный (на проект)