Заполнение документа ОперацияБух из экселя

1. 24.11.21 20:52 Сейчас в теме
Всем привет. ХЕЛП.
Учусь, пишу обработку для заполнения данных в документ ОперацияБух. Суть написал обработку, она выполняется в коде прослеживается что и основное средство определилось и счет, но документ на выходе пустой, не пойму что не так
Прикрепленные файлы:
Операция БУх.epf
Найденные решения
3. demonsed97 24.11.21 21:41 Сейчас в теме
во вроде разобрался тут без условий и тд, но робит
ДокОперация = Документы.ОперацияБух.СоздатьДокумент();
ДатаДокумента = ТекущаяДата();

Организация =  Справочники.Организации.НайтиПоНаименованию("ВОДОКАНАЛ-МЫТИЩИ АО");

Содержание = "Тест" ;
Комментарий = "Тестовый";
ДокОперация.Дата = ДатаДокумента;
ДокОперация.Организация = Организация;
//ДокОперация.Ответственный = Ответственный;
ДокОперация.Содержание = Содержание;
ДокОперация.Комментарий = Комментарий;
ДокОперация.Записать();
ДокОперацияСсылка = ДокОперация.Ссылка;

РегХозрасчетный = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей();
РегХозрасчетный.Отбор.Регистратор.Значение = ДокОперацияСсылка;
Для Каждого СтрокаДанных из Объект.Данные Цикл

КодОС = СтрокаДанных.Инв;
ОсновноеСредство = Справочники.ОсновныеСредства.НайтиПоКоду(КодОС);
РегЗапись = РегХозрасчетный.Добавить();
    РегЗапись.Период = ДатаДокумента;
    РегЗапись.Регистратор = ДокОперацияСсылка;
    РегЗапись.Организация = Организация;
    РегЗапись.Содержание  = "Тестовые проводки";
    РегЗапись.СчетДт = ПланыСчетов.Хозрасчетный.НайтиПоНаименованию("Аренда ОС");

    //БухгалтерскийУчет.УстановитьСубконто(РегЗапись.СчетДт, РегЗапись.СубконтоДт, "Контрагенты", Контрагент);
    БухгалтерскийУчет.УстановитьСубконто(РегЗапись.СчетДт, РегЗапись.СубконтоДт, "ОсновныеСредства", ОсновноеСредство);
    РегЗапись.Сумма = 8000000;
     КонецЦикла; 
	 РегХозрасчетный.Записать();
Показать
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. demonsed97 24.11.21 21:21 Сейчас в теме
Привел к другому виду, все ровно мертво(((

ДокументОперация= Документы.ОперацияБух.СоздатьДокумент();
Дата =  ТекущаяДата();
Организация = Справочники.Организации.НайтиПоНаименованию("ВОДОКАНАЛ-МЫТИЩИ АО");
    ДокументОперация.Организация = Организация;
    ДокументОперация.Дата = Дата;
    
    ДокументОперация.Записать();
	    
    ОперацияСсылка = ДокументОперация.Ссылка;
	
    РегХозрасчетный = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей();
    РегХозрасчетный.Отбор.Регистратор.Установить(ОперацияСсылка);
	
	Для Каждого СтрокаДанных из Объект.Данные Цикл


 
 		ОсновноеСредство = Справочники.ОсновныеСредства.НайтиПоКоду(СтрокаДанных.Инв);
		Если ЗначениеЗаполнено(ОсновноеСредство) тогда;
		
    	РегЗапись = РегХозрасчетный.Добавить();
		РегЗапись.Период = Дата;
		РегЗапись.Регистратор = ОперацияСсылка;
		РегЗапись.Организация = Организация;
		РегЗапись.СчетДт = ПланыСчетов.Хозрасчетный.НайтиПоНаименованию("Аренда ОС");
		БухгалтерскийУчет.УстановитьСубконто(РегЗапись.СчетДт, РегЗапись.СубконтоДт, "ОсновныеСредства", ОсновноеСредство);


Иначе
	Сообщить ("Ошибка");
	КонецЕсли
  КонецЦикла;  

    ДокументОперация.Записать();
	Сообщить("Запись, создана" + ОперацияСсылка);
Показать
3. demonsed97 24.11.21 21:41 Сейчас в теме
во вроде разобрался тут без условий и тд, но робит
ДокОперация = Документы.ОперацияБух.СоздатьДокумент();
ДатаДокумента = ТекущаяДата();

Организация =  Справочники.Организации.НайтиПоНаименованию("ВОДОКАНАЛ-МЫТИЩИ АО");

Содержание = "Тест" ;
Комментарий = "Тестовый";
ДокОперация.Дата = ДатаДокумента;
ДокОперация.Организация = Организация;
//ДокОперация.Ответственный = Ответственный;
ДокОперация.Содержание = Содержание;
ДокОперация.Комментарий = Комментарий;
ДокОперация.Записать();
ДокОперацияСсылка = ДокОперация.Ссылка;

РегХозрасчетный = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей();
РегХозрасчетный.Отбор.Регистратор.Значение = ДокОперацияСсылка;
Для Каждого СтрокаДанных из Объект.Данные Цикл

КодОС = СтрокаДанных.Инв;
ОсновноеСредство = Справочники.ОсновныеСредства.НайтиПоКоду(КодОС);
РегЗапись = РегХозрасчетный.Добавить();
    РегЗапись.Период = ДатаДокумента;
    РегЗапись.Регистратор = ДокОперацияСсылка;
    РегЗапись.Организация = Организация;
    РегЗапись.Содержание  = "Тестовые проводки";
    РегЗапись.СчетДт = ПланыСчетов.Хозрасчетный.НайтиПоНаименованию("Аренда ОС");

    //БухгалтерскийУчет.УстановитьСубконто(РегЗапись.СчетДт, РегЗапись.СубконтоДт, "Контрагенты", Контрагент);
    БухгалтерскийУчет.УстановитьСубконто(РегЗапись.СчетДт, РегЗапись.СубконтоДт, "ОсновныеСредства", ОсновноеСредство);
    РегЗапись.Сумма = 8000000;
     КонецЦикла; 
	 РегХозрасчетный.Записать();
Показать
4. smirnova_a 25.11.21 16:57 Сейчас в теме
набор записей нужно сначала прочитать, перед тем как заполнять, но вам скорее сюда:

https://forum.infostart.ru/forum9/topic9794/
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Тестировщик 1С
Санкт-Петербург
зарплата от 60 000 руб. до 120 000 руб.
Полный день

Архитектор НСИ
Москва
зарплата от 250 000 руб. до 300 000 руб.
Полный день

Аналитик 1С
Санкт-Петербург
зарплата до 150 000 руб.
Полный день

Программист 1С
Москва
зарплата от 150 000 руб. до 220 000 руб.
Полный день

Руководитель отдела разработки
Москва
зарплата от 200 000 руб. до 230 000 руб.
Полный день