Сохранение настроек внешней обработки

1. 24.11.21 11:58 Сейчас в теме
Добрый день. Подскажите пож-та как сохранить значения реквизитов внешней обработки, чтобы при открытии они загружались такими как были сохранены в последний раз. При этом это не должно быть зависимо от пользователя, любой может открыть обработку с сохраненными уже реквизитами.
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. dmbarchenkov 24.11.21 12:04 Сейчас в теме
(1) Пример:
&НаСервере
Процедура ПриСохраненииДанныхВНастройкахНаСервере(Настройки)
	
	Настройки.Вставить("НастройкиСКД", Компоновщик.Настройки);
	
КонецПроцедуры

&НаСервере
Процедура ПриЗагрузкеДанныхИзНастроекНаСервере(Настройки)
	
	НастройкиСКД = Настройки.Получить("НастройкиСКД");
	
	Если НЕ НастройкиСКД = НЕОПРЕДЕЛЕНО Тогда
		Компоновщик.ЗагрузитьНастройки(НастройкиСКД);
	КонецЕсли;
		
КонецПроцедуры
Показать
3. ghostrid3r 24.11.21 12:21 Сейчас в теме
(2) по подробнее можно? это надо в схему компоновки добавить?
Чем скд поможет заполнить реквизиты обработки, например, номера колонок?
4. mushdaj 24.11.21 12:24 Сейчас в теме
у формы есть настройка АвтоматическоеСохранениеДанныхВНастройках поставьте "использовать" и появится колонка у реквизитов, нужно отметить какие сохранять
5. ghostrid3r 24.11.21 12:25 Сейчас в теме
(4) а если кеш почистят, то эти же настройки слетят?
6. mushdaj 24.11.21 12:51 Сейчас в теме
(5) да слетит если кэш почистить или ид обработки сменить. Чтобы не слетала зависит от конфы, надо найти место для хранения например в старых БСП был регистр сохраненные настройки, в новых конфах можно попробовать как вариант хранить в регистре доп сведений.
7. SAShikutkin 3 24.11.21 14:16 Сейчас в теме
ХранилищеОбщихНастроек
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Администратор 1C
Москва
зарплата до 110 000 руб.
Полный день

Консультант-аналитик 1С
Москва
зарплата до 180 000 руб.
Полный день

Программист 1С
Москва
зарплата до 160 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству