Как извлечь набор картинок из библиотеки картинок

1. 624 24.11.21 06:44 Сейчас в теме
Всем привет! В новых конфигурация картинки могут храниться набором, по крайней мере встроенные картинки хранятся набором и есть возможность выгрузить их в файл из конфигуратора и сохраняются они как zip-архив. Вопрос: можно ли выгрузить все картинки набора программно? Или по отдельности или архивом, без разницы. Неужели предусмотрели возможность выгрузить из конфигуратора, но не предусмотрели получение набора программно? Заранее спасибо!
Найденные решения
7. VladimirB 10 24.11.21 09:57 Сейчас в теме
(1) Вот это похожде тогда?

   Для каждого ОбщКартинка Из Метаданные.ОбщиеКартинки Цикл 
        Картинка = БиблиотекаКартинок[ОбщКартинка.Имя];
        ИмяФайла = "E:\Иконки\1c\"+ОбщКартинка.Имя+".zip";
        Картинка.ПолучитьДвоичныеДанные(Истина).Записать(ИмяФайла);
    КонецЦикла;
frkbvfnjh; +1 Ответить
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
5. spacecraft 24.11.21 09:10 Сейчас в теме
(1) выгрузить конфигурацию в файлы и там искать в CommonPictures.
2. VladimirB 10 24.11.21 08:28 Сейчас в теме
(1)Не это имел ввиду?


 Для каждого ОбщКартинка Из Метаданные.ОбщиеКартинки Цикл 
        Картинка = БиблиотекаКартинок[ОбщКартинка.Имя];
        ИмяФайла = "C:\"+ОбщКартинка.Имя+".jpg";
        Картинка.Записать(ИмяФайла);
    КонецЦикла;
3. frkbvfnjh 624 24.11.21 08:45 Сейчас в теме
(2) Нет. В этом случае извлекается только картинка для текущего масштаба форм 1С:Предприятия, а нужно извлечь весь набор для всех масштабов
4. user1671936 24.11.21 08:57 Сейчас в теме
(3) можно попробовать все масштабы закинуть в массив, и обходом по массиву сохранять картинки. Навскидку:

МассивМасштабов = Новый Массив;
МассивМасштабов.Добавить("Масштаб1"); И тд

ЗЫ Но я не знаю, есть ли поле "Мастштаб" у ОбщКартинка.
6. frkbvfnjh 624 24.11.21 09:22 Сейчас в теме
7. VladimirB 10 24.11.21 09:57 Сейчас в теме
(1) Вот это похожде тогда?

   Для каждого ОбщКартинка Из Метаданные.ОбщиеКартинки Цикл 
        Картинка = БиблиотекаКартинок[ОбщКартинка.Имя];
        ИмяФайла = "E:\Иконки\1c\"+ОбщКартинка.Имя+".zip";
        Картинка.ПолучитьДвоичныеДанные(Истина).Записать(ИмяФайла);
    КонецЦикла;
frkbvfnjh; +1 Ответить
8. frkbvfnjh 624 24.11.21 10:32 Сейчас в теме
(7) Аааааа, блиииин, вот я затупил, там же параметры появились у метода ПолучитьДвоичныеДанные. Да все верно, так должно работать, спасибо!
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Администратор 1C
Москва
зарплата до 110 000 руб.
Полный день

Консультант-аналитик 1С
Москва
зарплата до 180 000 руб.
Полный день

Программист 1С
Москва
зарплата до 160 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству